Gwibber apparently displays Facebook updates without being authorized

Bug #1161783 reported by Hansen on 2013-03-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Friends
High
Robert Bruce Park
Gwibber
Undecided
Unassigned

Bug Description

Installing new Gwibber in raring beta:
Deleting facebook account to add new, testing testcase http://packages.qa.ubuntu.com/qatracker/testcases/1507/info
Gwibber apparently displays Facebook updates without being authorized.

Hansen (moteprime) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1161783

tags: added: package-qa-testing
Nicholas Skaggs (nskaggs) wrote :

Hansen, did you previously have an active facebook account before installing gwibber? Perhaps this is a cache thing -- was it showing new updates?

tags: added: friends-rewrite
Hansen (moteprime) wrote :

Actually I'm a bit unsure. I had the my facebook account in the online accounts.
It went like this:

Installed Gwibber according to instruction in the test.
Removed my Facebook account from the "Online Accounts".
Started Gwibber.

I'll try to figure out if the updates are old or new.

Hansen (moteprime) wrote :

The messages are not up to date, so they must be cached from the old Gwibber client.

Robert Bruce Park (robru) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

I know we recently had a situation where we weren't deleting messages from deleted UOA accounts, but I was pretty sure we had resolved that. Please follow these steps in order to bring your computer into a fresh slate, and then describe in as much detail as you can what you had to do in order to reproduce this:

1. Exit gwibber.

2. Open a terminal (Ctrl+Alt+T)

3. Type these commands:

killall friends-service
killall friends-dispatcher
rm -rf ~/.local/share/resources/com.canonical.Friends.* ~/.cache/friends/

4. Now go into UOA, add your facebook account, restart gwibber, and attempt to reproduce the bug please.

Thanks!

Changed in friends:
status: New → Incomplete
Changed in gwibber:
status: New → Invalid
Changed in friends:
importance: Undecided → High
assignee: nobody → Robert Bruce Park (robru)
Hansen (moteprime) wrote :

Tried to reproduce by:
Kill the services described, remove the cache: "rm -rf ~/.local/share/resources/com.canonical.Friends.* ~/.cache/friends/". Establish a UOA* facebook account.
start Gwibber, post are there. "End Process" Gwibber and remove my UOA Facebook. Gwibber does not display facebook messages after being started again. (only twitter's)
Any other way to try reproducing?

*Ubuntu Online Account

Robert Bruce Park (robru) wrote :

Hmmm, I dunno. It seems intermittent then.

Or perhaps friends-service wasn't running when the account was deleted. That might do it... try this:

1. Exit gwibber

2. Open a terminal:

3. type these commands:

killall friends-service
killall friends-dispatcher

4. Go into UOA, delete your account, then restart gwibber.

Hansen (moteprime) wrote :

Nope. Doesn't work either.
I can't make it do it again, but i am having a hard time making it show the Facebook updates at all. Half the times i'm trying they don't show up at at all. And it's a inconsistent, giving me some occasional popup notification bobbles but no updates in Gwibber timeline.

It did this a couple of times:
mads@Raring-ThinkPad-Edge-E130:~$ killall friends-dispatcher
friends-dispatcher: no process found

Robert Bruce Park (robru) wrote :

Yeah, that's normal, because friends-dispatcher doesn't run all the time, it is just invoked periodically in response to various events.

Can you update to the latest friends-app? Ken fixed a bug recently that was stopping it from displaying new messages on first run. So I think most likely the messages were there all along but they just might not have been visible.

Hansen (moteprime) wrote :

I quit Gwiber, updated (through updateman.), stopped the services, rm the cache and the UOA acc.
Started Gwibber, it was clean. Quit Gwibber, made twitter and FB acc, restarted Gwibber. All my messages was there.
Works like supposed to?

Robert Bruce Park (robru) wrote :

Sounds great! Thanks for taking the time to test this for us. Please feel free to report any new bugs you may find in the future ;-)

Changed in friends:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers