Gweled produces no sound without pulseaudio (with alsa only)

Bug #774700 reported by Igor Tarasov on 2011-05-01
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Gweled
Low
Wesley Ellis
libmikmod
New
Undecided
Unassigned

Bug Description

It's xubuntu 11.04, using gweled 0.9.1, I had to remove pulseaudio due to performance problems. Now I have alsa only, and all software works fine, including games. However, gweled does not produce any sound, when I start in in conslole, it says: Audio driver choosen: No Sound.

Related branches

description: updated
Changed in gweled:
status: New → Confirmed
importance: Undecided → Low
jony121 (jony121) wrote :

This is what I get when I run from terminal: Audio driver choosen: No Sound
I have standard Ubuntu 11.04 64bit install. I have not touched pulseaudio or sound server settings.
Next step is to see how it detects the sound server and see if we can override.

Please explain what actions you took to confirm your removing pulseaudio was related to this problem?

Igor Tarasov (tarasov-igor) wrote :

I've tried installing/removing pulseaudio.

jony121 (jony121) wrote :

Oh I see. It sounded like it worked before but then you removed pulseaudio and it stopped working.

In any case this was the only place I found the same terminal output. I have marked that this bug affects me also.

What audio card do you use?

Igor Tarasov (tarasov-igor) wrote :

I removed pulseaudio from the very start (since it behaved badly with skype). After that I've installed gweled. There was no sound. Then I installed something that had pulseaudio in recommendations, so that it was installed also, and sound in gweled appeared back. But since pulseaudio still does not behave well enough for this aged system, I've removed it and no sound from gweled again.

My sound card is Creative Sound Blaster Live 5.1.

Wesley Ellis (ellisgen) on 2011-08-12
Changed in gweled:
status: Confirmed → In Progress
assignee: nobody → Wesley Ellis (ellisgen)
status: In Progress → Fix Committed
Wesley Ellis (ellisgen) wrote :

Still trying to figure out how all this launchpad stuff works.

I have built what I'll call a beta of gweled using libcanberra. I would appreciate it if TGR could download and test this out from my PPA: https://code.launchpad.net/~ellisgen/+archive/ppa

The instructions for adding the PPA are on that webpage.

Please let me know if this fixes audio on a system without pulseaudio (ALSA only).

Thanks,
Wes

Wesley Ellis (ellisgen) wrote :

Well, I guess I don't quite have the recipe right for launchpad to build a package yet. The build failed on launchpad.

Wesley Ellis (ellisgen) wrote :

Looks like I finally got it to build, at least for natty amd64. The others have yet to be seen. Hopefully they are built by the time you read this and you can test it out for me. Thanks.

Igor Tarasov (tarasov-igor) wrote :

No sound still. Console output looks like

$ gweled
Initializing canberra-gtk context for display :3 on screen 0
libcanberra playing sound autonom.ogg [file /usr/share/sounds/gweled/autonom.ogg]: Sound disabled
libcanberra playing sound click.ogg [file: /usr/share/sounds/gweled/click.ogg]; Sound disabled
libcanberra playing sound swap.ogg [file: /usr/share/sounds/gweled/swap.ogg]; Sound disabled
libcanberra playing sound click.ogg [file: /usr/share/sounds/gweled/click.ogg]; Sound disabled
libcanberra playing sound swap.ogg [file: /usr/share/sounds/gweled/swap.ogg]; Sound disabled

...and so on and on.

Wesley Ellis (ellisgen) wrote :

Could you check to see that you have libcanberra-alsa installed, and if not install it? I don't know how to check the users system for the default sound server and set dependencies based on that. Sorry.

Wesley Ellis (ellisgen) wrote :

I just looked and I have libcanberra-alsa.so in /usr/lib. I don't know which package installed the libs, but you should be able to get sound working by installing "libcanberra0" and "libcanberra-gtk0" . If that doesn't work, try installing the respective dev packages and let me know if that works.

Wesley Ellis (ellisgen) wrote :

Even better, I've think I see how to add package dependencies, so I have. It should be building in Launchpad now and available as an update through software center to you shortly.

Wesley Ellis (ellisgen) wrote :

Actually I have exceeded todays quota for Natty. So it won't be built until tomorrow. So if you could manually install libcanbera0 and libcanberra-gtk0, I would appreciate knowing if that fixes your bug.

Igor Tarasov (tarasov-igor) wrote :

Here is what I have:

$ find /usr/lib/ -name "*canberra*"
/usr/lib/libcanberra.so.0
/usr/lib/libcanberra-0.28
/usr/lib/libcanberra-0.28/libcanberra-alsa.so
/usr/lib/libcanberra-gtk.so.0
/usr/lib/libcanberra.so.0.2.5
/usr/lib/libcanberra-gtk.so.0.1.8
/usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so

And here is what I get:

$ canberra-gtk-play -f /usr/share/sounds/gweled/swap.ogg
Failed to play sound: Sound disabled

I think that this bug is canberra-related now?

Wesley Ellis (ellisgen) wrote :

Okay, I can't say for certain that it is a bug with libcanberra just yet. Gnome Games uses canberra for sound events as well. So, if you could install one or two of their games and test it out, we will know if it's Gweled or Canberra.

You can find a list of the games here
http://live.gnome.org/GnomeGames

Igor Tarasov (tarasov-igor) wrote :

Okay, I was finally able to make gweled producing sounds, but only in gnome session. But it keeps reporting me "Sound disabled" in LXDE session (Lubuntu) .

Wesley Ellis (ellisgen) wrote :

Okay, so if it works in gnome session, but not LXDE, then I'm gona say this is a bug with libcanberra. We should push this bug upstream to get it fixed.

Anton Yarth (llancelot7) wrote :

This bug in libmikmod, because libmikmod not support alsa greater than 0.5. With pulseaudio mikmod uses oss output or other emulated by pulseaudio. This solves by replacing libmikmod by SDL+SDL_mixer, because SDL_mixer use libmikmod, but use own sound output driver.
Patched version with SDL_mixer in my git: https://github.com/Marisa-Chan/gweled-sdl_mixer

Andrew (keen101) wrote :

Running Gweled from a terminal produces this error:

"Audio driver choosen: No Sound"

This is on a default install of Ubuntu 12.04 in 2013, with all updates installed.

Mark Wallace (rmarkwallace) wrote :

I can't get it working either using Ubuntu Mate 1.6 with latest LTS release of Ubuntu.

Dana Lee Ling (dleeling) wrote :

I get the same message as #19 in Lubuntu 13.10.
Packages installed that may relate:
alsa-base 1.0.25+dfsg-0ubuntu4
libcanberra-gtk0 0.30-0ubuntu2
libcanberra-pulse 0.30-0ubuntu2
libmikmod2 3.1.12-5
libsdl-mixer1.2 1.2.12-7ubuntu1
pulseaudio 1:4.0-0ubuntu6

thom (tsk) wrote :

gweled in Lubuntu 14.04 LTS (without pulseaudio) and Ubuntu 12.04 LTS (with pulseaudio) : still no sound.

Des Nerger (ixuta) wrote :

I had experienced a similar issue in Linux Mint 17.1
But I did have pulseaudio
It turned out that the cause was lack of 'libasound.so' (even though 'libasound.so.2' and 'libasound.so.2.0.0' were in place)
I've installed 'libasound2-dev' and this has helped

miguelquiros (mquiros) wrote :

Following the idea in comment #24, I have just made a simlynk libasound.so -> libasound.so.2 and this solved the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers