Graphics corruption (mixed up texture memory) makes game unusable

Bug #1897712 reported by Joseph Maillardet
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Gweled
Critical
Daniele Napolitano
gweled (Debian)
Fix Released
Unknown
gweled (Ubuntu)
High
Daniele Napolitano

Bug Description

Start a new game, the jewel is replaced by ugly "graphical buffer noise".

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: gweled 0.9.1-7
ProcVersionSignature: Ubuntu 5.8.0-19.20-generic 5.8.8
Uname: Linux 5.8.0-19-generic x86_64
ApportVersion: 2.20.11-0ubuntu48
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Tue Sep 29 11:47:30 2020
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gweled
UpgradeStatus: Upgraded to groovy on 2020-06-09 (112 days ago)

Revision history for this message
Joseph Maillardet (jokx) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Please:

1. Attach a photo of the problem.

2. Run these commands after the problem happens next:

   lspci -kv > lspci.txt
   journalctl -b0 > journal.txt

   and attach the resulting text files here.

Changed in gweled (Ubuntu):
status: New → Incomplete
Changed in mutter (Ubuntu):
status: New → Incomplete
Revision history for this message
MV (mvidal) wrote :

Same problem since 20.10 upgrade this morning :

Revision history for this message
MV (mvidal) wrote :
Revision history for this message
MV (mvidal) wrote :
tags: added: nvidia
no longer affects: mutter (Ubuntu)
Changed in gweled (Ubuntu):
status: Incomplete → New
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thanks. It looks like the game is using texture memory from the wrong textures, but same process.

Since I see texture corruption in the same game with Intel graphics it looks very likely to be a bug in the game itself.

Changed in gweled (Ubuntu):
status: New → Confirmed
Changed in gweled (Debian):
status: Unknown → New
Revision history for this message
Keith Trudell (ackack) wrote (last edit ):

seen in current version of Ubuntu. Same visual garble.

Ubuntu version: 21.04
Gweled version: 0.9.1

summary: - Ugly image output make game unusable
+ Graphics corruption (mixed up texture memory) makes game unusable
Changed in gweled:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → Daniele Napolitano (dnax88)
Revision history for this message
Daniele Napolitano (dnax88) wrote (last edit ):

Bug fixed in commit: https://bazaar.launchpad.net/~dnax88/gweled/trunk/revision/109

It was SVGs not standard with rsvg more strict.

Changed in gweled (Ubuntu):
assignee: nobody → Daniele Napolitano (dnax88)
status: Confirmed → Fix Committed
status: Fix Committed → Triaged
importance: Undecided → High
Revision history for this message
William Vincenti (williamvincenti-comcast) wrote :

Starts and runs with good graphics now however, it's not closing. (Arch Linux).
No errors in journal (my journal is set to low log level so may be missing error messages).
It eventually times out not responding and gets the black popup message to close application.
This is in Openbox. Thank you.

Revision history for this message
Daniele Napolitano (dnax88) wrote :

@William Thank you for testing! Unfortunately I can't reproduce the bug in my system. Can you open Gweled from the console and attach here what is written during the bug?

Thank you in advance.

Revision history for this message
William Vincenti (williamvincenti-comcast) wrote (last edit ): Re: [Bug 1897712] Re: Graphics corruption (mixed up texture memory) makes game unusable

Ok that it was irreproducible on your system I suspected an error in my configs. So far, resetting Depends back to gtk2 and rebuilding seems to resolve the exit/save NO-YES hang. Just to note, that running it from console when it hanged on close never reported anything in the terminal beyond this:
% gweled
Audio driver choosen: ALSA
It would stay there and not return to prompt without [Ctrl]C.
The problem on my end appears to have been result of building it with Depends set to gtk3 (which I'm not familiar with how to tackle that). Thank you for the package! I have nothing further, it works great!

Changed in gweled (Debian):
status: New → Fix Released
Stephen Kitt (steve-sk2)
Changed in gweled (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Revision history for this message
William Vincenti (williamvincenti-comcast) wrote :

The game works without graphic corruption (/in Arch Linux/) but hangs
when trying to close it most times and I have to use xkill to close it,
or wait for "this application isn't responding" to close.

(/the popup close/save window turns gray and it nor the game respond to
anymore keyboard requests - running it from terminal shows no errors/).

On 10/30/21 09:34, Stephen Kitt wrote:
> ** Changed in: gweled (Ubuntu)
> Status: Triaged => Fix Committed
>
> ** Changed in: gweled (Ubuntu)
> Status: Fix Committed => Fix Released
>

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

William, please open a new bug for the hangs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.