Segmentation fault on startup

Bug #1741664 reported by Jeff VanDyke on 2018-01-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gweled
High
Unassigned
gweled (Debian)
Fix Released
Unknown

Bug Description

App failed to start, and on starting from the command line, I get this output:

--------------------

$ gweled

(gweled:2023): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Operation not supported
Segmentation fault

--------------------

System Info:

Manjaro GNOME 3, pretty fresh install
Linux 4.15.0-1-MANJARO #1 SMP PREEMPT Thu Jan 4 03:33:19 UTC 2018 x86_64 GNU/Linux

Thanks for your effort!

Related branches

Ben Zaborowsky (col-march) wrote :

I get the same error and Gweled never starts.

System info:

Fedora 27
Linux 4.14.11-300.fc27.x86_64 #1 SMP Wed Jan 3 13:52:28 UTC 2018 x86_64 GNU/Linux

Changed in gweled:
status: New → Confirmed
importance: Undecided → High

It happens with librsvg > -2:2.40.19-1 fails with segfualt, same error as others. Here is the segfault info:
[code]gweled[pid#]: segfault at 1f8 ip 00007f8ea91ca901 sp 00007ffd45cb8cb0 error 4 in libc-2.26.so[7f8ea9148000+1ae000][/code]

Arch Linux 4.14.13-1-ARCH #1 SMP PREEMPT Wed Jan 10 11:14:50 UTC 2018 x86_64 GNU/Linux

Changed in gweled (Debian):
status: Unknown → Incomplete
Johannes Sasongko (sjohannes) wrote :

This is caused by a librsvg bug [1], but it also exposes a bug in Gweled's error handling (GError pointer must be set to null before being used). A patch that works around the librsvg bug and fixes the error handling is attached.

[1] https://gitlab.gnome.org/GNOME/librsvg/issues/198

I can confirm the patch works - I wasn't able to patch the package as I have something messed up in my makepkg.conf that prevented makepkg from finding the correct file to patch however, I manually edited the lines in <[build directory]/gweled/src/gweled-0.9.1/src/sge_utils.c> according to the patch and reran makepkg (without the edited patch info) and have am once again playing gweled :)

4.14.15-1-ARCH #1 SMP PREEMPT Tue Jan 23 21:49:25 UTC 2018 x86_64 GNU/Linux
gweled 0.9.1-4
librsvg 2:2.42.2-1

Thank you Johannes

Johannes Sasongko (sjohannes) wrote :

This is a more defensive patch that should work regardless of how librsvg chooses to proceed -- whether it allows only path, only URI, or both.

Eli Schwartz (eschwartz) wrote :
Changed in gweled (Debian):
status: Incomplete → Confirmed
Johannes Sasongko (sjohannes) wrote :

The librsvg bug that triggers this has been marked fixed and will be in librsvg 2.42.3. Once that reaches users, they should see this issue disappear.

My patch still stands because it allows Gweled to run with the buggy librsvg versions, and it also fixes a bug in how Gweled handles librsvg error conditions.

Stephen Kitt (steve-sk2) on 2018-03-19
Changed in gweled (Debian):
status: Confirmed → Unknown
Changed in gweled (Debian):
status: Unknown → Fix Released
Eli Schwartz (eschwartz) on 2018-03-23
Changed in gweled:
status: Confirmed → Fix Committed
Jeff VanDyke (jv789521) wrote :

Seems to be working in Manjaro/Arch, I can't confirm Debian; I'm assuming if it works there, this issue can be closed, but I can't figure out how to close it :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.