Segmentation fault on startup

Bug #1741664 reported by Jeff VanDyke on 2018-01-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gweled
High
Unassigned

Bug Description

App failed to start, and on starting from the command line, I get this output:

--------------------

$ gweled

(gweled:2023): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Operation not supported
Segmentation fault

--------------------

System Info:

Manjaro GNOME 3, pretty fresh install
Linux 4.15.0-1-MANJARO #1 SMP PREEMPT Thu Jan 4 03:33:19 UTC 2018 x86_64 GNU/Linux

Thanks for your effort!

Ben Zaborowsky (col-march) wrote :

I get the same error and Gweled never starts.

System info:

Fedora 27
Linux 4.14.11-300.fc27.x86_64 #1 SMP Wed Jan 3 13:52:28 UTC 2018 x86_64 GNU/Linux

Changed in gweled:
status: New → Confirmed
importance: Undecided → High

It happens with librsvg > -2:2.40.19-1 fails with segfualt, same error as others. Here is the segfault info:
[code]gweled[pid#]: segfault at 1f8 ip 00007f8ea91ca901 sp 00007ffd45cb8cb0 error 4 in libc-2.26.so[7f8ea9148000+1ae000][/code]

Arch Linux 4.14.13-1-ARCH #1 SMP PREEMPT Wed Jan 10 11:14:50 UTC 2018 x86_64 GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers