[Lucid, Maverick, Natty or perhaps Ocelot] Not associated the use_underline and mnemonic_widget property with real GTK vidgets for some labels, this is resulting little problem with using Gufw for Orca screen reader

Bug #765899 reported by Attila Hammer on 2011-04-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gufw
Undecided
costales
gui-ufw (Ubuntu)
Undecided
Unassigned

Bug Description

Dear Developers,

Sorry my possible little bad english.
I am a visual impaired user and developer, and I using Orca Screen Reader.
Now, for example the Lucid packaged Gufw release, with some GTK Vidgets label description not associated the mnemonic_widget and use_underline property with real vidget.
For example, Gufw main window have an incoming: label, but this label not associated the incoming rule related combo box vidget.
What producing this problem?
Sighted usage nothing, but for example if a visual impaired user using Gufw, Orca screen reader not spokening the incoming and outgoing combo boxes labels, only spokening the actual selected combo box element when the user move the combo box with TAB or SHIFT+TAB key. For example, if the user landing the out going combo box, and the enabled combo box element is selected, Orca Screen reader only spokening "enabled" text, but not spokening the combo box label description. Right working method for screen reader usage is following, if the user landing for example the outgoing combo box:
"Outgoing: enabled"
So, when a label associated the mnemonic_widget with an another control, Orca Screen reader spokening both the label, and the another associated control related informations.

I maked a short example patch with my Lucid system, this patch only fix the incoming and outgoing combo box labels related issue.
Unfortunately, Glade not full possible handling with Orca, but if you tell what labels need associating an another control, I will be try doing this work.
When I applied this patch, Orca screen reader wonderful spokening both the labels and real combo box related informations.

What Ubuntu release possible fixing this type bug?

Attila

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gufw 10.04.5-0ubuntu0.1 [modified: usr/share/gufw/glade/gufw.glade]
ProcVersionSignature: Ubuntu 2.6.32-30.59-generic 2.6.32.29+drm33.13
Uname: Linux 2.6.32-30-generic x86_64
Architecture: amd64
Date: Tue Apr 19 15:00:21 2011
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=hu_HU:en
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
SourcePackage: gui-ufw

costales (costales) wrote :

Hi! I'll study this issue and I'll try fix for Ubuntu 11.10 ;)
Best regards and thanks!

Changed in gui-ufw (Ubuntu):
status: New → Invalid

Thank you the future fix.
When you fixing this issue in Ubuntu 11.10 for labels related, possible
add an _ character for importanter labels with you associated an another
control with mnemonics_vidget property (creating a mnemonic letter for
this labels)?
Now, for example not have mnemonic letters for incoming and outgoing
labels, perhaps have more labels with true this for example the
preferences dialog, I don't looked detailed the glade file.
For example, the incoming label text need changing with _Incoming: text
if you want associate i letter with mnemonic letter.
This is an optional modification, buthis modification help too with
easyest an application usage for visual impaired users if want jump fast
a vidget for a dialog or main window. Now, for example in Edit menu the
default awailable menu items not have mnemonic letters. Of course with
some menu items missing now the use_underline property, this property
need if you adding a mnemonic letter for a menu with not containing now
a mnemonic letter.

If this two type modifications is full done for Ubuntu 11.10, Gufw is a
very wonderful usable firewall preference tool for Orca Screen Reader
for visual impaired users.

More detailed GNOME accessibility related development documentation:
http://developer.gnome.org/accessibility-devel-guide/stable/

I full agree if you say not have enough time to doing this
modifications, because perhaps you have higher priorities works of other
Ubuntu developments. If this is true, and Ocelot development beginning,
please notify me this bugreport and I welcome doing this modifications.

Attila

costales (costales) wrote :

Thanks for the references and documentation ;D
I'll ask you for test it ;)
Best regards!

costales (costales) on 2011-05-03
Changed in gui-ufw:
status: New → Confirmed
costales (costales) wrote :

Attila, I'm so sorry the delay. I tried some months ago, but it's a big change.
Glade3 has now an 'accesibility' tab for each component. Could do I just fill those fields? :)
Thanks in advance!

Please try fill this fields, and attach a patch.
After this work done, I welcome testing gufw with Orca to this type
problem are fixed or not.
If you change use_underline property from false to true, and associate
labels the proper widgets with mnemonic_widget property, the result will
be right I think.
The adwantage this change if you doing this changes the gufw application
easyest handling with keyboard if need jumping a different widget
fastest with the widget mnemonic key, of course you need using an
underscore simbol before any letter with you would like marking mnemonic
letter. For example if you setting use_underline with True, setting
incoming label mnemonic_widget property the incoming combo box, and
insert an underscore character with incoming label before i letter, any
place with the Gufw dialog visual impaired users easyest to jump the
incoming combo box with ALT+I keystroke without need using TAB or
SHIFT+TAB key combinations.

Attila

costales (costales) on 2013-01-25
Changed in gui-ufw:
status: Confirmed → In Progress
assignee: nobody → costales (costales)
costales (costales) wrote :

Hi! I'm so sorry the delay.
Could you confirm me if it's OK?
By now, only these comboboxes: The current Profile, Status, Incoming Combobox and Outgoing Combobox.

Download the code with:
bzr branch lp:gui-ufw
and read the INSTALL file and install it ;)

Thanks in advance!

Attila Hammer (hammera) wrote :

Hi Costales,

Thank you your notification, I will be try the actual code and report
the test results with Orca Screen Reader.

Attila

costales (costales) wrote :

Thanks Attila :) Remember, it will work just with the Status, incoming, outgoing and profile objects.
The best way could be, in a Terminal:
sudo apt-get purge gufw ; sudo apt-get install ufw python-netifaces gir1.2-webkit-3.0 gir1.2-gtk-3.0 gnome-icon-theme-symbolic policykit-1 python-gobject python-distutils-extra bzr ; bzr branch lp:gui-ufw ; cd gui-ufw ; sudo python setup.py install --prefix=/usr ; gufw
Best regards and thanks in advance!!

Attila Hammer (hammera) wrote :

Hy Costales,

Sorry the delay.
Now, following the case, but possible have now new strings with need
translating hungarian language:
Default some english language labels not have mnemonic shortcuts,
following the label list:
Profile (associated the combo box widget), status toggle button
I not found other english language widgets, so I don't no what other
widgets possible associating mnemonic letters.
I suggest you future all possible places with setted the
use_underline=true property put an underscore character the english
language label string, so future translators will be known possible use
the underscore simbol too the translated string if want a shortcut a
widget label.
For example, if you already setted the use_underline property the
profile combo box GTK label, need changing the profile: string ffor
example with _profile: string.

I sending you a screenshot the actual UI.
The UI have a button with not have any label, this is the first focused
widget when launching the gufw application.

Attila

costales (costales) wrote :

Thanks for your patch Attila ;)
Could you confirm to me the last commit? All windows and labels has to been fixed :D
Cheers!

Changed in gui-ufw:
status: In Progress → Fix Committed
Attila Hammer (hammera) wrote :

Hy Costales,

All changes fine, very thank you your good work.
I doed only a minimal change the data/ui/preferences.ui (associate
mnemonic letters with two widgets).
I want add mnemonic letters with add and remove buttons with preferences
dialog, but because this widgets is GtkTool button type, this is not
possible.
I not want changing the control type from GtkToolButton to GtkButton
this widgets, because I don't no visually ok this change or not.
If this change are ok, data/ui/main.ui affected too. If you would like
add shortcuts with add and remove buttons, I suggest following shortcuts:
Add button: put an underscore character before A letter.
Remove button: put an underscore character before R letter.

Attila

Attila Hammer (hammera) wrote :

I forgot to wrote:
If not need any work with another Gufw windows, feel free you close this
bug with fixed state after you reviewed my last small attached patch.

Attila

costales (costales) on 2013-09-18
Changed in gui-ufw:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers