Enable/disable rules

Bug #360221 reported by komputes on 2009-04-12
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Gufw
Undecided
Unassigned
gui-ufw (Ubuntu)
Undecided
Unassigned

Bug Description

gufw 0.20.7-0ubuntu2

gufw is a great front end for ufw but it still feels very much like ufw. You can easily write rules but cannot easily manage the firewall.

My feature request is to have gufw save rules and then give the use the option to turn individual rules on or off. It would be useful to manually modify the firewall rules without having to type them in. It would also be interesting to have saved profiles which can be selected from a menu.

Currently, you need to completely delete a rule if you would like it to be disabled. This means you need to rewrite the rule every time you want it active. The other option is to create a profile and save it to a file and then load the profile by pointing to a file, (IMO, this should be done via a pull-down menu).

komputes (komputes) wrote :

Here is some inspiration, brought to you by Fedora...

costales (costales) on 2009-10-15
Changed in gui-ufw (Ubuntu):
status: New → Invalid
komputes (komputes) wrote :

@Marcos

Please understand that this is not a bug but a feature request. I do not understand why this was marked invalid. Please consider marking this bug as "Wishlist", otherwise let's discuss this proposed improvement.

Changed in gui-ufw (Ubuntu):
status: Invalid → New
costales (costales) wrote :

@komputes ;) I remove the bug from Gufw in Ubuntu repository, but PERSIST
I must think in

Changed in gui-ufw (Ubuntu):
status: New → Invalid
costales (costales) wrote :

@komputes ;) I remove the bug from Gufw in Ubuntu repository, but PERSIST in the Gufw proyect ;)
I must think in this bug, it's a great idea, but I think it's complicate for developer now.
Thanks by your time, and the bug persist as "new" ;)

costales (costales) on 2010-09-05
Changed in gui-ufw:
status: New → Triaged
Greg W. (mttbrnsmls) wrote :

I love the idea about having saved Profiles!

It would be so useful to be able to activate certain profiles based on what task you are doing so as to set boundaries on what applications can and cannot connect to the internet.

As GUFW works now, I can only have one profile. But users may want activate different profiles depending on what they are doing on the computer.

costales (costales) on 2014-03-03
summary: - Feature request: gufw should be able to enable/disable rules
+ Enable/disable rules
Mohamed Rizmi (mrizmi) on 2014-12-03
tags: added: wishlist
tags: added: feature-request
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments