gufw removes characters from interface name rendering rules invalid.

Bug #1830492 reported by Richard Kaufhold on 2019-05-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gufw
Undecided
Unassigned

Bug Description

My physical network interface has the name enp0s31f6 but gufw only shows enp0s31f so the final "6" is missing.

Only rules that do not reference the interface work. Rules using the interface name are created but simply ignored by iptables because the interface name does not match.

Changed in gui-ufw:
status: New → Fix Released

Hi,
Could you run this command in Terminal?
ls /sys/class/net
Thanks in advance.
--
Costales.

>

Richard Kaufhold (kaufholdr) wrote :

Sry for this bug report.

It's just debians outdated version 17.04.1-1.1 that is affected.

The debian testing version 18.10.0-1 works as expected.

Richard Kaufhold (kaufholdr) wrote :

I just tested to switch between the two versions and can reproduce the issue. I will open a bug report on debians issue tracking as this seems to be fixed in the current version.

# ls /sys/class/net
br0 enp0s31f6 lo ovs-system wlp4s0 wwp0s20f0u6i12

If you are still interested anyway.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers