Requires netstat (net-tools) to run, but not a dependency

Bug #1681250 reported by Doug McMahon on 2017-04-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gufw
Critical
Devid Antonio Filoni
gui-ufw (Debian)
Fix Released
Unknown
gui-ufw (Ubuntu)
Undecided
Unassigned

Bug Description

Will not run without netstat & net-tools package is neither a dep or installed on image by default.
Test case:
Install gufw
Try to open

What happens:
From terminal will see this message
Traceback (most recent call last):
  File "/usr/share/gufw/gufw/gufw.py", line 30, in <module>
    gufw = Gufw(controler.get_frontend())
  File "/usr/share/gufw/gufw/gufw/view/gufw.py", line 81, in __init__
    self.winadd = Add(self)
  File "/usr/share/gufw/gufw/gufw/view/add.py", line 43, in __init__
    self._set_initial_values()
  File "/usr/share/gufw/gufw/gufw/view/add.py", line 101, in _set_initial_values
    for ifaceName in self.gufw.fw.get_net_interfaces():
  File "/usr/share/gufw/gufw/gufw/model/frontend.py", line 126, in get_net_interfaces
    return self.firewall.get_net_interfaces(exclude_iface)
  File "/usr/share/gufw/gufw/gufw/model/firewall.py", line 251, in get_net_interfaces
    all_faces = self.backend.get_net_interfaces()
  File "/usr/share/gufw/gufw/gufw/model/ufw_backend.py", line 462, in get_net_interfaces
    cmd = self._run_cmd(cmd_ifaces)
  File "/usr/share/gufw/gufw/gufw/model/ufw_backend.py", line 37, in _run_cmd
    proc = subprocess.Popen(cmd, shell=False, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
  File "/usr/lib/python3.5/subprocess.py", line 676, in __init__
    restore_signals, start_new_session)
  File "/usr/lib/python3.5/subprocess.py", line 1282, in _execute_child
    raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] No such file or directory: 'netstat'

Installing the net-tools package allows it to open & run

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: gufw 17.04.1-1
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic x86_64
ApportVersion: 2.20.4-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Apr 9 13:50:24 2017
InstallationDate: Installed on 2017-04-08 (1 days ago)
InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Beta amd64 (20170407)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gui-ufw
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I found a corresponding bug report in Debian, so I have attached a bug watch and I'm marking this as confirmed.

Changed in gui-ufw (Ubuntu):
status: New → Confirmed
Changed in gui-ufw (Debian):
status: Unknown → New
costales (costales) on 2017-04-10
Changed in gui-ufw:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Devid Antonio Filoni (d.filoni)
milestone: none → 17.10
milestone: 17.10 → 17.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gui-ufw - 17.04.1-1ubuntu1

---------------
gui-ufw (17.04.1-1ubuntu1) zesty; urgency=medium

  * Add net-tools to gufw Depends field (LP: #1681250).

 -- Devid Antonio Filoni <email address hidden> Mon, 10 Apr 2017 19:16:16 +0200

Changed in gui-ufw (Ubuntu):
status: Confirmed → Fix Released
Changed in gui-ufw (Debian):
status: New → Fix Released
costales (costales) wrote :

Hi, please, remove it again for the next version 17.10. I removed that depedence from the code.
Thanks in advance.

Changed in gui-ufw:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.