GUFW generates only Input rules

Bug #1337746 reported by Bassam on 2014-07-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gufw
High
Unassigned
gui-ufw (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

TEST CASE:
1. install gufw from trusty
2. run it, open the "rules" part, click on the "+" and then on the "simple" tab
3. verify that there is no "direction" in there
4. install gufw from trusty-proposed
5. repeat step 2
6. verify that there is a directions entry now

REGRESSION POTENTIAL:
- it might uncover bugs in the previously hidden selection of the direction

Only Input-direction rules are possible to add, changing the connection direction to "Output" is only possible after the rule is created by changing "Input" to "Output" in the "edit the selected rules " menu.

GUFW 14.04.2

costales (costales) wrote :

Thanks Bassam! This was released for Ubuntu 14.10. I'll ask for a backport to Ubuntu 14.04.
Cheers!

Changed in gui-ufw:
status: New → Fix Released
importance: Undecided → Medium
costales (costales) wrote :

This is a fix for the IN/OUT rules in add/update rule & for Log in Advanced rule.

Apply with this:
sudo patch -p0 -i fix_direction_log.patch

And enter the proposed files:
/usr/share/gufw/ui/add.ui
/usr/share/gufw/ui/update.ui

costales (costales) wrote :

Resume, just run this command:
wget https://bugs.launchpad.net/gui-ufw/+bug/1337746/+attachment/4145782/+files/fix_direction_log.patch ; sudo patch -p0 -i fix_direction_log.patch ; rm sudo patch -p0 -i fix_direction_log.patch
Cheers!

costales (costales) on 2014-07-04
Changed in gui-ufw:
status: Fix Released → Fix Committed
importance: Medium → High
Bassam (bassam-f) wrote :

Hi again, the patch isn't working it says:

Ignoring potentially dangerous file name /usr/share/gufw/ui/add.ui
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Only in /usr/share/gufw/ui/: about.ui
|diff -c /usr/share/gufw/ui/add.ui new/add.ui
|*** /usr/share/gufw/ui/add.ui 2014-04-01 17:14:31.000000000 +0200
|--- new/add.ui 2014-07-04 21:26:05.366944350 +0200
--------------------------
File to patch:

Bassam (bassam-f) wrote :

Please ignore my last comment, I figured it out and the patch was applied.

Thanks a lot again..cheers

costales (costales) wrote :

Thank you Bassam! This bug should not have come so far:( I saw it too late.
I'll try to upload the patch to Ubuntu 14.04 :) Cheers!

costales (costales) wrote :

Hi @pitti! Please, could you apply this patch into Ubuntu 14.04 Trusty? Would you need a new bug?
https://bugs.launchpad.net/gui-ufw/+bug/1337746/+attachment/4145782/+files/fix_direction_log.patch
Thanks in advance!!

Resume:
  Problem: Direction fields are with the False attribute, then they are hidden.
  Patch: Set to True the Direction fields and users will see those fields in Add & Update windows (see atachments).

Martin Pitt (pitti) wrote :

Subscribing sponsors. Has this patch been applied in the upstream branch?

costales (costales) wrote :

Hi @pitty!

In Gufw 14.10 (for Ubuntu 14.10) hasn't this particular patch, because is a different release :) But of course this bug will be fixed in the release of Gufw 14.10 (I'll send the release to the MOTU this September).

Then, I just need this patch for Gufw 14.04.2 in Ubuntu 14.04.

Thanks a lot!

Changed in gui-ufw (Ubuntu Utopic):
status: New → Invalid

Please Martin, wait a few hours. I'm thinking i didn't make the diff with
the same package as in repository, i'm thinking i did with the LP branch.

I will send an updated pqtch in a few hours. My apologies!! :$
On Jul 5, 2014 1:00 PM, "costales" <email address hidden> wrote:

> Hi @pitty!
>
> In Gufw 14.10 (for Ubuntu 14.10) hasn't this particular patch, because
> is a different release :) But of course this bug will be fixed in the
> release of Gufw 14.10 (I'll send the release to the MOTU this
> September).
>
> Then, I just need this patch for Gufw 14.04.2 in Ubuntu 14.04.
>
> Thanks a lot!
>
>
>
> ** Changed in: gui-ufw (Ubuntu Utopic)
> Status: New => Invalid
>
> --
> You received this bug notification because you are a member of Gufw
> Developers, which is subscribed to Gufw.
> https://bugs.launchpad.net/bugs/1337746
>
> Title:
> GUFW generates only Input rules
>
> Status in Gufw:
> Fix Committed
> Status in “gui-ufw” package in Ubuntu:
> Invalid
> Status in “gui-ufw” source package in Trusty:
> New
> Status in “gui-ufw” source package in Utopic:
> Invalid
>
> Bug description:
> Only Input-direction rules are possible to add, changing the
> connection direction to "Output" is only possible after the rule is
> created by changing "Input" to "Output" in the "edit the selected
> rules " menu.
>
> GUFW 14.04.2
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gui-ufw/+bug/1337746/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~gufw-developers
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~gufw-developers
> More help : https://help.launchpad.net/ListHelp
>

costales (costales) wrote :

Please Martin, wait a few hours. I'm thinking i didn't make the diff with
the same package as in repository, i'm thinking i did with the LP branch.

I will send an updated pqtch in a few hours. My apologies!! :$
On Jul 5, 2014 1:00 PM, "costales" <email address hidden> wrote:

costales (costales) wrote :

Hi @pitti! I rebuild the patch ;)

This patch was done from the package gufw_14.04.2-0ubuntu1_all.deb ;)

Thanks in advance!

costales (costales) wrote :

Here my tests before & after the patch :)

Michael Vogt (mvo) on 2014-07-10
description: updated
description: updated
costales (costales) on 2014-07-14
Changed in gui-ufw:
status: Fix Committed → Fix Released

Hello Bassam, or anyone else affected,

Accepted gui-ufw into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gui-ufw/14.04.2-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gui-ufw (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
costales (costales) wrote :

Thanks a lot @arges!
I'll support this change, if anything is wrong, it'll fix. In other way, Gufw had the IN/OUT direction rule in previous versions, then I'm thinking all will be fine :)
Cheers!

Mathew Hodson (mathew-hodson) wrote :

Verified 14.04.2-0ubuntu1.1 from trusty-proposed. The Direction drop-down is correctly shown.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gui-ufw - 14.04.2-0ubuntu1.1

---------------
gui-ufw (14.04.2-0ubuntu1.1) trusty-proposed; urgency=low

  * cherry-pick lp:~costales/gui-ufw/gufw-14.10/revision/19
    and parts of lp:~costales/gui-ufw/gufw-14.10/revision/3
    to fix missing "directions" UI in the gtkbuild add.ui and
    update.ui files LP: #1337746
 -- Michael Vogt <email address hidden> Thu, 10 Jul 2014 15:26:46 +0200

Changed in gui-ufw (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gui-ufw has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Great! Thanks a lot to all of you for the upload and feedback :) Cheers!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers