Window size 640x480

Bug #1244670 reported by costales on 2013-10-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gufw
Undecided
Unassigned

Bug Description

My netbook, I use up and now, has a resolution of 1024 x 600 pixels.

I upgraded to Ubuntu 13.10 and found out your gufw app is now bigger that my screen height. Completely unusable. Same shit as Windows 8 requirements.

Can you please fix the height, so that it fits back again?

Good software should work with 640x480 VGA resolution. Never, ever make a unresizeable dialog that is bigger than 640x480 pixels. Allow users to resize down at least to 640x480. Take into consideration also the window manager title head and border.

How on the Earth you come with the idea to make the dialog so big? In your web page screenshot it looks so small and nice.

Other than this, a nice app.

costales (costales) wrote :

Hi!
I think this problem is fixed.
Could you try please? :) In a Terminal copy and paste this command:
sudo rm /etc/gufw/* ; sudo apt-get purge gufw ; sudo apt-get install ufw python-netifaces gir1.2-webkit-3.0 gir1.2-gtk-3.0 gnome-icon-theme-symbolic policykit-1 python-gobject python-distutils-extra bzr ; bzr branch lp:gui-ufw ; cd gui-ufw ; sudo python setup.py install --prefix=/usr

This will remove the current config file, remove gufw and install from the code.
Then just run Gufw again and it has to be small for your screen.
If the screen has or less 480px, the windows will be 440px.
If the screen has 600px or less, the window will be 550px.
Why those heights? Because I can't control the panel and the window decoration :)

I think this will works in all cases :D
Thanks for your feedback ppp! Cheers!

Changed in gui-ufw:
status: New → Fix Committed
ppp (superduper3000) wrote :

Thank you for your quick fix. As I do not want to install stuff I do not need in my netbook (the suggested packages bring a lot of dependencies, and it is hard to keep track to remove them clean again), what I did was to get bzr branch lp:gui-ufw in another pc, copy it to my netbook, take a backup of etc/gufw/, remove gufw, and I tried to run ./gui-ufw/bin/gufw, of course without any success. Actually to test the ui only it does not need to fully work, just to start. If you know a way for me to start the UI somehow from the source location without installing the dependencies (they should be there from the current gufw install) and without running setup.py, I can help.

costales (costales) wrote :

Good point ppp :) Don't worry, it's a less footprint way :D
We'll overwrite just one file ;)

1. Search your Gufw directory:
sudo find /usr/lib -name "utilsview.py"
You will get just ONE line like this:
/usr/lib/python2.7/site-packages/gufw/view/utilsview.py

2. Download the file to overwrite:
wget http://bazaar.launchpad.net/~costales/gui-ufw/gufw-13.10/download/head:/utilsview.py-20130614164138-7cef6k5melxzcc92-281/utilsview.py

3. Overwrite it :)
sudo cp utilsview.py /usr/lib/python2.7/site-packages/gufw/view/utilsview.py

4. Remove the current Gufw config file (it's save the window size):
sudo rm /etc/gufw/*

Done :) Run Gufw and send me your feedback please :D If anything is wrong, with screenshots please :)
Cheers!

ppp (superduper3000) wrote :

Thanks. The file seems to be located in /usr/share/gufw/gufw/view/utilsview.py

After replace:

$ gufw

(gufw.py:2584): Gtk-CRITICAL **: gtk_list_store_get_column_type: assertion 'index < priv->n_columns' failed
Traceback (most recent call last):
  File "/usr/share/gufw/gufw/gufw.py", line 34, in <module>
    app = Gufw(fw_frontend)
  File "/usr/share/gufw/gufw/view/gufw.py", line 49, in __init__
    self._set_initial_values()
  File "/usr/share/gufw/gufw/view/gufw.py", line 181, in _set_initial_values
    self.utils.print_rules(self.fw.get_rules())
  File "/usr/share/gufw/gufw/view/utilsview.py", line 121, in print_rules
    self.rules_model.set_value(iter_row, 13, row) # number
  File "/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py", line 980, in set_value
    value = self._convert_value(column, value)
  File "/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py", line 862, in _convert_value
    return GObject.Value(self.get_column_type(column), value)
  File "/usr/lib/python2.7/dist-packages/gi/overrides/GObject.py", line 214, in __init__
    self.init(value_type)
TypeError: Must be gobject.GType, not gobject.GType

Then I commented line 121 out - it looks like a bug anyway :)
#self.rules_model.set_value(iter_row, 13, row) # number

And tried again. This time it run ok, see the screenshot.

http://postimg.org/image/430os7iij/
http://s17.postimg.org/bizye067z/gufw3.png

To me it looks better now, but still some pixels in the very end of the widow (20 or so pixles) are still not visible.

For refernce gufw.cfg

[GufwConfiguration]
profile = Home
windowwidth = 371
windowheight = 560
expandrules = yes
expandlog = yes
expandlistening = yes

Hope this helps.

costales (costales) wrote :

Great debug ppp! :D

Yes, I'm changing code for the next release, and you have to comment that line 121. My apologies about that.

Could you change the line 170?
            win.set_size_request(360, 560)
for something like this:
            win.set_size_request(360, 530)

Remove the Gufw config file again:
sudo rm /etc/gufw/gufw.cfg

And try again :) Thanks in advance!!

ppp (superduper3000) wrote :

Yes, with 530 it looks fully ok now.

http://postimg.org/image/nbujqex5z/
http://s15.postimg.org/rxqnyrip7/gufw4.png

It is a bit smaller than the full screen estate, but that is perfect like this, some tolerance is ok.

Thanks. I was happy I could help.

costales (costales) wrote :

Perfect :) Remember that you can resize more bigger ;)
Gufw will be released with this improement into Ubuntu 14.04.
Cheers!

costales (costales) on 2013-12-19
Changed in gui-ufw:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions