IRC Clients join Ubuntu channels by default

Reported by Benjamin Rubin on 2010-01-28
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Guadalinex
Low
Guadalinex Members
Guadalinex Edu
Medium
David Erosa

Bug Description

Many of the IRC Client packages in Ubuntu are setup to join #ubuntu on irc.freenode.net by default. #Ubuntu is our official support channel and is English only (we have a number of channels for other languages[0], but they aren't joined by default). Since Gaudalinex is a derivative, it appears to inherit these settings. We have had a large number of Guadalinex users join lately who speak little or no English. This is becoming distracting and impacting on the level of support we can give as we are spending a lot of time directing these users elsewhere.

The Ubuntu IRC Council [1] would like to request that the default IRC channel for these applications be changed to somewhere more appropriate for Guadalinex users.

[0] https://help.ubuntu.com/community/InternetRelayChat#Channels
[1] https://wiki.ubuntu.com/IRC/IrcCouncil

Alfonso de Cala (alfem) wrote :

Have you any statistics of Ubuntu users grouped by native language? If spanish is one of the top three maybe a new channel could be interesting.

To avoid this kind of 'bug' a list of packages were "Ubuntu" or "Canonical" is hardcoded or configured by default could be handy as well.

Alfonso de Cala (alfem) wrote :

Self correction, #Ubuntu-es would be the right channel for Guadalinex users interested in IRC

https://help.ubuntu.com/community/InternetRelayChat#Channels

Miia Ranta (myrtti) wrote :

if you plan to change the default IRC channel to some other than a specific Guadalinex channel you own and administer instead of removing the default totally, I hope you discuss this matter with the administrators of the planned channel...

m4v (m4v) wrote :

Can #ubuntu-es realistically give support to Guadalinex users? I have been looking around in the Guadalinex webpage but couldn't find anything along the lines of "differences between Ubuntu and Guadalinex"
Is Guadalinex just an Ubuntu with a different theme and default packages or something more radical? Are Guadalinex releases in sync with Ubuntu's?

Alfonso de Cala (alfem) wrote :
Download full text (3.8 KiB)

Here follows a list of fixes & tweaks we developed (for Guadalinex) to improve Ubuntu usability:

* Hermes: when users plug anything into Guadalinex (webcams, bluetooth dongles, smart cards...) a notification pops up (as a kind of "confirm receipt") suggesting what to do with that piece of hardware. This is a generic system with 'actors' triggered by diferent types of hot-pluggable hardware. So, users don't need to browse the application menu looking for Cheese when they plug a webcam into their computer. Hermes also can suggest software to install when an user plugs something not directly supported by the base distribution.

* Mount-Systray: a few years ago, a someone came to me and said: "Windows has got a little button I have to press to extract usb drives safely. Where is it in my Guadalinex?". Right click on a device is not evident, so we developed an applet for in the upper panel. This applet sits in the upper panel and blinks when an user plugs an usb memory. Blinking can be easily switched off, but we surprisingly noticed that users prefer to leave it flashing (me too!).

* First Login Screen: new users need some tips when they arrive to Guadalinex. Our First Start Dialog opens a web page with brief but useful information:
 * A quick view to your desktop: a screenshot with sensible zones. Users can move the mouse over these areas to get an explanation of menues, buttons, panels...
 * A link to the full Guadalinex handbook (html).
 * How to get support: links to our official support system and users phorum.
 * What to do with the DVD: install more software just re-inserting it in the DVD-reader. Copy and give it to a friend. Keep it in a safe place, maybe you can need it in an emergency.

* Installer with disk-preview: we added disk preview to the DVD installer. Deleting or overwriting partitions is always dangerous and a preview of data in the target partitions is really appreciated.

* AMIGU (Assistant for Migration to Guadalinex): I know Ubuntu installer has got something similar embedded, but feature limited. We think that moving mails, files, backgrounds, bookmarks... from an existing windows partition to your brand new linux is interesting but we don't want to force users to do it during installation. This AMIGU is a stand-alone application with more features than the Ubuntu equivalent. AMIGU migrates bookmarks, outlook (any version) or thunderbird mails and contacts, personal documents, Instant Messaging accounts (MSN, gmail. yahoo), eMule configuration, truetype fonts...

* Accesibility profiles: when you start Guadalinex live disk, you can select an accesibility profile for visual impaired people or others. We also added this profiles to user creation dialogs.

* Grubaker: a small (graphical) tool to configure basic boot menú (grub) options.

* Spanish Voices: we developed two new spanish voices (male and female) for the included synthesys engine (Festival). All the spanish regional distributions (and some southamerican ones) are using them, and they are now getting in Fedora as well.

* MD5 summer: We want to make moving to a new version as easy as possible. Guadalinex ships backup software and a MD5 checksum graphical to...

Read more...

m4v (m4v) wrote :

Thanks for your quick reply, Alfonso.

The only thing I'm wondering now is which Ubuntu release is Guadalinex v6 based on, and if releases are synchronized with Ubuntu.
Having that information would be handy, if we ask "which Ubuntu release are you using?" and we get "Guadalinex v-something" as a reply doesn't help us much : /
For example, we expect grub2 and ext4 filesystems in users with Karmic, while not in those with Jaunty.

Alfonso de Cala (alfem) wrote :

We release a major version once a year, one month (roughly) after Ubuntu. Guadalinex V6 is based on Jaunty and the next one will be a Lucid derivative. We prefer a slower (and safer) pace :-)

For this new version we will change default config in XChat, selecting a spanish channel as default.

El Fri, 29 Jan 2010 10:42:42 -0000
Alfonso de Cala <email address hidden> escribió:

> Self correction, #Ubuntu-es would be the right channel for Guadalinex
> users interested in IRC

 Really dunno; most guadalinex users i've seen in the #ubuntu and #ubuntu-es
channels are very young kids looking for someone to chat with and just trying
this "IRC thing" they usually do not want help with anything.

 Frankly I do not think that it is a good idea to use #ubuntu-es for those users
I think it would be better to have a channel for them to tinker and chat with
fellow students if they wish.

 Users that really want help can be forwarded to #ubuntu-es no problem but we
 need some sort of firewall.

 At least make them join #ubuntu-es-offtopic so they do not disrupt the main
 support channel.

 Thanks.

AlejandroRiveira (ariveira) wrote :

No response to #8 ?

 We have been "suffering" more of this users in #ubuntu and #ubuntu-es and we can say that
what i suggested in #8 is the only way fordward. They should have its own channel.

 Also IRc can be quite "dangerous2 for kids of the age we are seing (11-12) teachers should warn
about it when they explain the system to this users IMHO.

 Thanks

Juha Siltala (topyli) wrote :

Agreed. These users being thrown into the general world of IRC without understanding what it is is definitely not a good thing.

I am not to lecture to Guadalinex maintainers about managing their community, just reflecting on what we see on Ubuntu channels.

Juanje Ojeda (juanje) wrote :

I think we are missing some points...

 * Guadalinex is based in Ubuntu and is 100% compatible with Ubuntu.
 * X-Chat is Ubuntu's package. We didn't changed it.
 * X-Chat join you by default into an irc Ubuntu's channel

The problem is the same with any group of kids arround the world using Ubuntu. They don't know about what irc or Ubuntu is and so.
Maybe we have a bit (maybe a few thousands) more of users than other Ubuntu groups, but it's not a different problem, it is the same with a different scale of users.

And of course the las Guadalinex v6 is not using the same that Lucid and I can understand that could be anoying to answer old issues' questions, but there is a lot of 'native' Ubuntu users using Jaunty or another old versions of Ubuntu around the world. Not all the users can/like to deal with the last fancy version...

We can try to figure out some solution (?) for this kind of problem on the next version but on previus is quite complicated. I mean that is the same that trying to change those options on Ubuntu Jaunty users that are already using the distro. It's not quite easy...

Juha Siltala (topyli) wrote :

Juanje,

Guadalinex is based on Ubuntu of course, and that's wonderful. It is decidedly *not* 100% compatible with Ubuntu however, and should not be. Why would anyone make another distribution just the same as another?

XChat is not the default IRC client in Ubuntu.

I agree that this will be easier to fix in an upcoming version of Guadalinex than the current one. The problem with upgrading users having the same XChat configuration and *still* joining #ubuntu by default will remain.

Juanje Ojeda (juanje) wrote :

Juha,

100% compatible doesn't means equal. You can install the Guadalinex packages and metapackages into a Ubuntu box with no problems and vice versa. That's 100% compatible. But Guadalinex have a different list of applications by default, some extra utilities, some extra doc in Spanish, some bugs fixed which weren't accepted for a stable version. We based on Jaunty, but we released a month or so after Jaunty. During tahat time we were fixing Ubuntu's bugs. Some patches were acepted and some weren't (because they weren't considerent important enough for Ubuntu users).

Anyway, that's why Guadalinex != Ubuntu Jaunty but still is 100% compatible.

And we were shipping X-Chat (which is the default IRC client for GNOME) and this package has configuration that join the user into an Ubuntu irc chanel by default. This is an Ubuntu's config for this package, not ours. We didn't realise this and we didn't know it was going to be a problem. Mostly because we didn't know that config, we could test all the specific configs... we were confident on the Ubuntu's configs.

But the problem is there and now we know and you know. Well... as I said before we'll try to do something else for the next release and the fix for the issue is quite complicated for the previous one, so what you propose?

I really don't know (right now) a very good solution. But the problem with the kids is actually because another flavor of Guadalinex: Guadalinex Edu (I'll subscribe the Guadalinex Edu's team to the bug), because is the version installed on the schools.
The good thing is that the PC aren't really upgraded, they (usually) are installed from the scrach (on all the schools), so this could fix the problem (from this point on).

This is the best thing I can tell you right now. I really understand your concern and I'd like to be able to help more, but I guess we'll have to wait until the next Guadalinex Edu release.

Guadalinex Edu' team, any thoughs?

There's already a #guadalinex channel registered on freenode that nobody seems to use, I think it would be the best place for this.

But Juanje is right, this seems to be a problem regarding Guadalinex-Edu more than all the Guadalinex family.

Maybe we could have both #guadalinex and a #guadalinex-edu channels...

David Erosa (erosa) on 2010-03-23
Changed in guadalinexedu:
status: New → Confirmed
importance: Undecided → Medium
David Erosa (erosa) wrote :

Thanks for the warning, we (the Guadalinex-Edu team) didn't even thought this could happen :)

We'll try to release a corrected xchat package asap. There's no need to wait for the next guadalinex-edu release, we can upgrade schools' packages.

Juanje Ojeda (juanje) wrote :

Great :-)

That's true, you can. I didn't remember it.
Good news, isn't it? :-)

Greetings

2010/3/23, David Erosa <email address hidden>:
> Thanks for the warning, we (the Guadalinex-Edu team) didn't even thought
> this could happen :)
>
> We'll try to release a corrected xchat package asap. There's no need to
> wait for the next guadalinex-edu release, we can upgrade schools'
> packages.
>
> --
> IRC Clients join Ubuntu channels by default
> https://bugs.launchpad.net/bugs/513915
> You received this bug notification because you are subscribed to
> Guadalinex.
>

--
Enviado desde mi dispositivo móvil

Juanje Ojeda Croissier
Responsable de Comunidad

Emergya Consultoría
Tfno: +34 954 51 75 77 / +34 672 16 74 09
Fax: +34 954 51 64 73
www.emergya.es

David Erosa (erosa) on 2010-03-30
Changed in guadalinexedu:
status: Confirmed → Fix Committed
assignee: nobody → David Erosa (erosa)

Xchat from now will not come with #ubuntu channel marked as default option in Guadalinex Edu.

David Erosa (erosa) on 2010-04-06
Changed in guadalinexedu:
status: Fix Committed → Fix Released
Alfonso de Cala (alfem) on 2010-05-03
Changed in guadalinex:
assignee: nobody → Guadalinex Members (guadalinex-members)
importance: Undecided → Low
Terence Simpson (tsimpson) wrote :

The IRC Council would like to know what progress, if any, has been made on this bug in the Guadalinex task. Can we get a quick update on this please?

David Erosa (erosa) wrote :

Terence: The Guadalinex Edu Team relesed a fix about two months ago.

Antonio Sánchez, can you confirm this, please?

Alfonso de Cala (alfem) wrote :

x-chat is not included anymore in the default installation of Guadalinex (V7 release scheduled for a couple of weeks).

But I agree with JuanJe Ojeda: Any ubuntu derivative should use the same channels than Ubuntu itself, or you will loose critical mass.

Of course, as you can see in the screenshot attached in Guadalinex Edu, there is no channel selected by default in Xchat.

Guadalinex Edu is being used by teachers and students in all the public schools of the south of Spain (more than 450000 computers). Inside the schools network, Ubuntu IRC Servers are filtered, so the problem was when students ran Xchat at home and they were connected by default to #ubuntu channel.

We hope #ubuntu not populated anymore with young spanish speakers :D

Terence Simpson (tsimpson) wrote :

Thanks, once the next release of Guadalinex out, please update the task.

Terence Simpson (tsimpson) wrote :

I assume Guadalinex V7 has been released and so I'm resolving this bug

Changed in guadalinex:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers