deja-dup backup window is white on lightgrey, white text on white background in details

Bug #929128 reported by Roman Yepishev on 2012-02-08
118
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Déjà Dup
High
Unassigned
GTK+
Expired
Medium
deja-dup (Debian)
Fix Released
Unknown
deja-dup (Fedora)
Won't Fix
Medium
deja-dup (Ubuntu)
High
Michael Terry
ubuntu-themes (Ubuntu)
Undecided
Unassigned

Bug Description

Deja-dup "Backup now" is white on light grey. The details widget draws white text on white background.

Screenshot is attached.

gtk3-engines-unico:
  Installed: 1.0.1-0ubuntu2
  Candidate: 1.0.1-0ubuntu2

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: light-themes 0.1.8.28.1
ProcVersionSignature: Ubuntu 3.2.0-14.23-generic-pae 3.2.3
Uname: Linux 3.2.0-14-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Wed Feb 8 23:27:53 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120119)
PackageArchitecture: all
SourcePackage: light-themes
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Roman Yepishev (rye) wrote :
Changed in light-themes (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Mike, could you have a look? Cimi says it seems a deja-dup issue:

<Cimi> seb128, it could be a deja dup bug
 seb128, I have a CSS match that does *:selected { color: white; }
 seb128, so it looks like all the widgets, including labels and buttons, have the selected state

Using adwaita (the GNOME theme) shows similar issue, so it seems deja-dup might be doing something weird?

affects: light-themes (Ubuntu) → deja-dup (Ubuntu)
Changed in deja-dup (Ubuntu):
assignee: Andrea Cimitan (cimi) → Michael Terry (mterry)
Dario Bertini (berdario) wrote :

This is only a guess, but given the similarity of the problem, and the timeframe... maybe a change in how gtk considers the widgets to be selected is also the cause for this bug in empathy?

https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/930917

Michael Terry (mterry) wrote :

I'm not convinced this isn't a GTK+ bug. GTK+ changed so that if you modified the foreground color of a parent GtkEventBox, a child GtkEventBox also now get that same foreground color (before, they didn't). But the background isn't treated the same way (i.e. the behavior of not inheriting the color stays the same). Seems wrong. But I worked around it in Deja Dup.

Changed in deja-dup:
importance: Undecided → High
milestone: none → 21.5
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

Thanks Michael, do you plan to open a gtk bug about the issue?

Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Michael Terry (mterry) wrote :

deja-dup (21.90-0ubuntu1) precise; urgency=low

  * New upstream release
  * debian/rules:
    - Enable 'make check' by default again
  * debian/control:
    - Add dbus-x11 and desktop-file-utils as Build-Depends for tests

Changed in deja-dup:
milestone: 21.5 → 21.90
status: Fix Committed → Fix Released
Changed in deja-dup (Ubuntu):
status: Confirmed → Fix Released

Created attachment 581845
On left screen is F17 TC2 and on right screen is F16 for comparison.

Description of problem:
  Backup connection window fonts are not readable.

Version-Release number of selected component (if applicable):
  deja-dup-20.2-2.fc17.x86_64

How reproducible:
  always

Steps to Reproduce:
  1. Open deja-dup (Backup from activities)
  2. Select - Backup now
  3. New window appears

Actual results:
  Fonts are not readable. They have white color on grey background.

Expected results:
  Readable font.

Additional info:
  Screenshot attached.

This is upstream bug https://bugs.launchpad.net/deja-dup/+bug/929128

Which is really GTK+_bug https://bugzilla.gnome.org/show_bug.cgi?id=670018

But this was worked around in deja-dup 22.0. You should really use the latest stable version, 22.1!

Changed in deja-dup (Debian):
status: Unknown → New

*** Bug 828173 has been marked as a duplicate of this bug. ***

Issue persists on:

deja-dup-20.2-2.fc17.x86_64

Michael Terry (mterry) wrote :

Turns out this is a bug in light-themes, not GTK+. Adwaita does the right thing. See https://bugzilla.gnome.org/show_bug.cgi?id=670018 for a test program and reproduction steps.

Changed in gtk:
status: New → Unknown

*** Bug 806108 has been marked as a duplicate of this bug. ***

Three months without any response?

This is only a problem for me if I use Adwaita GTK+ theme. Switching to another theme such as Elementary or one that's contrasted the text is readable.

Although Michael wrote in upstream ticket:
"Turns out this is a bug in light-themes, not GTK+. Adwaita does the right thing. See https://bugzilla.gnome.org/show_bug.cgi?id=670018 for a test program and reproduction steps."

Rawhide has the same problem as it's only a minor release.

I did a test build of latest stable 22.1 from 2012-04-16 and the problem no-longer exists. We might need to do a new major version bump for f17.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed

*** Bug 886630 has been marked as a duplicate of this bug. ***

*** Bug 878158 has been marked as a duplicate of this bug. ***

deja-dup-22.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/deja-dup-22.1-1.fc17

Package deja-dup-22.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing deja-dup-22.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6642/deja-dup-22.1-1.fc17
then log in and leave karma (feedback).

This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we may not be able to fix it before Fedora 17 is end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged change the
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Changed in gtk:
status: Unknown → New

Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

affects: light-themes (Ubuntu) → ubuntu-themes (Ubuntu)
Changed in deja-dup (Debian):
status: New → Fix Released
Changed in gtk:
status: New → Expired
Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 12.04 (precise) reached end-of-life on April 28, 2017.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test.

Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Incomplete
Changed in deja-dup (Fedora):
importance: Unknown → Medium
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.