deja-dup backup window is white on lightgrey, white text on white background in details

Reported by Roman Yepishev on 2012-02-08
118
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Déjà Dup
High
Unassigned
GTK+
New
Medium
deja-dup (Debian)
Fix Released
Unknown
deja-dup (Fedora)
Unknown
Unknown
deja-dup (Ubuntu)
High
Michael Terry
ubuntu-themes (Ubuntu)
Undecided
Unassigned

Bug Description

Deja-dup "Backup now" is white on light grey. The details widget draws white text on white background.

Screenshot is attached.

gtk3-engines-unico:
  Installed: 1.0.1-0ubuntu2
  Candidate: 1.0.1-0ubuntu2

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: light-themes 0.1.8.28.1
ProcVersionSignature: Ubuntu 3.2.0-14.23-generic-pae 3.2.3
Uname: Linux 3.2.0-14-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Wed Feb 8 23:27:53 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120119)
PackageArchitecture: all
SourcePackage: light-themes
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Roman Yepishev (rye) wrote :
Changed in light-themes (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Mike, could you have a look? Cimi says it seems a deja-dup issue:

<Cimi> seb128, it could be a deja dup bug
 seb128, I have a CSS match that does *:selected { color: white; }
 seb128, so it looks like all the widgets, including labels and buttons, have the selected state

Using adwaita (the GNOME theme) shows similar issue, so it seems deja-dup might be doing something weird?

affects: light-themes (Ubuntu) → deja-dup (Ubuntu)
Changed in deja-dup (Ubuntu):
assignee: Andrea Cimitan (cimi) → Michael Terry (mterry)
Dario Bertini (berdario) wrote :

This is only a guess, but given the similarity of the problem, and the timeframe... maybe a change in how gtk considers the widgets to be selected is also the cause for this bug in empathy?

https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/930917

Michael Terry (mterry) wrote :

I'm not convinced this isn't a GTK+ bug. GTK+ changed so that if you modified the foreground color of a parent GtkEventBox, a child GtkEventBox also now get that same foreground color (before, they didn't). But the background isn't treated the same way (i.e. the behavior of not inheriting the color stays the same). Seems wrong. But I worked around it in Deja Dup.

Changed in deja-dup:
importance: Undecided → High
milestone: none → 21.5
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

Thanks Michael, do you plan to open a gtk bug about the issue?

Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Michael Terry (mterry) wrote :

deja-dup (21.90-0ubuntu1) precise; urgency=low

  * New upstream release
  * debian/rules:
    - Enable 'make check' by default again
  * debian/control:
    - Add dbus-x11 and desktop-file-utils as Build-Depends for tests

Changed in deja-dup:
milestone: 21.5 → 21.90
status: Fix Committed → Fix Released
Changed in deja-dup (Ubuntu):
status: Confirmed → Fix Released
Changed in deja-dup (Debian):
status: Unknown → New
Michael Terry (mterry) wrote :

Turns out this is a bug in light-themes, not GTK+. Adwaita does the right thing. See https://bugzilla.gnome.org/show_bug.cgi?id=670018 for a test program and reproduction steps.

Changed in gtk:
status: New → Unknown
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Changed in gtk:
status: Unknown → New
affects: light-themes (Ubuntu) → ubuntu-themes (Ubuntu)
Changed in deja-dup (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.