lxappearance crashed with SIGSEGV in gtk_icon_view_layout_single_row()

Bug #899322 reported by Marián Kadaňka on 2011-12-02
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GTK+
Unknown
Unknown
gtk+2.0 (Ubuntu)
High
Unassigned
lxappearance (Ubuntu)
Medium
Unassigned

Bug Description

Crash immediately after lxappearance launch, Lubuntu 12.04 alpha 1

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: lxappearance 0.5.1-1
ProcVersionSignature: Ubuntu 3.2.0-2.5-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Fri Dec 2 19:26:07 2011
ExecutablePath: /usr/bin/lxappearance
Icons_Default: No icons theme configured by default
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha i386 (20111129.1)
ProcCmdline: lxappearance
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x21ecc6: mov 0xc(%ebp,%edi,1),%edi
 PC (0x0021ecc6) ok
 source "0xc(%ebp,%edi,1)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: lxappearance
StacktraceTop:
 ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
 g_cclosure_marshal_VOID__BOXED () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: lxappearance crashed with SIGSEGV in g_cclosure_marshal_VOID__BOXED()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxappearance (Ubuntu):
status: New → Confirmed

StacktraceTop:
 gtk_icon_view_layout_single_row (maximum_width=<synthetic pointer>, y=<synthetic pointer>, row=<optimized out>, item_width=12, first_item=0x9a35aa0, icon_view=0x9a51010) at /build/buildd/gtk+2.0-2.24.8/gtk/gtkiconview.c:2749
 gtk_icon_view_layout (icon_view=0x9a51010) at /build/buildd/gtk+2.0-2.24.8/gtk/gtkiconview.c:2855
 gtk_icon_view_size_allocate (widget=0x9a51010, allocation=0xbffdfc60) at /build/buildd/gtk+2.0-2.24.8/gtk/gtkiconview.c:1507
 g_cclosure_marshal_VOID__BOXED (closure=0x998adf0, return_value=0x0, n_param_values=2, param_values=0x9c7b718, invocation_hint=0xbffdfa80, marshal_data=0x21f5d0) at /build/buildd/glib2.0-2.30.1/./gobject/gmarshal.c:574
 g_type_class_meta_marshal (closure=0x998adf0, return_value=0x0, n_param_values=2, param_values=0x9c7b718, invocation_hint=0xbffdfa80, marshal_data=0x80) at /build/buildd/glib2.0-2.30.1/./gobject/gclosure.c:885

Changed in lxappearance (Ubuntu):
importance: Undecided → Medium
summary: - lxappearance crashed with SIGSEGV in g_cclosure_marshal_VOID__BOXED()
+ lxappearance crashed with SIGSEGV in gtk_icon_view_layout_single_row()
tags: removed: need-i386-retrace
Julien Lavergne (gilir) wrote :

Thanks Dave for the investigation, it should be fixed in the next version of gtk+2.0 (2.24.9), or if the path attached is applied.
Commit in upstream git : http://git.gnome.org/browse/gtk+/commit/?h=gtk-2-24&id=5c3bb1839cac52828756f9ddb98f49d586853991

tags: added: patch
Evan Broder (broder) wrote :

Thanks for tracking this down, guys.

I'm going to close the lxappearance task as "Invalid" since the issue seems to have been tracked down to GTK.

(In particular, this should cause it to show up as a GTK patch on the sponsorship queue, which hopefully means the right people will see it)

Changed in lxappearance (Ubuntu):
status: Confirmed → Invalid
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → High
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (9.8 KiB)

This bug was fixed in the package gtk+2.0 - 2.24.8-2ubuntu1

---------------
gtk+2.0 (2.24.8-2ubuntu1) precise; urgency=low

  * debian/patches/git_buggy_icon_view_update.patch:
    - git commit reverting a buggy icon view patch leading to
      segfaults in lxappearance (lp: #899322)
  * Resynchronize on Debian
  * debian/libgtk2.0-0.symbols:
    - Add Ubuntu specific symbols
  * debian/rules:
    - Use dh_autoreconf
    - Use -XNEWS -Xchangelog.Debian -XREADME to dh_compress calls to
      workaround a gzip issue leading to different md5sum between builds
  * debian/patches/012_ubuntu-set-grab-add.patch
    - Added ubuntu_gtk_widget_set_has_grab so we can grab sliders and
      things in menus, needed by ido
  * debian/patches/043_menu_proxy.patch
    - Add GtkMenuProxy support for remoting menus.
  * debian/patches/044_grips.patch:
    - Backport from the gtk3 resize grips to the natty gtk2 version
  * debian/patches/061_use_pdf_as_default_printing_standard.patch:
    - dropped, the issue has been fixed upstream differently since
  * debian/patches/062_dnd_menubar.patch:
    - Allow click on menubars for dnd
  * debian/patches/063_treeview_almost_fixed.patch:
    - Add an ubuntu-almost-fixed-height-mode property, (required for
      software-center)
  * debian/patches/065_gir_set_packages.patch
    - Added _gir_PACKAGES for each gir created, to match gir to pkg which is
      needed by vapigen-0.12
  * debian/patches/070_mandatory-relibtoolize.patch:
    - Dropped, we are using dh-autoreconf instead
  * debian/patches/071_no_offscreen_widgets_grabbing.patch:
    - Don't let offscreen widgets do grabbing
  * debian/patches/072_indicator_menu_update.patch:
    - change by Cody Russell to send an update event on menu changes,
      should make the bluetooth indicator refresh correctly
  * debian/patches/091_bugzilla_tooltip_refresh.patch:
    - Upstream bugzilla change to have better looking tooltips the gtk theme
      need to set "new-tooltip-style" to use those
  * debian/patches/092_default_to_xdg_document_dir.patch:
    - Use $XDG_DOCUMENTS_DIR as default directory rather than the home
      directory for the 'Print to File' function.
  * debian/patches/093_gtk3_gtkimage_fallbacks_use.patch:
    - Backported gtk3 patch to add a "use-fallback" property to GtkImage, using
      it "icon-name and GIcon type of GtkImages can use automatic fallback
      names.", it will be useful for the indicator stack
  * debian/patches/095_git_menus_scrolling.patch:
    - backported gtk3 commit to fix menu scrolling issues
  * debian/patches/096_git_gtkprintsettings.patch:
    - upstream git commit backported from the gtk3 serie, don't ignore the
      gtkprintsettings resolution settings
  * debian/patches/097_statusicon_image_fallback.patch: Make GtkStatusIcon
    images use fallbacks by default if the property is available.
  * debian/patches/100_overlay_scrollbar_loading.patch
    - support for dynamically loading overlay scrollbars
  * debian/patches/gailitem-set-alt-name.patch: Extend the GailItem object
    so applications can set an alternative textual description for a menu
    item that has an icon, where the icon is used to give the user more
 ...

Changed in gtk+2.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.