geany crashed when trying to open a second file

Bug #851383 reported by Leon Matthews on 2011-09-15
88
This bug affects 16 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
geany (Ubuntu)
High
Unassigned
gtk+2.0 (Ubuntu)
Medium
Unassigned

Bug Description

Opening a file through the system file browser (using open icon, or ctrl+o) works for one file, but causes Geany to crash to the desktop when trying to open the second file.

Opening files by dragging and dropping from the gnome file explorer works just fine, and is the work-around I'm currently using.

System details:

$ lsb_release -rd
Description: Ubuntu oneiric (development branch)
Release: 11.10
(Updated this morning, bug has been present during at least four days of updates.)

$ apt-cache policy geany
geany:
  Installed: 0.20-1.1ubuntu1
  Candidate: 0.20-1.1ubuntu1
  Version table:
 *** 0.20-1.1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: geany 0.20-1.1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CheckboxSubmission: 98327c5c9f6c8ffdc34672e97a4a2a51
CheckboxSystem: edda5d4f616ca792bf437989cb597002
CrashCounter: 1
Date: Fri Sep 16 09:45:42 2011
ExecutablePath: /usr/bin/geany
ProcCmdline: geany
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: geany
StacktraceTop:
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 gtk_file_chooser_default_initial_focus () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
 gtk_file_chooser_dialog_map () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: geany crashed with SIGABRT in g_assertion_message()
UpgradeStatus: Upgraded to oneiric on 2011-09-07 (7 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare staff

Leon Matthews (leon-matthews) wrote :

StacktraceTop:
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x7f3d76eb0b20 "gtk_file_chooser_default_initial_focus", message=0x160a7d0 "assertion failed: (widget != NULL)") at /build/buildd/glib2.0-2.29.90/./glib/gtestutils.c:1425
 g_assertion_message_expr (domain=0x7f3d76e9b17b "Gtk", file=0x7f3d76eb1c18 "/build/buildd/gtk+2.0-2.24.6/gtk/gtkfilechooserdefault.c", line=8750, func=0x7f3d76eb0b20 "gtk_file_chooser_default_initial_focus", expr=<optimized out>) at /build/buildd/glib2.0-2.29.90/./glib/gtestutils.c:1436
 gtk_file_chooser_default_initial_focus (chooser_embed=<optimized out>) at /build/buildd/gtk+2.0-2.24.6/gtk/gtkfilechooserdefault.c:8750
 gtk_file_chooser_dialog_map (widget=<optimized out>) at /build/buildd/gtk+2.0-2.24.6/gtk/gtkfilechooserdialog.c:359
 g_closure_invoke (closure=0xbf4470, return_value=0x0, n_param_values=1, param_values=0x15290c0, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.29.90/./gobject/gclosure.c:774

Changed in geany (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in geany (Ubuntu):
status: New → Confirmed
Julian Taylor (jtaylor) on 2011-09-17
visibility: private → public
Julian Taylor (jtaylor) wrote :

this is a regression caused introduced between:
libgtk2.0-0 2.24.6-0ubuntu1
libgtk2.0-0 2.24.5-0ubuntu7

downgrading to 2.24.5-0ubuntu7 fixes the problem

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → High
Changed in geany (Ubuntu):
importance: Medium → High
Leon Matthews (leon-matthews) wrote :

Thanks very much Julian!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Pedro Villavicencio (pedro) wrote :

this was tracked at https://bugzilla.gnome.org/show_bug.cgi?id=658600 and seems to be fixed already on git.

affects: gtk+2.0 (Ubuntu) → ubuntu
Changed in ubuntu:
importance: High → Medium
status: New → Triaged
Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → gtk+2.0 (Ubuntu)
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Fix Released
Ader (rasmusrim) wrote :

With the newest upgrades today I can confirm that this bug has been fixed.

Leon Matthews (leon-matthews) wrote :

OP here.

Contrary to what Adar wrote above, I'm still seeing the issue, even after running update-manager this morning, with a reboot for good measure.

No worries though, I'm sure the fix will come through soon. I'm thrilled to have had my bug addressed -- I've received much better support than any commercial OS I've ever used! :-)

Chow Loong Jin (hyperair) wrote :

Closing the geany task since it's confirmed in #6 to be a Gtk+ bug.

Changed in geany (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.24.6-0ubuntu5

---------------
gtk+2.0 (2.24.6-0ubuntu5) oneiric; urgency=low

  * debian/patches/101_filechooser.patch
    - Fix a crash when opening file chooser dialog twice (LP: #851383)
 -- Mario Limonciello <email address hidden> Wed, 05 Oct 2011 13:43:25 -0500

Changed in gtk+2.0 (Ubuntu):
status: Triaged → Fix Released
Julian Taylor (jtaylor) wrote :

the issue was not fixed by ubuntu5 more commits need to be picked:
these should be enough to fix this issue: f4814585 aa8f54b736 79d16aab

Changed in gtk+2.0 (Ubuntu):
status: Fix Released → Triaged
Julian Taylor (jtaylor) wrote :

+ maybe 2a2edc9

Ader (rasmusrim) wrote :

The issue reappeared for me yesterday after having been gone for a couple of days...

Dmitry Shachnev (mitya57) wrote :

I still get this with gtk+2.0 2.24.6-0ubuntu5.

Patrick Dawkins (pjcdawkins) wrote :

This seems to have been fixed for me as of today... but I am still on the same GTK/Geany versions as above.

description: updated
Paul Natsuo Kishimoto (khaeru) wrote :

I am also still experiencing this bug:

$ apt-cache policy geany libgtk2.0-0
libgtk2.0-0:
  Installed: 2.24.6-0ubuntu5
  Candidate: 2.24.6-0ubuntu5
  Version table:
 *** 2.24.6-0ubuntu5 0
        500 http://mirrors.mit.edu/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
geany:
  Installed: 0.20-1.1ubuntu1
  Candidate: 0.20-1.1ubuntu1
  Version table:
 *** 0.20-1.1ubuntu1 0
        500 http://mirrors.mit.edu/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status

Patrick Dawkins (pjcdawkins) wrote :

Ignore my #19, it's still occurring. Same package versions as #20.

codef0rmer (amit-2006-it) wrote :

I am still experiencing the issue but could not wait until it gets resolved. So found the solution myself is to open a file in geany on CLI. This is a temporary fix.

$ geany foobar
So you can now open a new file using CTRL+O without crashing geany. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.