Incorperate Beagle searching into GtkFileChooser

Bug #49608 reported by Kevin Kubasik
14
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Wishlist
Ubuntu
Undecided
Unassigned
Declined for Feisty by Sebastien Bacher
gtk+2.0 (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Declined for Feisty by Sebastien Bacher

Bug Description

Binary package hint: libgtk2.0-0

There is a patch (linked bellow) which provides the ability to search beagle through the GtkFileChooser, or in other words, almost every file selection dialog known to gnome. Several other distributions (such as SuSE) are packaging this patch as part of their default Gtk toolkit.

http://primates.ximian.com/~federico/misc/gtk2-151580-filechooser-beagle.diff

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

Here is a link to Federico's original blog post detailing a little more about the patch.

http://primates.ximian.com/~federico/news-2006-02.html#16

Revision history for this message
Sebastien Bacher (seb128) wrote :

one task is enough

Changed in libgtk2.0-0:
status: Unconfirmed → Rejected
Revision history for this message
Sebastien Bacher (seb128) wrote :

We will look into this for edgy

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Untriaged → Wishlist
status: Unconfirmed → Confirmed
Revision history for this message
ChristofferS (ubuntu-curo) wrote :

You can find a newer patch here:

http://ftp.opensuse.org/pub/opensuse/distribution/SL-OSS-factory/inst-source/suse/src/gtk2-2.8.10-49.src.rpm

fakeroot alien that and look for gtk2-filechooser-new-features.diff

It is a newer patch.

I would like to point you to the novell bugzilla entry but novell has decided to block outsiders. Pretty weird!

Revision history for this message
Sebastien Bacher (seb128) wrote :

Do they have ported the patch to GTK 2.10? Is that a runtime option like for nautilus? What happens if GTK is patched and you don't want to use beagle?

Revision history for this message
ChristofferS (ubuntu-curo) wrote :

The patches seem Beagle-centric (BeagleHit etc.).

Maybe it would be best to wait for Gnome to make a solution for both tracker and Beagle.

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

Well, any solution is going to have to have BeagleHit in it (thats the beagle api..) There are tracker solutions out there, but they are very limited at the moment. There is support for tracker in nautilus, but not any real plan for support in Gtkfilechooser.

Suse already ships this patch, so we do inherit some nice testing and a good bet of upstream support for some time.

Just a thought, it would be really a nice integration. Plans for USlab add really nice beagle search support, the only real pain is that when uploading files to the web and stuff its hard to find them. This integration would be a real major step up in desktop integration and usability.

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

Here we go, I got an updated version of the patch.

Revision history for this message
ChristofferS (ubuntu-curo) wrote :

I think it would be best if this would only be enabled if beagle is installed.

It is not okay to require beagle because systems with 256 MB of RAM will suffer. I've got one, so I know.

I agree that beagle is cool and edgy+1 would really benefit of integrated search for systems that are more modern than mine.

beagle.h is included in the beagle-dev package (beagle-dev: usr/include/libbeagle/beagle/beagle.h). Which package is then required: beagle or libbeagle0?

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

libbeagle is needed to compile and run. So it depends on libbeagle, as libbeagle has the needed functions to determine if the beagle daemon is running etc. I belive this patch automatically detects if beagle is running and hides the search feature when no daemon is present.

Changed in gtk:
status: Unknown → Unconfirmed
Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote :

Well. If you ask me any search tool like this should expoxse a dbus api to avoid linking to lib<mysearchtool>... This is how Tracker does it anyway.

There's also a spec on this: https://launchpad.net/distros/ubuntu/+spec/integrated-desktop-search

Revision history for this message
ChristofferS (ubuntu-curo) wrote :

A patch for Tracker _and_ beagle integration found here:

http://bugzilla.gnome.org/attachment.cgi?id=76777&action=view

(belongs to bug http://bugzilla.gnome.org/show_bug.cgi?id=344785)

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

Just for conveniances sake, I have uploaded the above mentioned patch. I've tried to make a sucessful debdiff, but I can't quite get it. When just applied to the source, it compiles and seems to work, I'm just not familiar enough with how the gtk packages are structured to apply the patch that way.

Also, I have inquired upstream about integration into an upstream release and will post back when I've heard something.

Changed in gtk:
status: Unconfirmed → Confirmed
Revision history for this message
Kevin Kubasik (kkubasik) wrote :

Has anyone tried adding this patch to the ubuntu libgtk+2.0 package?

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

Ok, a quick update on this so we can look into making it official for feisty. Or at least decide on a course of action. The upstream probably won't have this in untill well after our available time slot for feisty, so if we want this well probably have to package it in. The nice part is that a gtk+ developer is packaging this patch in with Suse, so with each new gtk+ release, there will be a new and updated patch, so we have some semblance of long-term committment here, at least until the next major gtk release.

As far as actual application of the patch, it applies completely clean to a deb package, I'm a little unsure of how to add it to the gtk2 packages's patch system, so I'm holding off on that. The only real application issue is that the patch adds several files, which are added to the appropriate Makefile.am's, however our debian source packages don't run autotools on the source, so we would have to add the needed Makefile.in code to the patch. Otherwise, it builds smoothly and runs even better ;). In a perfect world we would have a better UI in some places, but its not all that different from the normal window minuse the icons.

Either way, given the advanced state of this patch, and the publics overwhelmingly positive response to beagle integration in SLED, I think this is really a win-win, assuming the packaging magic isn't too complicated.

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

A patched/generated Makefile.in, should be almost what we need to add to the patch for a smooth ubuntu build.

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

Just noting this in the Desktop Search Integration Spec wiki page. Dunno if we can still expect this in feisty, but I really hope we can, its a huge help, I use it daily at least.

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

Hey, anyone have any updates/thoughts on this, namely about it an Feisty?

Revision history for this message
Sebastien Bacher (seb128) wrote :

the patch breaks the GTK static built and we are too busy to spend time on that, if somebody wants to work at fixing the patch he's welcome though

Changed in gtk:
status: Confirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

the change has been commited upstream now

Changed in gtk+2.0:
status: Confirmed → Fix Committed
Revision history for this message
Kevin Kubasik (kkubasik) wrote :

This is the new upstream bug that fixes are being tracked at.

Changed in gtk:
status: Unknown → Unconfirmed
Changed in gtk:
status: Unconfirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

This upload fixes the bug:

 gtk+2.0 (2.11.2-0ubuntu1) gutsy; urgency=low
 .
   * New upstream version
   * debian/control.in:
     - Build-Depends on libxcomposite-dev and libxdamage-dev
     - updated glib and pango requirement
   * debian/patches/011_directfb-build-fixes-from-head.patch,
     debian/patches/013_gdkproperty-directfb-strdup.patch,
     debian/patches/025_dfb-window-destroy-leak.patch,
     debian/patches/031_cursor-blinking-timeout.patch,
     debian/patches/032_filechooser-sizing.patch,
     debian/patches/090_capslock-numlock-im-thai.patch:
     - dropped, fixed with the new version
   * debian/patches/021_loader-files-d.patch:
     - patch update from Loic Minier
   * debian/patches/030_gtkentry_password-char-circle.patch:
     - updated
   * debian/patches/040_filechooser_single-click.patch:
     - don't apply, Debian patch which needs to be reworked
   * debian/patches/070_mandatory-relibtoolize.patch:
     - updated
   * debian/rules:
     - updated shlibs version

Changed in gtk+2.0:
status: Fix Committed → Fix Released
Changed in gtk:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.