Screen flickers when loading applications

Reported by Jon Packard on 2008-07-04
70
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Invalid
High
NVIDIA Drivers Ubuntu
Undecided
Unassigned
X.Org X server
Fix Released
Medium
xf86-video-intel
New
Undecided
Unassigned
gtk+2.0 (Ubuntu)
High
Sebastien Bacher
Intrepid
High
Sebastien Bacher
xserver-xorg-video-nv (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

I'm using a NVidia GeForce 8600GT video card and experience problems when using the nv and nouveau xorg drivers. When I use the vesa driver, the problem is not present. During login and whenever an application is launched my entire screen flashes black repeatedly. I did not experience these problems in Hardy (tested nv and nvidia drivers).

Problem has happened with both Intrepid Alpha1 and Alpha2 releases.

Alpha1:
nv - flicker problem
nouveau - flicker problem
vesa - no problems
nvidia - failed to load module

Alpha2:
nv - flicker problem
nouveau - not tested
vesa - no problems
nvidia - no problems

Related branches

Chris Halse Rogers (raof) wrote :

Thank you for your bug report. I've assigned this bug to the most likely package, where it will get more useful attention.

Jon Packard (jonpackard) on 2008-07-09
description: updated
Jon Packard (jonpackard) on 2008-07-13
description: updated
Chris Halse Rogers (raof) wrote :

Additionally, I don't get this problem with nouveau on nv4B (Geforce 7600 go), and there seem to be intel and radeon users with a similar problem. It sounds like load-detect might be getting triggered on application launch, but that would seem strange.

Chris Halse Rogers (raof) wrote :

This may well prove to be a duplicate of bug 246836. Can you attach your xorg.conf, Xorg.0.log, output of 'sudo ddcprobe' and output of 'xrandr'?

Jon Packard (jonpackard) wrote :
Jon Packard (jonpackard) wrote :
Jon Packard (jonpackard) wrote :
Jon Packard (jonpackard) wrote :

Thanks Chris! See attached. By the way, running xrandr from gnome-terminal causes the flicker as well. Running non-gui commands does not cause the flicker.

Matt Philmon (mattisking) wrote :

Just to chime in... this happens to me as well but I run an ATI X800 All In Wonder video card with the Open Driver.

laroygreen (laroygreen) wrote :

I have a similar issue. I'm using an Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller rev 3 on an HP NC6220 laptop. The laptop screen is fine, but my SOHO TOPAZ S 24" LCD flickers once an application or dialog is launched.

It seems to only happen the first time the application is launched, i.e. if you are using nautilus (example), minimizing or opening a new nautilus window while one is already active, will NOT cause a flicker.

laroygreen (laroygreen) wrote :

I updated all my intrepid packages to the latest available and that still did not fix the issue. I ended up turning off the laptop display, and working only with the LCD and the problem went away. So, maybe this is related to dual (multiple) screen setups?

opslynx (ioan-ionita) wrote :

I have an Intel 945GM and am using dual screens in extended mode. I'm experiencing the screen flicker as well.
I've tracked down the issue to a problem with Xorg. For some reason, it does DDC detection every time a new application is open (so every time a new app connects to the X server).The following lines are printed in the /var/log/Xorg.0.log EVERY TIME an application is launched:

imi@orcl:~$ tail /var/log/Xorg.0.log -n 30
(II) intel(0): EDID vendor "SEC", prod id 17495
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1440x900"x0.0 95.44 1440 1504 1536 1744 900 903 906 912 -hsync -vsync (54.7 kHz)
(II) intel(0): EDID vendor "SEC", prod id 17495
(II) intel(0): EDID vendor "SAM", prod id 549
(II) intel(0): EDID vendor "SEC", prod id 17495
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1440x900"x0.0 95.44 1440 1504 1536 1744 900 903 906 912 -hsync -vsync (54.7 kHz)
(II) intel(0): EDID vendor "SEC", prod id 17495
(II) intel(0): EDID vendor "SAM", prod id 549
(II) intel(0): EDID vendor "SEC", prod id 17495
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1440x900"x0.0 95.44 1440 1504 1536 1744 900 903 906 912 -hsync -vsync (54.7 kHz)

This is clearly what is causing the screen flicker. We need to file a bug upstream against Xorg. Maybe one has been filed already. Anyone aware of this?

This bug should probably be moved to a more generic xorg package since it's not specific to nv. Maybe xserver-xorg-core ?

In the meantime, I've attached my /var/log/Xorg.0.log
Could others attach it as well to see if it is indeed the same issue? Thank you!

Pascal Lamblin (blip-aigri) wrote :

I have exactly the same symptoms as opslynx :

blip@siva ~% tail /var/log/Xorg.0.log
(II) intel(0): EDID vendor "ACR", prod id 44393
(II) intel(0): EDID vendor "SEC", prod id 17495
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1440x900"x0.0 108.20 1440 1486 1556 1928 900 909 918 935 -hsync -vsync (56.1 kHz)
(II) intel(0): EDID vendor "SEC", prod id 17495
(II) intel(0): EDID vendor "ACR", prod id 44393
(II) intel(0): EDID vendor "SEC", prod id 17495
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1440x900"x0.0 108.20 1440 1486 1556 1928 900 909 918 935 -hsync -vsync (56.1 kHz)
(II) intel(0): EDID vendor "SEC", prod id 17495

The same 5 lines are appended each time I open a new application.

I'm running an extended desktop with an external 1400x1050 LCD on top of my laptop's 1440x900 display.

From lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Pascal Lamblin (blip-aigri) wrote :

The same flickering (and DDC detection) also happen when "unlocking" an application protected by PolicyKit.

Same issue with an ATi X300 PCIE and Open Drivers. Screen flicker only occured for me in hardy when logging in, starting compiz, and opening programs in wine. I get the same screen flicker when opening any graphical app in intrepid. When fixed, will all situations where the flicker occurs be fixed? Or just specifically what is occurring now that didn't before?

James Blackwell (jblack) wrote :

I am seeing this problem as well, on both Hardy and Intrepid. Hardy worked fine for me until an upgrade about a week ago. Attempting to get away from it, I moved to Intrepid, which also shares the same problem. As with others, starting up gnome-termina, mozilla, or most any other application causes the dual-headed attached lcd monitor to flicker or blink, for about one second. Transitory windows, such as run application, do not cause the problem to happen.

The hardware here is a Gateway laptop with a Intel Mobile 945GM with a 1280x800 LCD and an external monitor at 1680x1050. In order to get dual heading to work, I added a Virtual desktop setup to my xorg.conf to five a resolution of 2960 x 1050.

#ubuntu+1 hints that this is possibly a problem with xrandr or load-detect, and isn't unique to NV, so this bug will probably get merged in with something else soon.

Jon Packard (jonpackard) wrote :

I am moving this to the xorg package and marking this as confirmed. I notice this has been reported by users of Intel, ATI and Nvidia graphics adapters.

Changed in xserver-xorg-video-nv:
status: New → Confirmed
Bryce Harrington (bryce) wrote :

I can confirm this happens on -nv with two monitors attached (but not set up for dual-head).
I've also seen flickering on -intel on a laptop, although it's character differs from the -nv flickering I'm seeing, so not sure it's exactly the same problem. Possibly...

I'm closing out the xserver-xorg-video-nv task since we don't need it against both. I'll also move the xorg bug to the server since it's probably a server issue.

For people seeing flickering on hardy, you're almost certainly seeing something unrelated, since we use different versions of xserver and the drivers there.

Changed in xserver-xorg-video-nv:
status: New → Invalid
Changed in xorg:
importance: Undecided → High
milestone: none → intrepid-alpha-5
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

Possibly related upstream bugs:

https://bugs.freedesktop.org/show_bug.cgi?id=17050:
[945GM/Mac] DSPARB split regression: screen flickers massivly when starting gnome apps
(appears to be -intel only though)

https://bugs.freedesktop.org/show_bug.cgi?id=16224
When running dual-heads on my 965, opening a new window causes the VGA output
to blank momentarily (a second or so), apparently while the xserver conducts an
EDID query judging from the hundreds of lines of modelines accumulating in my
Xorg.log. Running xf86-video-intel and xserver from git.

Changed in xorg-server:
status: Unknown → Invalid
Bryce Harrington (bryce) wrote :

According to the upstream bug, this is a problem in gtk, not in X. Reassigning package.

"If I'm not mistaken, EDID transfers are done in-band and thus will cause the
monitor to lose sync. There's really no way around it. From the recent thread
on the mailing list, it sounds like the solution is to fix GTK to not rely so
heavily on calls to XRRGetScreenResources()."

Changed in libgnome:
assignee: nobody → desktop-bugs
milestone: intrepid-alpha-5 → ubuntu-8.10-beta
status: Triaged → Confirmed
Changed in gtk+2.0:
status: Confirmed → Triaged
Changed in gtk:
status: Unknown → New

Yep, definitely has to be gtk. Running a qt app doesn't give the flicker.

James Blackwell (jblack) wrote :

How could there be no workaround, when gtk didn't do this as late as July? Surely something changed in the code base to cause this behavior to become more apparent.

opslynx (ioan-ionita) wrote :

A thread where a patch is proposed http://people.freedesktop.org/~ajax/patches/randr-deliver-events-dammit.patch
http://thread.gmane.org/gmane.comp.freedesktop.xorg/30567

Another thread where someone worked around the problem by reverting an upstream change in the
2.4.0 series (as mentioned on xorg ML).
http://www.nabble.com/-Cooker--xrandr-Issues-with-intel-2.4.0-driver-and-or-gtk%2B-td18639779.html
This person mentions that:

"I've fixed this on my system by reverting an upstream change in the
2.4.0 series (as mentioned on xorg ML).

I'll monitor the thread to see if a better fix presents itself.

New intel 2.4.0-2mdv should be out shortly. "

So maybe 2.4.0-2mdv will fix the issue?

Steve Langasek (vorlon) wrote :

Assigning to Sebastien as discussed at the release meeting today; Seb, Loïc has volunteered to help with this if needed.

Changed in gtk+2.0:
assignee: desktop-bugs → seb128
James Blackwell (jblack) wrote :

Bug revalidated 2008-10-07, with xserver-xorg-video-intel 2.4.1-1u

ecsdrive (ecsdrive) wrote :

The problem seems to be solved with the latest driver, at least on intel GMA965 / X3100

aptitude show xserver-xorg-video-intel
Package: xserver-xorg-video-intel
State: installed
Automatically installed: no
Version: 2:2.4.1-1ubuntu2

Lewis Thompson (purple) wrote :

I'm still experiencing the issue with 2:2.4.1-1ubuntu2 on GMA965/X3100

Andreas (andreas-kotowicz) wrote :

the driver update didn't fix the problem for me either (GM965/GL960)

Mario Peter (mp-mpeter) wrote :

I made a upgrade right now, and the problem disappeared :-) GM965/X3100

Package: xserver-xorg-video-intel
State: installed
Automatically installed: yes
Version: 2:2.4.1-1ubuntu4

Lewis Thompson (purple) wrote :

Still experiencing the issue with 2:2.4.1-1ubuntu4 :(

Jeremy Bender (jerm0000) wrote :

I just did the latest upgrades for 8.10, with the intel drivers and still have the screen blanking issue as well.
Using the intel 945 chipset on a mini mac.

Sebastien Bacher (seb128) wrote :

could people stop adding comments to this bug to confirm it? you are mail spamming everybody subscribed, the bug is still open which means it's not fixed yet

Tormod Volden (tormodvolden) wrote :

You are showing a pretty negative attitude towards people contributing information. Especially since the bug has disappeared for some people it can be interesting to know it hasn't for others (granted, we don't tons of me-toos in this case). Bug report status is not always perfectly in sync with the real status, some bugs gets fixed "magically". It's of great value for Ubuntu that people comment in the bug tracker and keep bug reports "alive". For those who don't like users there are more developer-oriented projects like Debian and Gnome. If you get too much bug mail, learn how to filter mail and/or get for instance a gmail account. In the end it takes less than a second to dismiss/delete useless comments. Like this very one :)

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gtk+2.0:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.14.2-0ubuntu1

---------------
gtk+2.0 (2.14.2-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Don't use XRRGetScreenResources, since it doesn't work well
      (lp: #245383, #258498)
    - Bugs fixed:
    551063 deprecated marking without a link to what new code should use
    319849 gtkcalendar look in RTL locales
    550989 gdk_display_put_event should call g_main_context_wakeup
    550062 Small update in gdk/gdkkeysyms.h
    551325 Reference to wrong parameter in gtk_editable_insert_text
    551386 gtk_printer_set_is_default() always sets TRUE
    550676 Memory leak, update keyboard layout data structure
    551699 gtk_scrolled_window_destroy() is broken
    551567 DND mark broken
    551378 Print dialog: should try UDS when fetching PPD for localhost
    536542 gtk_list_store_set() documentation doesn't say whether...
    552153 GtkModules loading with XSettings doesn't work...
    552001 gtkimcontextsimple.c: variable is declared at middle...
    551987 GtkPaned redrawing problem
    551722 gtk_widget_set_scroll_adjustments() should check...
    552107 Small libtool fixes
    552500 GtkPrintSettings API doc not precise enough
    408154 Change GtkEntryCompletion max-items to style property
    329593 Entering characters on a line very cpu intensive and slow
    552667 gtkimage containing gicon leaks memory
    552668 format not a string literal and no format arguments...
    346903 gtk_enumerate_printers needs events to complete
    550969 fix a typo which breaks the static build
    517233 Calling gdk_pixbuf_loader_close causes "GError set over...
    551063 deprecated marking without a link to what new code should use
    540967 docs build slowly because of entities
  * debian/patches/021_loader-files-d.patch:
    - new version update
  * debian/patches/080_correct_typo_fix_static_build.patch:
    - the change is in the new version
  * debian/patches/092_gtkadjustement_doesnt_use_page_size_value.patch:
    - revert the change which makes gtkadjustement use the page_size setting
      to determinate the gtkadjustement upper value for now, that's confusing
      lot of applications and should be done earlier in a cycle

 -- Sebastien Bacher <email address hidden> Thu, 18 Sep 2008 11:00:43 +0200

Changed in gtk+2.0:
status: Fix Committed → Fix Released
djtm (djtm) wrote :

I still see this bug in intrepid or a similar one: Static dual head xorg.conf, intel driver, intrepid with all of today's updates.

The main differece is that I don't have to load an application or do anything at all for the "black out" to appear.

The external monitor goes black for a second and at the same time
(II) intel(0): Printing DDC gathered Modelines:
appears in my Xorg.0.log.
Video playback on the other screen stutters at the same time.

Any hints?

Ben Gamari (bgamari) wrote :

I have also observed this behavior with the listed package. It seems that something other than gtk+ is triggering an output probe.

2008/10/28 Ben Gamari <email address hidden>:
> I have also observed this behavior with the listed package. It seems
> that something other than gtk+ is triggering an output probe.

I'm seeing flickering with the current intrepid packages for X. I
tested upstream and it appears to be fixed there.

debiani386 (debiani386) wrote :

On Sun, Sep 7, 2008 at 12:18 AM, James Blackwell <email address hidden>wrote:

> Bug revalidated 2008-10-07, with xserver-xorg-video-intel 2.4.1-1u
>
> --
> Screen flickers when loading applications
> https://bugs.launchpad.net/bugs/245383
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in gtk: New
> Status in X.Org X server: Invalid
> Status in X.org xf86-video-intel: New
> Status in "gtk+2.0" source package in Ubuntu: Triaged
> Status in "xserver-xorg-video-nv" source package in Ubuntu: Invalid
> Status in gtk+2.0 in Ubuntu Intrepid: Triaged
> Status in xserver-xorg-video-nv in Ubuntu Intrepid: Invalid
>
> Bug description:
> I'm using a NVidia GeForce 8600GT video card and experience problems when
> using the nv and nouveau xorg drivers. When I use the vesa driver, the
> problem is not present. During login and whenever an application is launched
> my entire screen flashes black repeatedly. I did not experience these
> problems in Hardy (tested nv and nvidia drivers).
>
> Problem has happened with both Intrepid Alpha1 and Alpha2 releases.
>
> Alpha1:
> nv - flicker problem
> nouveau - flicker problem
> vesa - no problems
> nvidia - failed to load module
>
> Alpha2:
> nv - flicker problem
> nouveau - not tested
> vesa - no problems
> nvidia - no problems

I had that problem too back in my ubuntu days (i use an INTEL card here
too), but the new version of mandriva doesnt seem to do that. The bug has
been filed (as others have stated) in launch pad.

-cj

Ben Gamari (bgamari) wrote :

My Fedora Rawhide box also doesn't exhibit this issue.

djtm (djtm) wrote :

I've added another bug which is most likely the cause at least for me.

Changed in xorg-server:
status: Invalid → Unknown
Changed in xorg-server:
status: Unknown → Confirmed
djtm (djtm) wrote :

It can neither be related to Xorg (incl. the intel driver) nor to KDE.
I can start X and KDE manually without problems. And it starts only at some (late) point during loading the session.
But I'm still stuck trying to find the exact program that causes the constant problems for me...
@Sceptic how did you check upstream?

Sceptic (keith-no) wrote :

2008/10/30 djtm <email address hidden>:
> @Sceptic how did you check upstream?

Cloned the git repositories and built them using the script from the wiki.

I can't be sure it's the same bug, of course. The symptoms I see are
that I get flickers every ten or so seconds until I set up a dummy
output using xrandr. This is on intel 965GM, btw.

djtm (djtm) wrote :

When I manually start X, then e.g. konsole and plasma I have no problems.
When I start ksmserver the problems begins - not immediately, but after a few seconds. And I couldn't find what I have to disable to stop that, because I've got no idea, what exactly ksmserver does, except starting everything in ksmserverrc.

@sceptic Using KDE? 10 second flicker on KDE: https://bugs.launchpad.net/ubuntu/+source/meta-kde/+bug/278471

D (dj-lp) wrote :

As the bug is still there in libgtk2.0-0: 2.14.4-0ubuntu1, the released fix did not work.
Thus I remove the Fix Released status.

Changed in gtk+2.0:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

gtk has been changed to not call the expensive xorg api, if you have an issue that's a different one

Changed in gtk+2.0:
status: Confirmed → Fix Released
Sceptic (keith-no) wrote :

2008/11/6 Chris Bainbridge <email address hidden>:
> @sceptic Using KDE? 10 second flicker on KDE:
> https://bugs.launchpad.net/ubuntu/+source/meta-kde/+bug/278471

Yes, that's very much the same bug.

And upstream seems to have an actual fix, rather than just another workaround.

Changed in xorg-server:
status: Confirmed → Fix Released
Changed in xorg-server:
status: Fix Released → Confirmed
debiani386 (debiani386) wrote :

Im running an intel 945gm on my laptop and i never had this problem...

i used to have it back on ubuntu 8.04, but mandriva 2008 (which had the same
version of xorg as ubuntu 8.04 did i believe) and 2009 ran smoothely
--cj

On Tue, Jan 20, 2009 at 4:00 PM, Bug Watch Updater <
<email address hidden>> wrote:

> ** Changed in: xorg-server
> Status: Fix Released => Confirmed
>
> --
> Screen flickers when loading applications
> https://bugs.launchpad.net/bugs/245383
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in gtk: New
> Status in X.Org X server: Confirmed
> Status in X.org xf86-video-intel: New
> Status in "gtk+2.0" source package in Ubuntu: Fix Released
> Status in "xserver-xorg-video-nv" source package in Ubuntu: Invalid
> Status in gtk+2.0 in Ubuntu Intrepid: Fix Released
> Status in xserver-xorg-video-nv in Ubuntu Intrepid: Invalid
>
> Bug description:
> I'm using a NVidia GeForce 8600GT video card and experience problems when
> using the nv and nouveau xorg drivers. When I use the vesa driver, the
> problem is not present. During login and whenever an application is launched
> my entire screen flashes black repeatedly. I did not experience these
> problems in Hardy (tested nv and nvidia drivers).
>
> Problem has happened with both Intrepid Alpha1 and Alpha2 releases.
>
> Alpha1:
> nv - flicker problem
> nouveau - flicker problem
> vesa - no problems
> nvidia - failed to load module
>
> Alpha2:
> nv - flicker problem
> nouveau - not tested
> vesa - no problems
> nvidia - no problems
>

Thomas Pilarski (thomas.pi) wrote :

I have noticed, that the following message is printed out, when this flickers begins.

CE: hpet increasing min_delta_ns to 15000 nsec

Are AMD uses affected by this problem? AFAIK: There is no hpet clocksource on am systems.

Changed in xorg-server:
status: Confirmed → Fix Released
Changed in gtk:
status: New → Invalid
primefalcon (primefalcon) wrote :

I am not sure if this is the same problem or not but...

I am using an ati (I have an x1300) card with open source drivers, I am having this problem when I open apps in wine or java (screen flickers as if changing res modes)

primefalcon (primefalcon) wrote :

Oh for reference I am using Ubuntu 9.04

Changed in xorg-server:
importance: Unknown → Medium
Changed in gtk:
importance: Unknown → High
status: Invalid → Unknown
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
Changed in gtk:
status: Unknown → Invalid
Ads20000 (ads20000) wrote :

Added the same problem with the Nvidia drivers: http://askubuntu.com/questions/281060/screen-flickers-with-nvidia-gpu

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.