Software center's category menu is unreadable with GTK 3.8

Bug #1173611 reported by Julien Olivier on 2013-04-27
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Medium
gtk+3.0 (Ubuntu)
Undecided
Unassigned
software-center (Ubuntu)
High
Unassigned

Bug Description

In Ubuntu GNOME, the category menu on the left side of the software center is unreadable with GTK3.8 from the Ubuntu Desktop PPA.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: software-center 5.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
Date: Sat Apr 27 15:01:45 2013
InstallationDate: Installed on 2010-09-15 (954 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: Upgraded to raring on 2011-04-01 (757 days ago)

Julien Olivier (julo) wrote :
Julien Olivier (julo) wrote :
Jeremy Bicha (jbicha) on 2013-04-27
summary: - Software center's category menu is unreadable on GNOME 3
+ Software center's category menu is unreadable with GTK 3.8
Jeremy Bicha (jbicha) on 2013-04-27
description: updated
Jeremy Bicha (jbicha) on 2013-04-27
Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Adolfo Jayme (fitojb) on 2013-04-28
no longer affects: gtk+3.0 (Ubuntu)
Tim Lunn (darkxst) wrote :

It appears here that GtkLabel is not getting the correct calculated height when text wrapping is enabled. Probably this is a gtk bug, however I cannot reproduce it with gtk git master (I also can't find any commits that look like they would resolve the issue).

Linked branch works around the issue by disabling text-wrapping in the category pane, however its probably best to find and fix the underlying bug.

Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Tim Lunn (darkxst) wrote :

fixed gtk on gnome3-staging, and will be fixed upstream in 3.8.2

Changed in ubuntu:
status: New → Confirmed
Tim Lunn (darkxst) on 2013-05-10
affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Fix Released
affects: ubuntu → gtk+3.0 (Ubuntu)
Changed in software-center (Ubuntu):
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

Hum, why did you make your own version of GTK rather than using the one from the ubuntu-desktop ppa which already includes that fix?

Tim Lunn (darkxst) wrote :

oh, I had not seen that one ;(

Changed in gtk:
status: New → Incomplete
Changed in gtk:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.