Reporting fails when only one activity has been logged

Bug #778285 reported by Jeroen Langeveld on 2011-05-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GTimeLog
Medium
Barry Warsaw
gtimelog (Ubuntu)
Undecided
Unassigned

Bug Description

Reporting works fine when NOTHING was reported ("No work done today.").
However, when the initial activity was logged, but nothing else, the enumeration of categories fails:

-----
Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/gtimelog-0.5.0-py2.6.egg/gtimelog/main.py", line 1572, in on_daily_report_activate
    self.mail(reports.daily_report)
  File "/usr/local/lib/python2.6/dist-packages/gtimelog-0.5.0-py2.6.egg/gtimelog/main.py", line 1727, in mail
    write_draft(draft, self.settings.email, self.settings.name)
  File "/usr/local/lib/python2.6/dist-packages/gtimelog-0.5.0-py2.6.egg/gtimelog/main.py", line 709, in daily_report
    if categories:
UnboundLocalError: local variable 'categories' referenced before assignment
-----

Related branches

Barry Warsaw (barry) on 2011-08-17
Changed in gtimelog:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Barry Warsaw (barry)
status: Confirmed → Fix Committed
Barry Warsaw (barry) on 2011-08-17
Changed in gtimelog:
milestone: none → 0.6
Barry Warsaw (barry) on 2011-08-23
Changed in gtimelog:
status: Fix Committed → Fix Released
affects: ubuntu → gtimelog (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtimelog - 0.6.0-0ubuntu1

---------------
gtimelog (0.6.0-0ubuntu1) oneiric; urgency=low

  * debian/watch: Update for new location on Launchpad.
  * New upstream release. Changes since to our bzr snapshot and patches:
    - Ctrl-Q now quits. (LP: #750092)
    - Fixed UnboundLocalError. (LP: #778285)
    - Hide the main window on Esc. (LP: #716257)
  * Drop patches which are upstream now:
    - fix-gobject-import
    - fix-appindicator
    - gi_require_version_api
    - pango_tab_align
  * debian/patches/force-gi: Unfuzz.
  * Add debian/patches/gi-fixes: Fix working with current Pango, and missing
    import.
  * debian/control: Bump gir1.2-pango-1.0 dependency to a version with
    unbroken GIR.
  * debian/control: Bump GIR dependencies for GTK 3.
 -- Martin Pitt <email address hidden> Tue, 20 Sep 2011 12:12:26 +0200

Changed in gtimelog (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers