Rename "backends" to "Sync(hronization) services" everywhere in the UI.

Bug #962642 reported by Bertrand Rousseau on 2012-03-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Anant Gupta

Bug Description

"Backends" is actually quite a technical term. It is probably not clear for many users not versed in programming. We should find a more accessible term. (thanks Radina for poiting this!)

Related branches

Izidor Matušov (izidor) wrote :

Just few ideas from top of my head:
 * task sources
 * synchronization

What do you think about them?

Changed in gtg:
importance: Wishlist → Medium

I'll put an emphasis on the "synchronization" stuff: after all, this
is the core service backends provide.

I like the idea of having a "Sync with online services" or "Sync with
other services". Maybe the second one is more appropriate since we
actually offer many sync services that work locally, with other apps
(Tomboy, GNote, Local file).

Btw, I think the default "Local file" backend should not be displayed
if we opt for "Synchronization services". Users can't edit it anyway.
(that can become another bug if needed)

2012/3/23 Izidor Matušov <email address hidden>:
> Just few ideas from top of my head:
>  * task sources
>  * synchronization
>
> What do you think about them?
>
> ** Changed in: gtg
>   Importance: Wishlist => Medium
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/962642
>
> Title:
>  Rename "backends"
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/962642/+subscriptions

--
Bertrand Rousseau

In my opinion the backend term is not clear. We have discussion how to translate "backends" into Russian with Alexey Ivanov and we decide to use a word that means "Source for anything", "storage", "vault", and so on.

Hi,

I've also thought about 'Storage', but I don't really like it, because
that still doesn't express what it brings to the user.

I have a hunch for "Synchronization services". The advantage it brings
to the user is clear. What do you think? Would there be a reason not
to opt for this?

On Mon, Mar 26, 2012 at 9:38 PM, DmDr <email address hidden> wrote:
>
> In my opinion the backend term is not clear. We have discussion how to
> translate "backends" into Russian with Alexey Ivanov and we decide to
> use a word that means "Source for anything", "storage", "vault", and so
> on.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/962642
>
> Title:
>  Rename "backends"
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/962642/+subscriptions

--
Bertrand Rousseau

I like Synchronization services. The only problem I can think of is its length - it might not fits to smaller UI widgets.

Radina Matic (radina-matic) wrote :

Easiest short solution would be "Sync Services", even Google has them so it should not be difficult to understand... :P

User Documentation could explain the concept in detail and state the difference between "Sync with online services" and "Sync with
other services".

Ok, so let's go for "Sync services" or "Synchronization services",
depending on the available space, it's still better than backends.

On Tue, Mar 27, 2012 at 6:53 AM, Radina Matic <email address hidden> wrote:
> Easiest short solution would be "Sync Services", even Google has them so
> it should not be difficult to understand... :P
>
> User Documentation could explain the concept in detail and state the difference between "Sync with online services" and "Sync with
> other services".
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/962642
>
> Title:
>  Rename "backends"
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/962642/+subscriptions

--
Bertrand Rousseau

summary: - Rename "backends"
+ Rename "backends" to "Sync(hronization) services" everywhere in the UI.
Changed in gtg:
milestone: none → 0.3.1
milestone: 0.3.1 → 0.3
Izidor Matušov (izidor) on 2012-03-27
Changed in gtg:
status: Confirmed → Triaged
Anant Gupta (anantzoid) on 2012-03-27
Changed in gtg:
assignee: nobody → Anant Gupta (anantzoid)
Anant Gupta (anantzoid) wrote :

The places in UI where I spotted the term "bacekends" were:
Edit -> backends
Backends dialog-> Add new backend
On Delete-> Do you want tor emove this backend?

I've updatede them to Sync services. Please inform me if the tem exists anywhere else in the UI.

Anant Gupta (anantzoid) on 2012-04-01
Changed in gtg:
status: Triaged → In Progress

If you do the search for "backend" in
Translation<https://translations.launchpad.net/gtg/trunk/+pots/gtg/en_GB/+translate?batch=10&show=all&search=backend>,
you'll get 12 strings. Not all of them are part of GUI elements like
buttons and menu options, but all should be changed to "Sync services"...

On Sun, Apr 1, 2012 at 06:55, Anant Gupta <email address hidden> wrote:

> The places in UI where I spotted the term "bacekends" were:
> Edit -> backends
> Backends dialog-> Add new backend
> On Delete-> Do you want tor emove this backend?
>
> I've updatede them to Sync services. Please inform me if the tem exists
> anywhere else in the UI.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/962642
>
> Title:
> Rename "backends" to "Sync(hronization) services" everywhere in the
> UI.
>
> Status in Getting Things GNOME!:
> Triaged
>
> Bug description:
> "Backends" is actually quite a technical term. It is probably not
> clear for many users not versed in programming. We should find a more
> accessible term. (thanks Radina for poiting this!)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/962642/+subscriptions
>

Anant Gupta (anantzoid) wrote :

The term "backend" is in translated documentation, ant not the UI.
I wasn't aware that I have to change there too.
Isn't changing it in the UI not enough, as mentioned in the bug description?

You don't have to change it (at least not with a commit). But translators will have to update the related strings once the code is updated.

Izidor Matušov (izidor) wrote :

Anant > You can get the list of missing changes by running

./scripts/generate_potfile.sh > /dev/null 2>&1 && grep -i 'backend' po/gtg.pot | grep -v '^#'

All transable strings could be shown to user and must be changed to complete this bug.

Radina > Don't forget what you see might be quite old snapshot of strings because they had to be manually updated.

General question: Do we want to replace all recurrences of word backend? I vote for that.
When dealing with code, it is more likely to use backend term because I think about things as backends. Instead of having two terms for the same thing and choosing the correct one, having just one would make the life much more easy -- one item less to think about. What's your opinion?

Izidor Matušov (izidor) on 2012-04-01
Changed in gtg:
status: In Progress → Incomplete

Izidor> I suggest we open another bug for that since it's a separate developer-oriented discussion. However, on a personal note, I'm ok with it (but note that I actually don't play with that code, so this would not be confusing for me neither...)

Radina Matic (radina-matic) wrote :

On Sun, Apr 1, 2012 at 20:43, Izidor Matušov <email address hidden>wrote:

> Anant > You can get the list of missing changes by running
>
> ./scripts/generate_potfile.sh > /dev/null 2>&1 && grep -i 'backend'
> po/gtg.pot | grep -v '^#'
>
> All transable strings could be shown to user and must be changed to
> complete this bug.
>
> Radina > Don't forget what you see might be quite old snapshot of
> strings because they had to be manually updated.
>
>
Dully noted... Do you have a specific schedule when you perform these
manual string-update tasks in Launchpad?

> General question: Do we want to replace all recurrences of word backend? I
> vote for that.
> When dealing with code, it is more likely to use backend term because I
> think about things as backends. Instead of having two terms for the same
> thing and choosing the correct one, having just one would make the life
> much more easy -- one item less to think about. What's your opinion?
>
>
We definitely have to replace all recurrences of the term in the GUI,
dialog boxes, alert messages, info and user docs.... In short, everything
viewable by the users.

All the rest depends on you/us... If we agree that the benefit of having
only one term all around outweighs the inconvenience of having to stop
using another more habitual term... I am not a coder, so that's something
you guys should decide among yourselves.

Cheers,
Radina

> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/962642
>
> Title:
> Rename "backends" to "Sync(hronization) services" everywhere in the
> UI.
>
> Status in Getting Things GNOME!:
> In Progress
>
> Bug description:
> "Backends" is actually quite a technical term. It is probably not
> clear for many users not versed in programming. We should find a more
> accessible term. (thanks Radina for poiting this!)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/962642/+subscriptions
>

Izidor Matušov (izidor) wrote :

For term "backend" in code, there is bug #971672

Izidor Matušov (izidor) wrote :

Radina> I update the template for translations once in a while without any schedule. Of course, it is going to be updated before releasing the next version. You can ping me to update it.

Izidor Matušov (izidor) wrote :

Fixed in rev 1149, template translation for GTG were updated, soon in Launchpad ;)

Changed in gtg:
status: Incomplete → Fix Committed
Radina Matic (radina-matic) wrote :

There is still a "backend" in template translation at GTG/gtk/browser/custominfobar.py:36:

"The <b>%s</b> backend cannot login with the supplied authentication data and has been disabled. To retry the login, re-enable the backend."

Should I file a separate bug for it...?

Well, maybe you're using old code, since in the current trunk (rev. 1232), the template file is correct: https://bazaar.launchpad.net/~gtg/gtg/trunk/view/head:/po/gtg.pot#L927

Anyway, I'll update the translation template.

Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers