User is not warned if gnote back-end fails to connect

Bug #932877 reported by Branko Majic on 2012-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Izidor Matušov

Bug Description

Steps to reproduce:

1. Make sure that gnote is not started.
2. Edit -> Backends -> Add
3. Select Gnote as backend, click on "Ok"
4. Select the new backend and click on the "Enable syncing" button

Expected results:

User is warned that the Gnote service isn't reachable (maybe even disabling the backend).

Actual results:

No error is reported, except if you ran the GTG in terminal.

Trace:

Exception in thread Thread-6:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 552, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/threading.py", line 505, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/home/branko/src/gtg/GTG/core/datastore.py", line 656, in __start_get_tasks
    self.backend.start_get_tasks()
  File "/home/branko/src/gtg/GTG/tools/interruptible.py", line 39, in new
    return fn(*args)
  File "/home/branko/src/gtg/GTG/backends/generictomboy.py", line 101, in start_get_tasks
    with self.TomboyConnection(self, *self.BUS_ADDRESS) as tomboy:
  File "/home/branko/src/gtg/GTG/backends/generictomboy.py", line 525, in __init__
    obj = bus.get_object(bus_name, bus_path)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 246, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Gnote was not provided by any .service files

Exception in thread Thread-10:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 552, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/threading.py", line 505, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/home/branko/src/gtg/GTG/core/datastore.py", line 656, in __start_get_tasks
    self.backend.start_get_tasks()
  File "/home/branko/src/gtg/GTG/tools/interruptible.py", line 39, in new
    return fn(*args)
  File "/home/branko/src/gtg/GTG/backends/generictomboy.py", line 101, in start_get_tasks
    with self.TomboyConnection(self, *self.BUS_ADDRESS) as tomboy:
  File "/home/branko/src/gtg/GTG/backends/generictomboy.py", line 525, in __init__
    obj = bus.get_object(bus_name, bus_path)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 246, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Gnote was not provided by any .service files

Exception in thread Thread-12:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 552, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/threading.py", line 756, in run
    self.function(*self.args, **self.kwargs)
  File "/home/branko/src/gtg/GTG/backends/genericbackend.py", line 639, in launch_setting_thread
    self.set_task(task)
  File "/home/branko/src/gtg/GTG/tools/interruptible.py", line 39, in new
    return fn(*args)
  File "/home/branko/src/gtg/GTG/backends/generictomboy.py", line 260, in set_task
    with self.TomboyConnection(self, *self.BUS_ADDRESS) as tomboy:
  File "/home/branko/src/gtg/GTG/backends/generictomboy.py", line 525, in __init__
    obj = bus.get_object(bus_name, bus_path)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 246, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Gnote was not provided by any .service files

Related branches

Branko Majic (branko-majic) wrote :

This probably affects the Tomboy backened as well (since it's almost the same backend with different service names).

Izidor Matušov (izidor) on 2012-02-15
Changed in gtg:
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → Izidor Matušov (izidor)
milestone: none → 0.3
Izidor Matušov (izidor) on 2012-04-22
Changed in gtg:
importance: Critical → Medium
assignee: Izidor Matušov (izidor) → nobody
Izidor Matušov (izidor) on 2012-06-01
Changed in gtg:
assignee: nobody → Izidor Matušov (izidor)
status: Confirmed → In Progress
Izidor Matušov (izidor) on 2012-07-24
Changed in gtg:
status: In Progress → Fix Committed
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers