Drag'n'Drop task on "Task without tags" remove tags but does not update view

Bug #896798 reported by Izidor Matušov on 2011-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Low
Xuan (Sean) Hu

Bug Description

Steps to reproduce:
  1, a task that is assigned a tag
  2, the task is shown in the active pane
  3, drag and drop the task on "Tasks without tags"

Expected result:
All tags from the task are removed *and* task in the active pane is removed/updated

Actual result:
The tags are removed but the task is not updated so it looks like nothing has happened. Opening the task and closing it solve this problem.

(It should be easy to fix this bug, just task.modified() after Drag'n'Drop, setting to love :-)

Related branches

Izidor Matušov (izidor) wrote :

Fix was merged in rev 1114

Changed in gtg:
assignee: nobody → huxuan (huxuan)
status: Confirmed → Fix Committed
Song Yangyu (flyfy1) wrote :

Hi, there's a slight problem with this issue.
The current fix is to remove the whole tag inside the text-buffer, but sometimes people like to use the tag with meaning inside a string also. For example:

Discuss with @boss about @work by 3pm.

Then if we move this task to the "Tasks without tags", then the @boss and @work would be removed, left with string:
Discuss with about by 3pm.

Izidor Matušov (izidor) wrote :

That's the problem of TaskEditor design. We should address this problem in TaskEditor rework (adding a comment to the blueprint): https://live.gnome.org/gtg/blueprints/taskeditor-rework

Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers