After deleting/making as done of parent, children editor is not closed

Bug #887053 reported by Izidor Matušov on 2011-11-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Lionel Dricot

Bug Description

Let's have following tasks:
- a
-- b

Open editor for task b. Then switch to main window and delete task a or mark it as done. Editor for 'b' is still open although task does not exists anymore (if the parent was removed).

Sometimes it raises a traceback: (not able to reproduce it on script/debug.sh)

Traceback (most recent call last):
  File "/usr/share/gtg/GTG/gtk/editor/editor.py", line 436, in delete_task
    self.vmanager.ask_delete_tasks([self.task.get_id()])
  File "/usr/share/gtg/GTG/gtk/manager.py", line 215, in ask_delete_tasks
    if self.delete_dialog.delete_tasks(tids):
  File "/usr/share/gtg/GTG/gtk/delete_dialog.py", line 96, in delete_tasks
    recursive_list_tasks(tasks, task)
  File "/usr/share/gtg/GTG/gtk/delete_dialog.py", line 93, in recursive_list_tasks
    for i in root.get_subtasks():
AttributeError: 'NoneType' object has no attribute 'get_subtasks'

Also have a look at the duplicate of this bug - bug #826683

Izidor Matušov (izidor) on 2012-02-13
description: updated
tags: added: love
removed: editor
Lionel Dricot (ploum) on 2012-02-14
Changed in gtg:
assignee: nobody → Lionel Dricot (ploum)
Lionel Dricot (ploum) wrote :

rev 1074 solve the delete use case

Changed in gtg:
status: Confirmed → Fix Committed
Lionel Dricot (ploum) wrote :

For the "mark as done", this is a separate issue as marking a task as done from the browser never close an open editor.

Izidor Matušov (izidor) wrote :

Lionel> I think the linked (duplicate) bug is the bug asking for closing after "mark as done". Nevertheless, I added support for mark as done and also dismissing in rev 1076.

I found a bug: when deleting many tasks, tasks list was reduced only to first X tasks and some tasks weren't closed afterwards. It is also fixed in rev 1076.

Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers