GTG stable no longer starts after trying trunk

Bug #827658 reported by Christian Dywan on 2011-08-16
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Critical
Izidor Matušov

Bug Description

After running GTG trunk once, and going back to the distro-provided stable, ie. 0.2.4, I get:

ImportError: No module named backend_localfile

I don't know about the internal storage, so speaking only from a user perspective here. I was originally a bit puzzled because opening from the dash would result in a waiting pointer and nothing happening and nothing else. Until I realized I could try running trunk again.
So I would at least expect a graphical message, if it's not feasible to be backwards-compatible. I'm in a bit of a catch-22 now between stable without my tasks and unstable with bugs.

Running latest bzr trunk on openSuse/ GnomeShell.

Related branches

Lionel Dricot (ploum) wrote :

I confirm this bug. I'm not sure what has change exactly and also I'm not sure how to fix that because the patch has obviously to go to the stable version.

Anyway, we will have a daily PPA soon.

Changed in gtg:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → 0.2.9
Izidor Matušov (izidor) wrote :

Christian > I am sorry for inconvenience. We should definitely patch the stable version before releasing 0.2.9. Maybe we can provide for 0.2.9 and 0.3 script which will revert tasks back. There is a quick workaround how to enable your 0.2.4 tasks:

1, Open your projects.xml file located at ~/.local/share/gtg/projects.xml.
2, Edit backend element:
  -> replace module="backend_localfile" by module="localfile"
  -> replace attribute name path="<your path>" by filename="<your path>"

Save and GTG 0.2.4 starts correctly. (I've tried it on my own tasks, it works)

If you want to test the trunk, you should do that by these two scritps
scripts/import_my_tasks_into_debug_tasks.sh
scripts/debug.sh

Changed in gtg:
assignee: nobody → Izidor Matušov (izidor)
Christian Dywan (kalikiana) wrote :

Ah, so the tasks don't really change, it's just renaming? How about reverting the rename then, instead of changing stable? And save the effort for the time when there's a real break in the storage format.

And in either case I would suggest a graphical error message with a way to Cancel or Clear all tasks. This would also help if files are corrupted for whatever reason.

Christian Dywan (kalikiana) wrote :

In fact the tasks DID change, the suggested fix doesn't recover all my tasks.

Izidor Matušov (izidor) on 2011-11-26
Changed in gtg:
status: Confirmed → In Progress
Izidor Matušov (izidor) wrote :

Christian> I've patched GTG 0.2.4, so downgrade should work now. Please test it.

#backup your tasks
cp -r ~/.local/share/gtg ~/backup-gtg

# Run GTG 0.2.9, make some modification, etc
bzr branch lp:gtg gtg029
cd gtg029
./gtg
cd ..

# Run the patched GTG 0.2.4
bzr branch lp:gtg/0.2 gtg024
cd gtg024
./gtg

# Or run downgrade script
./downgrade-gtg-0.2.9.py

-----------------------------------
I and several other people have tested it, it should work. It removes every backend but localfile and convert ids in the localfile. In other words, it is not a lossless downgrade (it is not possible to do that).

If you don't find any problems, I would like to release this patch as 0.2.5 and so enable to users to play with GTG 0.2.9.

----------------------------------

Fix Committed means in the lp:gtg/0.2 (because it is bug against this version) in rev696

Changed in gtg:
status: In Progress → Fix Committed
Izidor Matušov (izidor) on 2011-12-01
Changed in gtg:
milestone: 0.2.9 → 0.2.5
Izidor Matušov (izidor) on 2011-12-01
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers