GTG

all tasks deleted after sync with RTM

Bug #753327 reported by charly
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
GTG
Fix Released
Critical
Alan
gtg (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

I sync GTG (0.2.4. - official ppa on ubuntu 10.10) with RTM. This worked good until 3 days ago.
The sync deleted all my task! - I got them back after the next sync, but unsorted. I restructured them and synced again - no problem for the next day.
Today the sync deleted all tasks again and the sync is no longer working it just starts syncing and then sys it is ready, without doing anything

The debug mode has no output, maybe because I restarted the netbook in between.

Revision history for this message
Mircea (tramir) wrote :

Same here, lost all my tasks after a sync with RTM today. Using version 0.3-0~ubuntu114. Subsequent syncs seem to be successful, but the task list is still empty. Tried to close and restart GTG, deleted the rtm-sync folder, still no luck.

Revision history for this message
Joao Lencart e Silva (j-lencart) wrote :

Same problem with GTG 0.2.4 on opensuse 11.2.

Revision history for this message
Mircea (tramir) wrote :

The problem persists with version 0.3.0~ubuntu116. At this point, I can't sync with RTM at all, as it deletes all the tasks every single time (I backed up the .config and .local folders). I thought this was on RTM's side, so I deleted all tasks on RTM, deleted .local/share/gtg/plugins/rtm-sync/taskpairs, and did a sync. All went well, the tasks showed up in RTM and in GTG. Second sync: all tasks got deleted in GTG. More importantly, .local/share/gtg/plugins/rtm-sync/taskpairs is almost empty (attached). Maybe this can shed some light on what's going on?

Revision history for this message
Alan (alangsmello) wrote :

I've got the same problem here, so I looked through the code and noticed that there is a small error ocurring in line 102 of file 'rtmProxy.py': the itens of 'task_list_global' list are also lists, but with only one element (they were expected to be plain "dotted"s, instead).
If you change line 101 from "task_list_global= map(get_list_of_taskseries, lists_id_list)" to "task_list_global= map(lambda item: item[0] if type(item) == list and len(item) >= 1 else item, map(get_list_of_taskseries, lists_id_list))" the problem is solved. I think it's only a palliative solution (there must be an elegant way of dealing with this list!), but it's working well for now!

Revision history for this message
Joao Lencart e Silva (j-lencart) wrote :

@Alan:
Thanks Alan, that worked like a charm!
I got all my tasks back from RTM with all subcategories as supposed.

rtmProxy.py in my system is in:
/usr/lib/python2.6/site-packages/GTG/plugins/rtm_sync/rtmProxy.py

Revision history for this message
Vanessa Kovalsky (vanessa-kovalsky) wrote :

Hello,

I'v the same bug.
The ligne Alan gives correct this.
The file on my UNE 10.10 is in :
/usr/share/gtg/GTG/plugins/rtm-sync/
Thanks for the correction

Revision history for this message
charly (charlymr) wrote :

Thank's Alan!

It works like a charm!!

Revision history for this message
Luca Invernizzi (invernizzi) wrote :

Thanks a lot Alan! I've updated the PPA. It seems that RTM changed something in the API, since in about a week we've received tens of reports. A much improved way to sync with RTM (synchronizing in background when you're online) is in the pipeline: i think we'll be releasing it in August.

Changed in gtg:
assignee: nobody → Alan (alangsmello)
milestone: none → 0.3
importance: Undecided → Critical
status: New → Fix Committed
Revision history for this message
charly (charlymr) wrote : Re: [Bug 753327] Re: all tasks deleted after sync with RTM

Hi Luca!

Thank's for the information!

I think it would be a good idea to post on the GTG-homepage, that there
is a new version in the pipeline, because a lot of people will be
waiting for it and they will see that there is still development in GTG
- much do think, that there is no more improvement.

charly Mayrhofer
mobil: +43 676 5680104
mail to: <email address hidden>
mail to: <email address hidden>
ICQ: 360328306

Am 2011-04-19 09:22, schrieb Luca Invernizzi:
> Thanks a lot Alan! I've updated the PPA. It seems that RTM changed
> something in the API, since in about a week we've received tens of
> reports. A much improved way to sync with RTM (synchronizing in
> background when you're online) is in the pipeline: i think we'll be
> releasing it in August.
>
> ** Changed in: gtg
> Assignee: (unassigned) => Alan (alangsmello)
>
> ** Changed in: gtg
> Milestone: None => 0.3
>
> ** Changed in: gtg
> Importance: Undecided => Critical
>
> ** Changed in: gtg
> Status: New => Fix Committed
>

Revision history for this message
Luca Invernizzi (invernizzi) wrote :

Yep, I'll do that in a few days, when our Google Summer of Code
students will be announced.

On Tue, Apr 19, 2011 at 1:16 AM, charly <email address hidden> wrote:
> Hi Luca!
>
> Thank's for the information!
>
> I think it would be a good idea to post on the GTG-homepage, that there
> is a new version in the pipeline, because a lot of people will be
> waiting for it and they will see that there is still development in GTG
> - much do think, that there is no more improvement.
>
> charly Mayrhofer
> mobil: +43 676 5680104
> mail to: <email address hidden>
> mail to: <email address hidden>
> ICQ: 360328306
>
>
> Am 2011-04-19 09:22, schrieb Luca Invernizzi:
>> Thanks a lot Alan! I've updated the PPA. It seems that RTM changed
>> something in the API, since in about a week we've received tens of
>> reports. A much improved way to sync with RTM (synchronizing in
>> background when you're online) is in the pipeline: i think we'll be
>> releasing it in August.
>>
>> ** Changed in: gtg
>>       Assignee: (unassigned) =>  Alan (alangsmello)
>>
>> ** Changed in: gtg
>>      Milestone: None =>  0.3
>>
>> ** Changed in: gtg
>>     Importance: Undecided =>  Critical
>>
>> ** Changed in: gtg
>>         Status: New =>  Fix Committed
>>
>
> --
> You received this bug notification because you are subscribed to Getting
> Things GNOME!.
> https://bugs.launchpad.net/bugs/753327
>
> Title:
>  all tasks deleted after sync with RTM
>
> Status in Getting Things GNOME!:
>  Fix Committed
>
> Bug description:
>  I sync GTG (0.2.4. - official ppa on ubuntu 10.10) with RTM. This worked good until 3 days ago.
>  The sync deleted all my task! - I got them back after the next sync, but unsorted. I restructured them and synced again - no problem for the next day.
>  Today the sync deleted all tasks again and the sync is no longer working  it just starts syncing and then sys it is ready, without doing anything
>
>  The debug mode has no output, maybe because I restarted the netbook in
>  between.
>

Revision history for this message
Michael A. Phillips (maphilli14) wrote :

Thanks so much for this fix! Glad to have fine folks like you in the community!

Revision history for this message
Martin Marmolejo (martinianomarmolejo) wrote :

Thank you Alan!
Worked perfectly! Needed to restore some label colors and such but no biggie.

Revision history for this message
Tom Ellis (tellis) wrote :

Hitting this in the default 11.04 package, the proposed fix works well for me.

Thanks.

Changed in gtg:
milestone: 0.3 → 0.2.9
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtg (Ubuntu):
status: New → Confirmed
Izidor Matušov (izidor)
Changed in gtg:
status: Fix Committed → Fix Released
Changed in gtg (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtg - 0.2.9-1

---------------
gtg (0.2.9-1) unstable; urgency=low

  * New upstream release (Closes: #668096).
    - Implement a search text box (Closes: #650279).
    - Window title reflects active tasks (LP: #537096).
    - Fix misbehaviours of the indicator applet (LP: #548836, #676353).
    - Fix crash when selecting notification area plugin twice (LP: #550321).
    - Fix sorting of tasks by date (LP: #556159).
    - Fix excessive delays at startup (LP: #558600).
    - Fix crash with dates having unknown values (LP: #561449).
    - Fix crash issued when pressing delete key (LP: #583103).
    - Keep notification plugin enabled after logoff (LP: #617257).
    - Fix Hamster plugin to work with recent Hamster versions (LP: #620313).
    - No longer use non-unicode strings (LP: #680632).
    - New RTM sync mechanism (LP: #753327).
    - Fix crashes while handling XML storage file (LP: #916474, #917634).
  * debian/patches/*:
    - Drop all patches, they have been merged upstream.
  * debian/patches/shebang.patch:
    - Fix shebang line.
  * debian/patches/manpages.patch:
    - Fix some groff warnings in gtg_new_task man page
  * debian/compat:
    - Bump compatibility level to 9.
  * debian/control:
    - Bump X-Python-Version to >= 2.6.
    - Add python-liblarch and python-liblarch-gtk to Depends field.
    - Add python-cheetah, python-geoclue, python-gnomekeyring,
      python-launchpadlib and python-suds to Suggests field.
    - Bump Standards-Version to 3.9.3.
  * debian/copyright:
    - Refresh copyright information.
    - Format now points to copyright-format site.
  * debian/rules:
    - Make gtcli_bash_completion script executable.
  * debian/watch:
    - Update watch file.

 -- Luca Falavigna <email address hidden> Tue, 10 Apr 2012 23:08:21 +0200

Changed in gtg (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments