Right click on a task doesn't change the selection

Bug #604293 reported by Michael Martin-Smucker on 2010-07-11
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Low
Bryce Harrington

Bug Description

If a task is selected, right-clicking on a different task doesn't change the selection. For example:

Create "task 1" and "task 2." Left-click on "task 1" to select it. Now right-click on "task 2" to bring up the context menu. The selection stays with "task 1," so any actions you choose from the context menu will apply to "task 1," even though you specifically right-clicked on "task 2."

Obviously this is not a big problem, but it seems a little awkward to require an extra left-click before you can get to an item's context menu. This is also inconsistent with other GTK+ list views.

Using GTG 0.2.4 with Ubuntu 10.04.

Related branches

Luca Invernizzi (invernizzi) wrote :

This has been done to be able to do a multi-selection and then bring up the menu. Perhaps a better behavior can be decided. Proposals?

Changed in gtg:
milestone: none → 0.4
status: New → Incomplete
importance: Undecided → Low

Certainly multi-select and right-click-to-select can both work with a the menu, no? With Nautilus, Rhythmbox, etc, right-click moves the selection, but that doesn't prevent you from selecting multiple items and using right-click to interact with the whole group. But I haven't been using GTG for very long, so maybe its multi-select works differently, and I'm just not understanding...?

Luca Invernizzi (invernizzi) wrote :

Yes, we should mimic the common behavior in gnome.

Changed in gtg:
status: Incomplete → Confirmed
Changed in gtg:
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

It looks like in nautilus, when you select two files in the list view, and then right click on a third (unselected) file, it selects that file as well. So the menu clearly operates on three items in this case.

Bryce Harrington (bryce) on 2010-08-03
Changed in gtg:
assignee: nobody → Bryce Harrington (bryceharrington)
milestone: 0.4 → 0.3
status: Triaged → Fix Committed
Pititjo (jonathan-barnoud) wrote :

I was a little surprise by the behaviour of right clicking in the task treeview. It seem to be in purpose that when two task are selected, a right click on another one select the third task in addition of the two others.

But it's not the common behaviour in gnome. In nautilus or rhytmbox for example (but I think it is the same in every other gnome applications) when two items are selected and you right click a third one, the third one is selected and the two others are unselected so the action is applied only on the right clicked item.

Of course if you right click on one of the selected item the action is applied on the whole selection and no item is unselected.

So GTG's behaviour seem strange and is not consistent whith the rest of gnome. Perhaps this bug should be reopen.

Pititjo (jonathan-barnoud) wrote :

I just linked a branch witch change the right click behaviour to let him be consistent with the rest of gnome.

tags: added: toreview
Changed in gtg:
milestone: 0.3 → 0.2.9
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers