More simple way to discover dependencies for plugins

Bug #584667 reported by Gert on 2010-05-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Erin McLaughlin

Bug Description

Version: 0.2.4 from daily ppa

It took me quite a long time to figure out why the plugins were "grayed" in the plugin section. In my humble opinion having the user to click on the "about plugin" button is not the best way to indicate a missing dependency

Keep up the good work!

Related branches

Luca Invernizzi (invernizzi) wrote :

I agree. The "about plugin" should list the authors of the plugin, and a description, not why it's not working.
Right now I don't have any smart idea on how to change the UI to reflect that. Anyone?

Changed in gtg:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 0.3
tags: added: toreview
Gert (mar-rocca) wrote :

Just a "on the fly" idea, more a clarification than a solution.

How about adding a line above/below plugin description with a list of
missing dependencies?

example:

title:
Export and print

description:
Exports the tasks in the current view into
a variety of formats. You can also personalize the format
of your tasks by writing your own template
This plugin cannot be enabled without installing the following python
modules:
Cheetah

essentially moving this information from the about dialog to the
description, to make it visible.
I remember it took me weeks to find out why some plugins were grayed out. :D
It didn't occur to me to open the about dialog.

On Sun, May 23, 2010 at 8:02 PM, Luca Invernizzi <email address hidden>wrote:

> I agree. The "about plugin" should list the authors of the plugin, and a
> description, not why it's not working.
> Right now I don't have any smart idea on how to change the UI to reflect
> that. Anyone?
>
> ** Changed in: gtg
> Status: New => Confirmed
>
> ** Changed in: gtg
> Importance: Undecided => Medium
>
> ** Changed in: gtg
> Milestone: None => 0.3
>
> ** Tags added: toreview
>
> --
> More simple way to discover dependencies for plugins
> https://bugs.launchpad.net/bugs/584667
> You received this bug notification because you are a member of Gtg
> contributors, which is subscribed to Getting Things GNOME!.
>
> Status in Getting Things GNOME!: Confirmed
>
> Bug description:
> Version: 0.2.4 from daily ppa
>
> It took me quite a long time to figure out why the plugins were "grayed" in
> the plugin section. In my humble opinion having the user to click on the
> "about plugin" button is not the best way to indicate a missing dependency
>
> Keep up the good work!
>
>
>

Luca Invernizzi (invernizzi) wrote :

I think this bug will be made obsolete by https://bugs.edge.launchpad.net/gtg/+bug/591747

Izidor Matušov (izidor) on 2011-08-12
Changed in gtg:
milestone: 0.3 → 0.4
tags: added: ui
tags: added: love
Changed in gtg:
assignee: nobody → Erin McLaughlin (emclaughlin1215)

I requested a merge for this bug, which I hope I did right.

Izidor Matušov (izidor) on 2011-11-19
Changed in gtg:
milestone: 0.4 → 0.2.9
tags: removed: toreview
Changed in gtg:
status: Confirmed → Fix Committed
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers