Tomboy reference in a title stucks gtg burning CPU

Bug #584515 reported by François Pinard on 2010-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Low
Luca Invernizzi

Bug Description

When editing a task title (the first line), I inserted a Tomboy reference in there. The task window refuses to close, gtg then becomes unresponsive, and the CPU consumption raises a lot.

I then have to kill gtg and restart it. On restart, in the main window, the task shows with an explicit TOMBOY__ reference instead of the Tomboy icon followed by the note title. I may then edit the task and remove the Tomboy reference. If I keep it, closing the window again repeats the problem.

Another tiny problem, likely unrelated, is that a "T" prefix gets added to the Tomboy reference, once per visit and crash. So, after a while, I may get a string of "T"s to the left of the Tomboy icon.

This is gtg 0.2.4 as available on Ubuntu Lucid.

$ gtg -d
2010-05-23 06:25:45,099 - DEBUG - gtg:main:105 - Debug output enabled.
2010-05-23 06:25:46,308 - DEBUG - browser:on_task_added:1811 - Add task with ID: 0@1
2010-05-23 06:25:46,313 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-23 06:25:46,315 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 1@1
2010-05-23 06:25:46,316 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 2@1
2010-05-23 06:25:46,318 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 3@1
2010-05-23 06:25:46,319 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 4@1
2010-05-23 06:25:46,320 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 5@1
2010-05-23 06:25:46,320 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 6@1
2010-05-23 06:25:46,321 - DEBUG - browser:on_task_added:1811 - Add task with ID: 6@1
2010-05-23 06:25:46,330 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 6@1
2010-05-23 06:25:46,333 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-23 06:25:46,349 - DEBUG - browser:on_task_added:1811 - Add task with ID: 5@1
2010-05-23 06:25:46,351 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 5@1
2010-05-23 06:25:46,361 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-23 06:25:46,374 - DEBUG - browser:on_task_added:1811 - Add task with ID: 4@1
2010-05-23 06:25:46,376 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 4@1
2010-05-23 06:25:46,385 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-23 06:25:46,393 - DEBUG - browser:on_task_added:1811 - Add task with ID: 3@1
2010-05-23 06:25:46,406 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 3@1
2010-05-23 06:25:46,416 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-23 06:25:46,427 - DEBUG - browser:on_task_added:1811 - Add task with ID: 2@1
2010-05-23 06:25:46,431 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 2@1
2010-05-23 06:25:46,441 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-23 06:25:46,452 - DEBUG - browser:on_task_added:1811 - Add task with ID: 1@1
2010-05-23 06:25:46,463 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 1@1
2010-05-23 06:25:46,474 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-23 06:25:46,488 - DEBUG - browser:on_task_added:1811 - Add task with ID: 9@1
2010-05-23 06:25:46,492 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 9@1
2010-05-23 06:25:46,504 - DEBUG - browser:on_task_added:1811 - Add task with ID: 10@1
2010-05-23 06:25:46,513 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 10@1
2010-05-23 06:25:46,516 - DEBUG - browser:on_task_added:1811 - Add task with ID: 12@1
2010-05-23 06:25:46,523 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 12@1
2010-05-23 06:25:46,531 - DEBUG - browser:on_task_added:1811 - Add task with ID: 13@1
2010-05-23 06:25:46,533 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 13@1
2010-05-23 06:25:46,543 - DEBUG - browser:on_task_added:1811 - Add task with ID: 7@1
2010-05-23 06:25:46,545 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 7@1
2010-05-23 06:25:46,557 - DEBUG - browser:on_task_added:1811 - Add task with ID: 8@1
2010-05-23 06:25:46,571 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 8@1
2010-05-23 06:25:46,581 - DEBUG - browser:on_task_added:1811 - Add task with ID: 11@1
2010-05-23 06:25:46,590 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 11@1
2010-05-23 06:25:46,844 - DEBUG - browser:general_refresh:1865 - Trigger refresh on taskbrowser.
/usr/share/gtg/GTG/taskbrowser/browser.py:2005: GtkWarning: gtk_accel_group_activate: assertion `GTK_IS_ACCEL_GROUP (accel_group)' failed
  gtk.main()
^C^C^Z
[1]+ Stopped gtg -d
$ kill %1
$ kill -KILL %1

Changed in gtg:
status: New → Confirmed
assignee: nobody → Luca Invernizzi (invernizzi)
milestone: none → 0.3
importance: Undecided → Low
Izidor Matušov (izidor) on 2012-07-18
Changed in gtg:
assignee: Luca Invernizzi (invernizzi) → nobody
Izidor Matušov (izidor) wrote :

CPU burning was solved, at least I can't reproduce it anymore in rev. 1209. However, a reference in a title still behaves oddly. Rather than changing the title and bug description, I reported a new bug #1026065 for it and closing this bug as fixed.

Changed in gtg:
assignee: nobody → Luca Invernizzi (invernizzi)
status: Confirmed → Fix Committed
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers