'All tasks' count is wrong

Bug #583021 reported by Bryce Harrington on 2010-05-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Luca Invernizzi

Bug Description

The counts for 'All tasks' and 'Tasks with no tags' appears to be wildly off, and seem to be set to a different value each time the program is restarted with WorkView turned on. I've seen 233, 760, 494, and 405 reported, when gtg 0.2.x is (correctly, consistently) reporting 130 or so. The total number of tasks I have is some amount over 700.

The counts for the individual tag entries are all correct, it's just the two filter-based items that are inaccurate.

If I switch off Work View, it also reports incorrect numbers. It shows the total as 1143 when it should be in the 700's. Toggling WorkView on and off seems not to cause the numbers to recalculate, it just switches between 494 and 1143 or whatever.

Related branches

Bryce Harrington (bryce) wrote :

Interestingly, I notice the titlebar says "130 active tasks" which is the correct count. So GTG is calculating the correct number internally, just not displaying it properly where it should.

Bryce Harrington (bryce) wrote :

The title bar updates the count by calling:

        count = self.req.get_main_n_tasks()

Whereas the tagtree.py code is using this call:

        return self.active_workview_filtered_tree.get_nodes_count()

However we can't use get_main_n_tasks() here for a few reasons. First, it shows the total number of tasks being *displayed* so as you click on things the number varies and doesn't always reflect the All tasks count. Second, it's a routine that uses browser functionality, whereas we want tagtree.py to work independently of the browser. And third, it doesn't fix the notags case.

Bryce Harrington (bryce) on 2010-05-19
summary: - All tasks count is wrong
+ 'All tasks' count is wrong
Bryce Harrington (bryce) on 2010-05-19
tags: added: regression
Changed in gtg:
importance: Undecided → Medium
milestone: none → 0.3
Luca Invernizzi (invernizzi) wrote :

The call is correct. The problem is that filtered tree is messing up the nodes count.

Changed in gtg:
status: New → In Progress
assignee: nobody → Luca Invernizzi (invernizzi)
Luca Invernizzi (invernizzi) wrote :

All tasks count should now be correct. The "Tags with no tags" is still wrong, so it must be related to another bug.

Opened new bug #583330

Changed in gtg:
status: In Progress → Fix Committed
Changed in gtg:
milestone: 0.3 → 0.2.9
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers