Some plugins has zero-sized About Window

Reported by DmDr on 2010-05-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
High
Paulo Cabido

Bug Description

So, there are some steps to see the bug:
1. Call menu commands: Edit --> Preferences
2. Recall Modules Tab
3. Select any plugin
4. Click About_module button
5. See About window that has normal size
6. Press Close button in the this window (not at the window title-bar!)

7. Do steps 4, 5, 6 - all will be OK

8. Click About_module button
9. See About window that has normal size
10. Press close button AT THE TITLE-BAR
11.Click About_module button
12. See About window that has ZERO-SIZE (you can close it by system menu command)

13. Do steps 10, 11, 12 to repeat a problem

After restart GTG situation will be the same.

GTG 0.2.4 on Ubuntu Karmic.
When I press About Plugin button when some of plugins is selected (for example Notification area) new window have zero size. This window may be closed only by the xkill. In the debug mode there are:
/usr/lib/python2.6/dist-packages/GTG/taskbrowser/preferences.py:265: GtkWarning: gtk_label_set_markup: assertion `GTK_IS_LABEL (label)' failed
  pad.set_name(p.full_name)
/usr/lib/python2.6/dist-packages/GTG/taskbrowser/preferences.py:266: GtkWarning: gtk_label_set_markup: assertion `GTK_IS_LABEL (label)' failed
  pad.set_version(p.version)
/usr/lib/python2.6/dist-packages/GTG/taskbrowser/preferences.py:270: GtkWarning: gtk_widget_show: assertion `GTK_IS_WIDGET (widget)' failed
  pad.set_authors(authors)
/usr/lib/python2.6/dist-packages/GTG/taskbrowser/preferences.py:271: GtkWarning: gtk_label_set_text: assertion `GTK_IS_LABEL (label)' failed
  pad.set_comments(p.description.replace(r'\n', "\n"))
/usr/lib/python2.6/dist-packages/GTG/taskbrowser/preferences.py:271: GtkWarning: gtk_widget_show: assertion `GTK_IS_WIDGET (widget)' failed
  pad.set_comments(p.description.replace(r'\n', "\n"))
/usr/lib/python2.6/dist-packages/GTG/taskbrowser/preferences.py:273: GtkWarning: gtk_widget_show: assertion `GTK_IS_WIDGET (widget)' failed
  pad.show_all()
/usr/lib/python2.6/dist-packages/GTG/taskbrowser/preferences.py:273: GtkWarning: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
  pad.show_all()

Some other plugin's about window works properly without any debug messages.

Related branches

Changed in gtg:
milestone: none → 0.3
Lionel Dricot (ploum) wrote :

I cannot reproduce that bug in Lucid. Could you please give a step by step description to experience that bug?

Thanks.

Changed in gtg:
status: New → Incomplete
DmDr (cardioexp) wrote :

OK:
0. Start GTG
1. Call menu commands: Edit --> Setup
2. Recall Modules Tab
3. Select plugin Notifacation area
4. Click About_module button
5. See small, notresizeable window (marked red on the picture)

Additional information about my system:
> uname -a
Linux XXXXX 2.6.31-21-generic #59-Ubuntu SMP Wed Mar 24 07:28:27 UTC 2010 x86_64 GNU/Linux

> python --version
Python 2.6.4

DmDr (cardioexp) wrote :

It was reverse translation from Russian
1. Call menu commands: Edit --> Setup

The true variant is:
1. Call menu commands: Edit --> Preferences

Excuse me :-)

Luca Invernizzi (invernizzi) wrote :

Hmm... I cannot reproduce it either (which make it very difficult to fix). Has anybody else the same problem?

Hello!

2010/5/11 Luca Invernizzi <email address hidden>:
> Hmm... I cannot reproduce it either (which make it very difficult to
> fix). Has anybody else the same problem?

I can try to reproduce problem on an another computer (Ubuntu Lucid),
but in a few days.

--
DmDr

DmDr (cardioexp) wrote :

I need to do special research to discover a way to guaranteed reproduction of th bug. :-)
The results on the Ubuntu Lucid and Karmic are the same...

So, there are some steps to see the bug:
1. Call menu commands: Edit --> Preferences
2. Recall Modules Tab
3. Select any plugin
4. Click About_module button
5. See About window that has normal size
6. Press Close button in the this window (not at the window title-bar!)

7. Do steps 4, 5, 6 - all will be OK

8. Click About_module button
9. See About window that has normal size
10. Press close button AT THE TITLE-BAR
11.Click About_module button
12. See About window that has ZERO-SIZE (you can close it by system menu command)

13. Do steps 10, 11, 12 to repeat a problem

After restart GTG situation will be the same.

Those steps are the same on the Karmic and on the Lucid on 2 different computers.
Sorry for incomplete initial bug report.

Izidor Matušov (izidor) wrote :

I can confirm it, it really happens...

Changed in gtg:
status: Incomplete → Confirmed
importance: Undecided → High
description: updated
Paulo Cabido (pcabido) on 2011-11-26
Changed in gtg:
assignee: nobody → Paulo Cabido (pcabido)
Paulo Cabido (pcabido) on 2011-11-26
Changed in gtg:
status: Confirmed → In Progress
Izidor Matušov (izidor) on 2011-12-22
Changed in gtg:
status: In Progress → Fix Committed
milestone: 0.3 → 0.2.9
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers