plugin: task reaper automatic timer hangs gtg on quit

Bug #576901 reported by Sasha Shveik on 2010-05-07
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Luca Invernizzi

Bug Description

there aren't conf-files:
$ ls ~/.local/share/
desktop-couch gnome-do gvfs-metadata hamster-applet moonlight quadrapassel Trash vlc webkit

enter in the console:
$ /usr/bin/gtg

program window was not appear, and nothing was taken into the console, but...

process is appeared:
$ ps -ef | grep gtg
ap 31975 22648 0 13:36 pts/6 00:00:00 /usr/bin/python /usr/bin/gtg
ap 32607 32382 0 13:37 pts/7 00:00:00 grep --color=auto gtg

and conf-files is created:
$ ll ~/.local/share/gtg/
total 40
-rw-r--r-- 1 ap ap 11856 2010-05-07 13:36 0ce76e57-9542-4035-a903-a900837ad6ac.xml
-rw-r--r-- 1 ap ap 11856 2010-05-07 13:36 0ce76e57-9542-4035-a903-a900837ad6ac.xml.bak.0
-rw------- 1 ap ap 5 2010-05-07 13:36 gtg.pid
-rw-r--r-- 1 ap ap 133 2010-05-07 13:36 projects.xml
-rw-r--r-- 1 ap ap 133 2010-05-07 13:36 projects.xml.bak.0
-rw-r--r-- 1 ap ap 33 2010-05-07 13:36 tags.xml

additional info:
$ cat /etc/issue.net
Ubuntu 10.04 LTS
$ dpkg-query -s gtg
Package: gtg
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 3068
Maintainer: Ubuntu Developers <email address hidden>
Architecture: all
Version: 0.2.4-1ubuntu1
Depends: python (>= 2.5), python-support (>= 0.90.0), python-gtk2 (>= 2.14), python-gnome2, python-glade2, python-dbus, python-xdg, python-configobj
Description: organizer for the GNOME desktop environment
 Getting Things GNOME! is an organizer for the GNOME desktop environment.
 GTG focuses on usability and ease of use. Its main objective is to
 provide a simple and yet flexible organization tool for life and work.
Original-Maintainer: Luca Falavigna <email address hidden>
Homepage: http://gtg.fritalk.com/

Sasha Shveik (sasha-shveik) wrote :

and yet, the process is not killed:
$ ps -ef | grep gtg
ap 11670 32382 0 13:55 pts/7 00:00:00 grep --color=auto gtg
ap 31975 22648 0 13:36 pts/6 00:00:01 /usr/bin/python /usr/bin/gtg
$ kill 31975
$ ps -ef | grep gtg
ap 11912 32382 0 13:55 pts/7 00:00:00 grep --color=auto gtg
ap 31975 22648 0 13:36 pts/6 00:00:01 /usr/bin/python /usr/bin/gtg

Luca Invernizzi (invernizzi) wrote :

Since you use ubuntu could you create a temporary guest user (from the same menu from which you shut down your computer) and run gtg with the -d switch ("gtg -d"), posting here the output?

Changed in gtg:
status: New → Confirmed
milestone: none → 0.3
Sasha Shveik (sasha-shveik) wrote :

result under clean user:
2010-05-07 20:07:34,797 - DEBUG - gtg:main:105 - Debug output enabled.
2010-05-07 20:07:35,585 - DEBUG - browser:on_task_added:1811 - Add task with ID: 0@1
2010-05-07 20:07:35,586 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-07 20:07:35,587 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 1@1
2010-05-07 20:07:35,587 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 2@1
2010-05-07 20:07:35,587 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 3@1
2010-05-07 20:07:35,587 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 4@1
2010-05-07 20:07:35,588 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 5@1
2010-05-07 20:07:35,588 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 6@1
2010-05-07 20:07:35,588 - DEBUG - browser:on_task_added:1811 - Add task with ID: 6@1
2010-05-07 20:07:35,589 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 6@1
2010-05-07 20:07:35,591 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-07 20:07:35,592 - DEBUG - browser:on_task_added:1811 - Add task with ID: 5@1
2010-05-07 20:07:35,605 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 5@1
2010-05-07 20:07:35,607 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-07 20:07:35,608 - DEBUG - browser:on_task_added:1811 - Add task with ID: 4@1
2010-05-07 20:07:35,609 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 4@1
2010-05-07 20:07:35,613 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-07 20:07:35,615 - DEBUG - browser:on_task_added:1811 - Add task with ID: 3@1
2010-05-07 20:07:35,616 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 3@1
2010-05-07 20:07:35,617 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-07 20:07:35,620 - DEBUG - browser:on_task_added:1811 - Add task with ID: 2@1
2010-05-07 20:07:35,621 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 2@1
2010-05-07 20:07:35,622 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-07 20:07:35,625 - DEBUG - browser:on_task_added:1811 - Add task with ID: 1@1
2010-05-07 20:07:35,626 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 1@1
2010-05-07 20:07:35,628 - DEBUG - browser:on_task_modified:1828 - Modify task with ID: 0@1
2010-05-07 20:07:35,650 - DEBUG - browser:general_refresh:1865 - Trigger refresh on taskbrowser.

after the restart with the working user, the program correctly loaded with the launch of the operating system, which means that when you reinstall the program, not all settings have been removed, although I re-installed as follows:
sudo aptitude purge gtg
rm -rfv ~/.local/share/gtg/
sudo aptitude install -y gtg

Sasha Shveik (sasha-shveik) wrote :

now application correctly starts, but quit only as:
kill -9 <pid gtg>

Luca Invernizzi (invernizzi) wrote :

Settings are in .local/share/gtg , .config/gtg, and some plugins use .cache/gtg (which are standard directories, following the Freedesktop specifications).
It would be interesting to understand what caused that problem.

About the qutting problem, just to be clear, are you saying that selecting the Quit in the menu does not do anything (or ctrl+Q)?
Could you try to run

chmod -R u+rwx ~/.{local/share,config,cache}/gtg

and try running gtg again, to exclude it's a file permission problem?

Sasha Shveik (sasha-shveik) wrote :

I isolated this problem:
1. $ rm -rfv ~/.{local/share,config,cache}/gtg
2. $ sudo aptitude purge gtg
3. $ sudo aptitude install gtg
then the application starts and ends correctly.

Initial state: only the plugin "Closed tasks removed" is enabled with default settings.
step:
1. start gtg
2. menu "edit -> parameters"
3. tab "plugins"
4. select the plugin "Closed tasks removed"
5. click the button "Configure plugin"
6. set the flag "Delete tasks automatically"
7. click "ok"
8. close the dialog "parameters"
9. exit the application
result: gtg hangs.

if unset the flag "Delete tasks automatically", gtg correctly ends again.

Luca Invernizzi (invernizzi) wrote :

Thanks for isolating this bug! I believe it's caused by a timer that doesn't close nicely when the quitting signal is received. I'll look into this.

summary: - hangs at startup
+ plugin: task reaper automatic timer hangs gtg on quit
Changed in gtg:
assignee: nobody → Luca Invernizzi (invernizzi)
importance: Undecided → Medium
Luca Invernizzi (invernizzi) wrote :

I think I solved this one. The fix should be available in the daily PPA (https://edge.launchpad.net/~invernizzi/+archive/gtg-daily) in half an hour.

Please confirm that everything works fine now :)

Changed in gtg:
status: Confirmed → Fix Committed
Changed in gtg:
milestone: 0.3 → 0.2.9
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers