sorting of finished tasks is buggy

Bug #538643 reported by Michael Keppler on 2010-03-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Karlo Jež

Bug Description

When sorting finished tasks by their finished date, the sorting is buggy (as the order is neither ascending nor descending). This is version 0.2.4. I'm using a German locale, if that matters.

See attached screenshot

Michael Keppler (bananeweizen) wrote :
Changed in gtg:
status: New → Triaged
assignee: nobody → Luca Invernizzi (invernizzi)
importance: Undecided → Medium
milestone: none → 0.2.4
assignee: Luca Invernizzi (invernizzi) → nobody
Changed in gtg:
milestone: 0.2.4 → 0.3

On Sun, Mar 14, 2010 at 07:23:55AM -0000, Michael Keppler wrote:
> Public bug reported:
>
> When sorting finished tasks by their finished date, the sorting is buggy
> (as the order is neither ascending nor descending). This is version
> 0.2.4. I'm using a German locale, if that matters.

Confirmed; I've noticed this as well.

Karlo Jež (karlo-jez) wrote :

Column COL_CDATE is never displayed, but it is used for sorting. Because it is converted to readable string it is sorted by lexicographic order:

2 days ago
300 days ago
50 days ago
today
tomorrow
yesterday

Since COL_CDATE is not displayed, it does not have to be in readable form. This small patch removes to_readable_string() from the task date returned by func. on_get_value() for the column. It seems to fix the sorting problem.
I guess it would be possible to add a special column_id for sorting, but it seems unnecessary for now.

Luca Invernizzi (invernizzi) wrote :

I love when patches come in. Thanks!

Changed in gtg:
status: Triaged → Fix Committed
assignee: nobody → Karlo Jež (karlo-jez)
milestone: 0.3 → 0.2.4
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments