Allow selecting multiple tags in the sidebar

Bug #522971 reported by diegoe on 2010-02-17
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Wishlist
Unassigned

Bug Description

Currently the sidebar only allows selecting one tag at a time. It should be possible to select more than one. For example "urgent" and "thisweek" are a feasible scenario.

Changed in gtg:
importance: Undecided → Wishlist
milestone: none → 0.3
status: New → Confirmed
Luca Invernizzi (invernizzi) wrote :

Diego, thanks for the bug report.
I think this can be solved by the concept of "saved searches". See:
https://bugs.edge.launchpad.net/gtg/+bug/410822
and
https://bugs.edge.launchpad.net/gtg/+bug/487108

As such, I'm marking this at won't fix.
If anyone is against this, please reopen the bug.

Changed in gtg:
status: Confirmed → Won't Fix
DmDr (cardioexp) wrote :

It will be great functionality in GTG!
If compare functionality of multiple tags selection and complicated search mechanism the first is more simple and has natural interface for a man. So I vote for reopened this wish and do it. I think, that Ctrl+click in the tag panel have to select next tag. If multiple tags selected a user have to see tasks with ALL of selected tags In the Task list or Workview.

DmDr (cardioexp) wrote :

I can't to reopen this bug. :-(

Luca Invernizzi (invernizzi) wrote :

Let's see what the others think about this.

Changed in gtg:
status: Won't Fix → Incomplete
ricardofunke (ricardo-funke) wrote :

I agree with DmDr,

This functionality is very "KISS" from the point of view of the user. As DmDr said, it's natural for the user, as I tryed to do when I wanted to see the tasks that have more then one tag and be frustrated that it isn't do that.

I'm not against the search mechanism, but that functionality will be more useful IMHO.

So I vote to reopen this bug

Luca Invernizzi (invernizzi) wrote :

On second though, search and "multi-tag select" (have a better name?) are not mutually exclusive, and the second doesn't clutter the UI (which is a big plus).
The only thing I'm afraid of is that users may get a bit disoriented having two ways to do the same thing. I guess that someday we need to update our guide :-)
Anyway, bug is re-opened

Changed in gtg:
status: Incomplete → Confirmed
tags: added: discuss
François Pinard (fpinard) wrote :

I also think one should be able to select many labels at once, and than obtain a list of tasks simultaneously having all these tags.

This is a fairly common operation, it should be very easy to do. Ctrl-click would be a nice way to go, as a lot of other GNOME tools use this already.

Lionel Dricot (ploum) wrote :

I will implement this with a "AND" filter (meaning that a task has to have all tags to be displayed). It's easier, we might change to a OR if it seems to be better.

Changed in gtg:
assignee: nobody → Lionel Dricot (ploum)
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
milestone: 0.3 → 0.3.2
Izidor Matušov (izidor) on 2012-06-11
Changed in gtg:
assignee: Lionel Dricot (ploum) → nobody
Changed in gtg:
assignee: nobody → Alan Gomes Alvino (alangalvino)
Alan Gomes Alvino (alangalvino) wrote :

Hi I'm working in a solution for this feature.

Changed in gtg:
status: Confirmed → In Progress
Izidor Matušov (izidor) on 2012-07-18
Changed in gtg:
milestone: 0.3.2 → 0.4
Nimit Shah (nimit-svnit) on 2014-03-23
Changed in gtg:
status: In Progress → Confirmed
assignee: Alan Gomes Alvino (alangalvino) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers