RTM plugin: Tasks from archived (= semi-deleted) lists are also synced

Bug #520427 reported by Tom Van Braeckel on 2010-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Low
Luca Invernizzi

Bug Description

I started using GTG but noticed that about 300 tasks from a distant past appeared in GTG after syncing with RTM.
It turned out these tasks came from archived lists.

Archived lists are lists that are as good as deleted, but are kept around just in case you need them. This allows you to ressurect a list and have it back the way it was when you (almost) "deleted" it. They don't show up in searches unless you add includeArchived:true, and there is no way to search for *only* the archived tasks (which would allow me to mark them all as completed, even though that's not correct).

I propose not syncing tasks from archived lists, since they only cause confusion and clutter.
This should also speed up syncing, and in my case even double the speed.

Another solution would be to allow the user to configure whether or not to sync tasks from archived lists.

Related branches

description: updated
summary: - Tasks from archived (= semi-deleted) lists are synced
+ RTM plugin: Tasks from archived (= semi-deleted) lists are synced
summary: - RTM plugin: Tasks from archived (= semi-deleted) lists are synced
+ RTM plugin: Tasks from archived (= semi-deleted) lists are also synced

Fixing this in a branch, more details follow...

Luca Invernizzi (invernizzi) wrote :

Nice. I'll wait for your merge request.

tags: added: plugins
removed: plugin rtm
Changed in gtg:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Luca Invernizzi (invernizzi)
milestone: none → 0.3
Changed in gtg:
status: Confirmed → Fix Committed
Changed in gtg:
milestone: 0.3 → 0.2.2
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers