Create a cairo dock plugin

Bug #519915 reported by Chris Johnston on 2010-02-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Plug-ins
Wishlist
Unassigned
Getting Things GNOME!
Wishlist
Unassigned

Bug Description

Create a plugin to integrate gtg into cairo dock

Related branches

Changed in gtg:
status: New → Confirmed
importance: Undecided → Wishlist
milestone: none → 0.3
Paul Natsuo Kishimoto (khaeru) wrote :

I had no clue this project existed!

Bryce Harrington (bryce) wrote :

Does special code need to be added to gtg to enable it to be added to cairo dock? If not, perhaps this bug report should actually be filed against cairo dock?

Luca Invernizzi (invernizzi) wrote :

Considering that a Docky plugin already exists and that it just uses dbus calls, I don't think we'll need to do anything on our side.
If something has to be done, the cairo developer will file a bug against us.

I'm moving the bug to cairo-dock and changing the title accordingly.
Hello, cairo-dock developers!

Changed in gtg:
status: Confirmed → Invalid
Matthieu Baerts (matttbe) wrote :

Hello gtg developers :) !

What kind of plug-in do you want?
Does gtg have a complete documentation about its DBus API ?

BTW it's now easy to create plug-ins for Cairo-Dock with DBus signals ( http://www.glx-dock.org/ww_page.php?p=Control_your_dock_with_DBus&lang=en ) or with the help of CD-core API ( http://doc.glx-dock.org/ )

Matttbe for the Cairo-Dock team

Changed in cairo-dock-plug-ins:
importance: Undecided → Wishlist
Changed in cairo-dock-plug-ins:
status: New → Confirmed
Luca Invernizzi (invernizzi) wrote :

For the type of plugin wanted, Chris (the bug reporter) will most probably give out specifications.

Gtg does not have a complete documentation about its dbus api. A new gtg contributor is currently looking into writing some docs, so in the future we may have something.
You cairo-guys have a nice guide!

For the one who will implement this bug: have a look at GTG/core/dbuswrapper.py. For any question, there is (almost) always someone in #gtg in irc.gimpnet.org.

I'm ok to interface the dock with any application provided it has a stable
API.
Is gtg some sort of Tomboy enhancement ? from the name it seems to only work
for Gnome, although I couldn't guess why.

2010/2/23 Luca Invernizzi <email address hidden>

> For the type of plugin wanted, Chris (the bug reporter) will most
> probably give out specifications.
>
> Gtg does not have a complete documentation about its dbus api. A new gtg
> contributor is currently looking into writing some docs, so in the future we
> may have something.
> You cairo-guys have a nice guide!
>
> For the one who will implement this bug: have a look at
> GTG/core/dbuswrapper.py. For any question, there is (almost) always
> someone in #gtg in irc.gimpnet.org.
>
> --
> Create a cairo dock plugin
> https://bugs.launchpad.net/bugs/519915
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: Confirmed
> Status in Getting Things GNOME!: Invalid
>
> Bug description:
> Create a plugin to integrate gtg into cairo dock
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Luca Invernizzi (invernizzi) wrote :

Hi Fabounet. GTG API is pretty stable, we already have a lot of plugins.
GTG is a task manager: it manages smartly your TODO list. If you know any of: Tasque, Rememberthemilk.com, toodledo,com, google tasks , GTG has a similar focus.
It's not strictly intended for GNOME, it works fine without it. However, it is intended to use with GNOME (we have a tomboy plugin, for instance).
It has become fairly famous recently, we are regularly featured in open source blogs (e.g. http://www.omgubuntu.co.uk/search/label/gtg).
Try it! :-D

Fabounet (fabounet03) wrote :

ok I've tried it :)

first :
when you right-click on a task (the menu appears), the task window appears
as soon as you make the sub-menu appear.

second : since it really looks like Tomboy/Gnote, wouldn't it be a good
occasion to make some kind of unified DBus API ?
The audio players have made that (it's called MPRIS), and the result is a
much better and easier integration with all the tools like the docks and
panels.

last :
it could be good if Chris could develop a bit the kind of applet he's
expecting. Although I have an idea of what it would be, I don't know all the
possibilities of the program.

2010/2/23 Luca Invernizzi <email address hidden>

> Hi Fabounet. GTG API is pretty stable, we already have a lot of plugins.
> GTG is a task manager: it manages smartly your TODO list. If you know any
> of: Tasque, Rememberthemilk.com, toodledo,com, google tasks , GTG has a
> similar focus.
> It's not strictly intended for GNOME, it works fine without it. However, it
> is intended to use with GNOME (we have a tomboy plugin, for instance).
> It has become fairly famous recently, we are regularly featured in open
> source blogs (e.g. http://www.omgubuntu.co.uk/search/label/gtg).
> Try it! :-D
>
> --
> Create a cairo dock plugin
> https://bugs.launchpad.net/bugs/519915
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: Confirmed
> Status in Getting Things GNOME!: Invalid
>
> Bug description:
> Create a plugin to integrate gtg into cairo dock
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Luca Invernizzi (invernizzi) wrote :

thanks for the "first" comment, it's now fixed.
I'm not sure if we can adopt the same API as Tomboy. I'll look into it

Fabounet (fabounet03) wrote :

things like "get tasks", "create new task", "get task content", etc could be
mutualized.
moreover other programs doing task managing like your could also share a
common API.
for us, it's more interesting to suport many similar applications in a
single applet than having douzains of similar applets ^^

2010/2/23 Luca Invernizzi <email address hidden>

> thanks for the "first" comment, it's now fixed.
> I'm not sure if we can adopt the same API as Tomboy. I'll look into it
>
> --
> Create a cairo dock plugin
> https://bugs.launchpad.net/bugs/519915
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: Confirmed
> Status in Getting Things GNOME!: Invalid
>
> Bug description:
> Create a plugin to integrate gtg into cairo dock
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Luca Invernizzi (invernizzi) wrote :

I understand your concern and I agree with you, however the applications which could have some sort of common interface via dbus are not that many.
I checked all the projects I'm aware of, and it came down that only tomboy, tasque an us (For the records evolution (TODO tasks), pimlico tasks, Task Coach, gtodo, chandler, glista, sticky notes do not have a dbus interface).

Our focus is different from Tomboy's, but we can talk to the Tasque guys and find some kind of agreement. Thanks for pointing that out, I didn't think about that.

Fabounet (fabounet03) wrote :

a GTG plug-in is now functionnal, despite the lack of signals in the Dbus API of GTG.

Changed in cairo-dock-plug-ins:
status: Confirmed → Fix Committed
Izidor Matušov (izidor) on 2012-02-08
Changed in gtg:
milestone: 0.3 → none
Changed in cairo-dock-plug-ins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers