Error syncing with RTM when RTM has recurring tasks

Bug #516906 reported by Chris Johnston on 2010-02-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
High
Luca Invernizzi

Bug Description

This is after applying the update.. The error changed from the one you saw to:

** (gtg:4528): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
Exception in thread Thread-4:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/threading.py", line 477, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/share/gtg/GTG/plugins/rtm_sync/syncEngine.py", line 83, in synchronize
    self.synchronizeWorker()
  File "/usr/share/gtg/GTG/plugins/rtm_sync/syncEngine.py", line 137, in synchronizeWorker
    self.local_proxy)
  File "/usr/share/gtg/GTG/plugins/rtm_sync/syncEngine.py", line 229, in _process_new_tasks
    created_task.copy(task)
  File "/usr/share/gtg/GTG/plugins/rtm_sync/genericTask.py", line 41, in copy
    if self.status != task.status:
  File "/usr/share/gtg/GTG/plugins/rtm_sync/genericTask.py", line 59, in <lambda>
    status = property(lambda self: self._get_status(),
  File "/usr/share/gtg/GTG/plugins/rtm_sync/rtmTask.py", line 64, in _get_status
    return self.get_proxy()._rtm_to_gtg_status[self.task.task.completed\
AttributeError: 'list' object has no attribute 'completed'

Related branches

Changed in gtg:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Luca Invernizzi (invernizzi)
milestone: none → 0.3
Luca Invernizzi (invernizzi) wrote :

Fixed, but I cannot reproduce it.
It seems that the RTM server sometimes gives out list of tasks when asked for a single task.
I think this fix does not solve the overall problem, but until I understand what are the causes that trigger that behaviour I'm fixing bugs as you report them.
No help on the API doc either.

Changed in gtg:
status: Confirmed → Fix Committed
Changed in gtg:
milestone: 0.3 → 0.2.2
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers