"today" in due and start date columns

Bug #516387 reported by Luca Invernizzi on 2010-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Low
Luca Invernizzi

Bug Description

We have that if a date is tomorrow or next week is automatically converted to the string "tomorrow" and "next week".
Why don't we do the same for "today"?

Related branches

Changed in gtg:
status: New → Confirmed
importance: Undecided → Low
milestone: none → 0.3

That's strange, there's code supposed to do that:

            if dleft == 0:
                 return _("Today")

Somehow it doesn't work as expected.

Luca Invernizzi (invernizzi) wrote :

bug is caused by:
===
dleft = task.get_days_left()
if not dleft:
                return something
[..]
if dleft == 0:
                return _("Today")

===
if dleft is 0, not dleft is 1.

Changed in gtg:
status: Confirmed → Fix Committed
assignee: nobody → Luca Invernizzi (invernizzi)
Changed in gtg:
milestone: 0.3 → 0.2.2
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers