tag renaming shouldn't allow spaces

Bug #504366 reported by Luca Invernizzi on 2010-01-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Luca Invernizzi

Bug Description

step to reproduce:
- rename any tag to "hi mum"
tag renaming occours correctly
- open any task tagged with "hi mum"
the task contain the text "@hi mum"
- close the task
the taskeditor assumes that the tag has been renamed @hi because of the space.
Thus a new tag "hi" appear.

Related branches

Lionel Dricot (ploum) wrote :

simply converting space to underscore should be enough and user friendly, I think.

It should be really easy : in the tagstore.py, in Tag, just str.replace(" ","_") in the rename function. (no time to do it now)

Changed in gtg:
status: Confirmed → Fix Committed
assignee: nobody → Luca Invernizzi (invernizzi)
Lionel Dricot (ploum) wrote :

I don't see the fix. Forgot it ?

Luca Invernizzi (invernizzi) wrote :

You're right. I'm getting old.

Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers