Allow change of closing date

Bug #502111 reported by Muflone on 2010-01-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Wishlist
Unassigned

Bug Description

This bug has been marked as a "Love" bug, meaning it's a relatively easy bug which would be a perfect starting point for anybody willing to contribute. GTG dev will provide supports to anybody interested in doing this work (previous python experience is mandatory).

The proposed solution is to modify the bottom of closed tasks editor to display
"due date | |V| closing date | |V| the task was completed X days late|".

This involve moving the duedate calendar to the place of the startdate calendar and to make a way to modify the closingdate.
Also, the "XXX days left" string will be replaced by "closed on time" or "closed X days late".

The work takes place in TaskEditor/editor.py. There's no need to touch the glade file. In fact, as you can discover in the code, the same calendar widget is used but send a different signal depending on how it was open. You will have to had a new "closed date modified" signal and of course catch it.

This is a good introduction to the TaskEditor. It might be required to touch core/task.py to modify the closing date, which is a good way of learning GTG guts.

********** Original report :

The user should have the possibility to specify a different done/closed date.
The actual version 0.2 assumes always a closing date for today.

Change closing date will be useful for tasks completed on previous date which have not yet been marked as done.

Related branches

Luca Invernizzi (invernizzi) wrote :

In my personal view, the closing date is not an important information.
Currently, it is used only for internal calculations (as the modified date).
GTG focuses on simplicity, addressing the minimal set of features to be both useful and lean. To the casual user, I feel that it doesn't really matter when a task is closed. There was also a discussion on whether we should show only tasks closed in the near past in the closed task pane, to be both faster in loading tasks and keep some kind of sliding window in time.

I'm very interested in the opinion of others gtg devs (and not) on this.

Le vendredi 01 janvier 2010 à 18:35 +0000, Luca Invernizzi a écrit :
> In my personal view, the closing date is not an important information.
> Currently, it is used only for internal calculations (as the modified date).
> GTG focuses on simplicity, addressing the minimal set of features to be both useful and lean. To the casual user, I feel that it doesn't really matter when a task is closed. There was also a discussion on whether we should show only tasks closed in the near past in the closed task pane, to be both faster in loading tasks and keep some kind of sliding window in time.
>
> I'm very interested in the opinion of others gtg devs (and not) on this.
>

I agree with Luca. We don't need this feature in GTG's core. Perhaps in
a plugin.

Lionel Dricot (ploum) wrote :

Against that feature:

It seems to me not really important because, if you did something yesterday and mark it as done today, it's generally not really a big problem.

Could you propose an user interface that would allow this easily ?

in favour of tha feature:
Luca, Pitijo : what if closed tasks replace the (start date/due date) by a (due date/close date) combo? It makes sense, isn't it ? And it does not clutter the UI at all.

In fact, I think that this feature could be implemented very cheaply with no drawback (one drawback : you cannot set/see the start date of a closed tasks but it makes no sense anyway)

Luca Invernizzi (invernizzi) wrote :

That's a good solution.

Lionel Dricot (ploum) on 2010-01-07
Changed in gtg:
importance: Undecided → Wishlist
status: New → Confirmed
Bryce Harrington (bryce) wrote :

I am using gtg to generate a listing of the tasks I did over the past week for my required weekly status report for work. Often I need to add a status item for something I did on a previous day so it will be included in my status report. So being able to correct the closed date would have a usefulness in ensuring the status report is produced properly.

Lionel Dricot (ploum) on 2010-01-12
tags: added: love
Lionel Dricot (ploum) on 2010-01-12
description: updated
Benjamin Danon (sphax3d) on 2010-01-12
description: updated

I'd be happy to work on that, provided that nobody already started doing it.

Lionel Dricot (ploum) wrote :

Lionel > I assigned it to you, now, you don't have any excuse to not work on it ;-)

Changed in gtg:
assignee: nobody → Lionel Montrieux (lionel-montrieux)
Lionel Dricot (ploum) on 2010-02-03
Changed in gtg:
assignee: Lionel Montrieux (lionel-montrieux) → nobody
description: updated

Hey, I'm still on it. I've been incredibly busy with real-life things in January, which is why I haven't sent a patch yet. Will be done really soon (like, this week)

Fixed in the related branch. I still have to figure out how to update the po/pot files, though

Lionel Dricot (ploum) on 2010-02-10
Changed in gtg:
status: Confirmed → Triaged

I updated the pot file using the generate_potfile.sh script.
And merged with the current head on the main branch.

Changed in gtg:
status: Triaged → Fix Committed
Lionel Dricot (ploum) on 2011-08-13
Changed in gtg:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
assignee: nobody → Lionel Montrieux (lmontrieux)
milestone: none → 0.2.9
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers