check access to .config/gtg/tasks.conf'

Bug #500707 reported by eoard on 2009-12-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Low
Luca Invernizzi

Bug Description

FIGURED IT OUT:
IOError: [Errno 13] Permission denied: '/home/user/.config/gtg/tasks.conf'
For some reason i didnt have correct file permissions there. The issue also caused cpu spike when editing tasks, and occasionally made gtg unresponsive.

Maybe gtg should check permissions for such files, and if they aren't correct alert the user to prevent such issues.

ISSUE:
1/ Start GTG
2/ Deselect notification are and tomboy plugins (currently selected).
(notification area icon disappears, and plugins seem to be disabled)
3/ quit gtg
4/ start gtg. the disabled plugins are now enabled

UPDATE: if i check any, they are unchecked after restart. so, basically plugin enablings/disablings work only until quit, when they are lost and default back to tomboy, and notifications for some reason.

Possibly could have something to do with gtg quiting improperly at some point?

gtg 0.2

im not sure how to figure out how to reproduce it with debugging data. first time reporting a bug and i have a feeling i did it wrong. :P

eoard (neonfloss) on 2009-12-27
description: updated
eoard (neonfloss) on 2009-12-27
description: updated
eoard (neonfloss) on 2009-12-27
Changed in gtg:
status: New → Invalid
description: updated
Luca Invernizzi (invernizzi) wrote :

Hi eoard, thanks for the bug report, and also for finding its solution :-)
I've changed the title and marked the bug as new again, since this issue on file accessibility should be addressed.

summary: - plugins reselected after restart
+ check access to .config/gtg/tasks.conf'
Changed in gtg:
status: Invalid → New
importance: Undecided → Low
milestone: none → 0.2.1
tags: removed: plugin
Changed in gtg:
status: New → Fix Committed
assignee: nobody → Luca Invernizzi (invernizzi)
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers