text after the cursor is deleted when creating the first subtask

Bug #500034 reported by Jeff Fortin Tam on 2009-12-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Lionel Dricot

Bug Description

In the bzr version, in the task editor, under the task title, type this: "- banana mango potato"

Then, place the text cursor between mango and potato, and press Enter.

Result:
- banana mango becomes a subtask (as expected)
- potato is deleted

Instead, potato should also become a separate subtask.

Confirmed in rev496

Changed in gtg:
status: New → Confirmed
importance: Undecided → High
milestone: none → 0.2.1
Lionel Dricot (ploum) on 2009-12-25
Changed in gtg:
assignee: nobody → Lionel Dricot (ploum)
Lionel Dricot (ploum) on 2010-01-01
Changed in gtg:
importance: High → Medium
Lionel Dricot (ploum) wrote :

fixed in rev. 523

Changed in gtg:
status: Confirmed → Fix Committed
Jeff Fortin Tam (kiddo) wrote :

Not completely fixed. It doesn't take into account the case when you're "not yet in a list" (see attached bunch of screenshots)

Changed in gtg:
status: Fix Committed → In Progress
Lionel Dricot (ploum) wrote :

It is fixed, exactly as you described it and it works for me, it becomes

- banana mango
- potato|

be sure to do bzr pull lp:gtg

Changed in gtg:
status: In Progress → Fix Committed
Kevin Mehall (kevin-mehall) wrote :

I also tried it and it looks fixed. I get 2 separate subtask links and no deleted text.

Actually, you're right, this is fixed. I did do "bzr pull", but for some
reason, it only pulled the metadata and had not actually updated the
tree... I just did "bzr update" and now it works. Oh well.

Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers