Copy-paste subtask in same task weird behavior

Bug #499608 reported by fonji on 2009-12-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Lionel Dricot

Bug Description

Following of bug #496680
You can get weird behavior if you copy-paste a subtask line in a same task.

Steps to reproduce:
Create a task with the following content:
test
- sub-test
-

then select like this: http://img690.imageshack.us/img690/1821/capturetest.png
Copy and paste without changing the selection.
Expected behavior: text unselected, no modification of task.
GTG's behavior: got a few different results from the exact same actions, here's an example:
http://img15.imageshack.us/img15/4479/capturetest1.png
and another one:
http://img10.imageshack.us/img10/5791/capturetest2.png

Hope this helps.

Lionel Dricot (ploum) on 2010-01-07
Changed in gtg:
assignee: nobody → Lionel Dricot (ploum)
importance: Undecided → Medium
milestone: none → 0.2.1
status: New → Confirmed
tags: added: taskeditor
Lionel Dricot (ploum) wrote :

Fix committed in rev. 526

This is not perfect because of bug #493335

Changed in gtg:
status: Confirmed → Fix Committed
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers