Second click on a task's calendar brings drag'n'drop cursor

Bug #495446 reported by mati on 2009-12-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Lionel Dricot

Bug Description

GTG 0.1.99

To reproduce:
1. Double click a task to open it.
2. Click an arrow and then select some start (or due) date.
3. Click the arrow second time and move the mouse.

Result:
You will get a strange cursor, like in attachement.

Related branches

mati (mati-wroc) wrote :
Lionel Dricot (ploum) wrote :

Thanks a lot! I've seen this behaviour a few times but was enable to reproduce it. Your step-by-step is really helpful.

Changed in gtg:
importance: Undecided → Medium
status: New → Confirmed
milestone: none → 0.3
Lionel Dricot (ploum) wrote :

It looks like we hide the following is happening :

- We hide the calendar when a date is seclected (mouse press event, date-selected signal)
- We don't catch the mouse released signal (because calendar is hidden and thus cannot catch any X event)
- When we show the calendar, it thinks that the mouse button is still pressed and initiate a drag-n-drop

My proposed solution is to close the calendar on mouse released event, not on day-selected. It would be a more elegant behaviour and solve this bug.

Lionel Dricot (ploum) wrote :

This is fixed in the linked branch (I also discovered and fixed a small bug and removed some dead code).

Unfortunatly, this will not make it in the 0.2 release but I hope to merge it to the trunk just after the release.

Changed in gtg:
status: Confirmed → In Progress
assignee: nobody → Lionel Dricot (ploum)
Lionel Dricot (ploum) on 2009-12-16
Changed in gtg:
status: In Progress → Fix Committed
Lionel Dricot (ploum) on 2009-12-20
Changed in gtg:
milestone: 0.3 → 0.2.1
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers