RTM plugin uploads dates one day before

Bug #493176 reported by gsmx on 2009-12-06
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
High
Luca Invernizzi

Bug Description

When synchronising a task that is eg due December 9th 2009, via the rtm webinterface this task is shown as December 8th 2009.

Luca Invernizzi (invernizzi) wrote :

Thanks for the bug report. It seems that I can't reproduce that behavior.
Could you please check that you system timezone (get it clicking on the clock applet in Gnome, or via the command line with "date +%::z") is the same as the one in RTM (on the web interface, click on settings in the upper right corner and scan the page for Timezone).

Changed in gtg:
importance: Undecided → High
assignee: nobody → Luca Invernizzi (invernizzi)
milestone: none → 0.2
Changed in gtg:
status: New → Triaged
gsmx (gsmx) wrote :

The webinterface and my system timezone have the same setting.

Luca Invernizzi (invernizzi) wrote :

That's odd. I tried with different settings and lots of task but I can't reproduce this bug.
It's really hard to fix a bug I'm not experiencing, so I'm asking if you or someone else experiencing it can give me a series of steps to reproduce it. I understand that it could not be easy.

Changed in gtg:
status: Triaged → Incomplete
Changed in gtg:
milestone: 0.2 → 0.3
Changed in gtg:
milestone: 0.3 → none
jean-luc menut (jeanluc-menut) wrote :

Same problem here (ubuntu karmic and gtg 0.2 installed via the ppa).

«I'm asking if you or someone else experiencing it can give me a series of steps to reproduce it.»

There is not much to do : when synchronizing to RTM, a task define in gtg is set 1 day before in RTM. When the task is defined primarly on RTM, there is no problem (except that you cannot modify the date of the task with GTG but I suppose it is the right behavior)

Changed in gtg:
status: Incomplete → Confirmed
Changed in gtg:
status: Confirmed → In Progress
Changed in gtg:
milestone: none → 0.3
status: In Progress → Fix Committed
Changed in gtg:
milestone: 0.3 → 0.2.2
Changed in gtg:
status: Fix Committed → Fix Released
[BlockDog] (blockdog) wrote :

Getting Things Gnome! 0.2.3

Still got the problem: adding task in GTG with 2010-03-15 due date, and after syncing it appears in RTM with 2010-03-14 due date...

Changed in gtg:
status: Fix Released → Incomplete
emgsilva (godsiem) wrote :

Hi, I using the latest version of GTG (0.2.4) and I also came across this problem... I got it in different computers, all using Ubuntu. This is very annoying and makes the system impossible to use, since it changes all the dates and mixes everything, it looks like it changes the dates several times after I synch with RTM. Are you still looking at this issue?

Luca Invernizzi (invernizzi) wrote :

I understand this is quite annoying but I haven't been able to reproduce it so far. I'm planning to review the plugin in the next couple of months to port it to the new GTG infrastructure, so I'll look into it.

I'd like some data, though.
- what timezone is set on your pc? you can run "date %z"
- what timezone is set on the RTM website? it can be seen in the settings.

Mario (diraimondo) wrote :

Same problem: fresh new task in GTG with expiration date (for example) on 10/05/2010. Sync. In RTM on the web: 09/05/2010. :(

- timezone on the RTM website: (GMT +01:00) Europe/Rome;
- 'date +%z' output: +0200

The timezone in my ubuntu is set on Europe/Rome.

Luca Invernizzi (invernizzi) wrote :

I guess it has to do something with daylight savings (+1 != +2).

emgsilva (godsiem) wrote :

First, I verified that both timezones are set in the same timezone (GMT +01:00 Europe/Amsterdam). There is a funny thing though, that is when I use the command "date +%::z" it prints "+02:00:00", when it should only be +01:00:00... Anyway, I don't think this can be the source of the problem...

Then I tried to make several tests, changing some of the properties I think that may influence this weird behaviour... and I found some very strange things. Here you have the sequence of actions on my tests:

-------------------

TIMEZONE Amsterdam
START GTG
ADD new task in GTG "Amsterdam TEST" due date 1/6/2010
SYNC
- Date in RTM goes to 31/05/2010
CHANGE DATE in task RTM to 2/6/2010
SYNC
- Date in GTG is not updated
CHANGE (not updated) DATE in GTG to 5/6/2010
- Date in RTM is changed to 4/6/2010 (one day before the day set in GTG)
(At this moment I have the appointment in 5/6/2010 in GTG and 4/6/2010 in RTM)
QUIT GTG

TIMEZONE change to GMT/London in both systems
START GTG
ADD new task in GTG "London TEST" due date 1/6/2010
SYNC
- Date in RTM is kept in 1/6/2010!!!
CHANGE DATE in task RTM to 2/6/2010 (The previous appointment (Amsterdam TEST) date in RTM changed to 5/6/2010! it looks like GTG uploads again the task with the GTG date)
SYNC
CHANGE DATE in GTG to 5/6/2010
- Date in RTM is in fact changed to 5/6/2010!
(At this moment we have both "London TEST" and "Amsterdam Test" with due date as they should 5/6/2010
QUIT GTG

TIMEZONE change to Amsterdam
START GTG
SYNC
- Both appointments dates in RTM are changed from 5/6/2010 to 4/6/2010
ADD in GTG "Amsterdam TEST 2" due date 1/6/2010
SYNC
- Date in RTM goes to 31/05/2010

TIMEZONE change to Berlin
START GTG
SYNC
- In RTM all the appointments keep the same dates
ADD in GTG "Berlin TEST" due date 1/6/2010
SYNC
- Date in RTM goes to 31/05/2010
QUIT GTG

TIMEZONE in RTM GMT/London and in GTG to GTM/London (time in local machine set to not us time server... so I can use the GMT timezone but still have a correct time in my machine)
START GTG
ADD in GTG "Amsterdam TEST 3" due date 1/6/2010
SYNC
- All RTM dates are set correctly!!!
CHANGE date in RTM
SYNC
- Date in GTG is updated!

-------------------

I am still not completely sure how I should interpret these results... but somehow this is only working when I set both times to GMT/London...

However, this is very weird, since I am also using another tool to manage my tasks (Tasque) and it manages to be consistent with RTM even in other timezones...

Another thing I noticed is that the Synchronisation button does not work every time I try to synchronise with RTM... I am not sure whether this is due to GTG or the fact I am trying to do this very often and RTM tries to control the number of accesses...

In conclusion it seems that with this setup it works... but it is a bit strange, since I have to change my timezone to a different one... Any idea why this works this way?

Luca Invernizzi (invernizzi) wrote :

First of all, thanks for all your tests, so nicely documented.
I made a fix to the plugin that surpasses all your tests correctly. It seems that everything is fine now.
Since you've been so through, would you mind testing it?
To get it, execute

sudo aptitude install bazaar
bzr branch lp:gtg/0.2 gtg
./gtg

And again,thank you. This kind of bug reports make a developer life much easier :-)

Luca Invernizzi (invernizzi) wrote :

Missing one command:

sudo aptitude install bazaar
bzr branch lp:gtg/0.2 gtg
cd gtg
./gtg

Changed in gtg:
status: Incomplete → In Progress
emgsilva (godsiem) wrote :

Very nice to ear that my tests were useful! I will keep bothering with more tests in the future :p

Here you have my "crash" test to the new version:

-------------------

TIMEZONE Amsterdam (in RTM and GTG)
START GTG
ADD new task in GTG "Amsterdam TEST" due date 20/5/2010
SYNC
- Date in RTM Stays 20/05/2010!!! :)
CHANGE DATE in task RTM to 21/05/2010
SYNC GTG
- Date in GTG is updated!!! :)
CHANGE DATE in GTG to 22/05/2010
- Date in RTM is changed to 22/05/2010!!! :)
QUIT GTG (and happy since all the tests succeeded!!)

-------------------

Right now I don't have time to go through the other tests I made before... but I think this test proves that the weird error (with the timezones) is not happening any more! :) Thank you very much, I hope you can include this fix soon in the next release! I will keep testing it, and if I find some other issue I will report it...

Cheers!

Changed in gtg:
status: In Progress → Fix Committed
milestone: 0.2.2 → 0.3
emgsilva (godsiem) wrote :

Hi,

I am not sure if this problem is related with this "bug", but I got this in continuation of this bug... I have just downloaded this version in my second computer (using the bazaar commands above), and I cannot get the GTG-RTM plugin to work... I get a message saying "The plugin can not be loaded. Unknown error while loading the plugin..."

I thought this had something to do with some changes you have made since I downloaded on the other machine, so I copied the version in the other machine, but I get the same problem... any ideas why I get his error? How can I download the latest version for ubuntu, if it already has this fix...?

Thank you!

Luca Invernizzi (invernizzi) wrote :

It seems you're missing some dependencies. I'm uploading the newest version to the PPA (https://edge.launchpad.net/~gtg/+archive/ppa) right now. It should be available in half an hour or so.

emgsilva (godsiem) wrote :

Hi,

I still get the same behaviour, RTM plugin cannot be activated, after I upgrade to the newest version (0.3~karmic4developersubuntu102)... If I force the previous version (0.3~karmic4developersubuntu100, which still had the weird date behaviour) the RTM plugin still works, I get the same error as in the previous post.

I also tried to clean all the possible previous configurations/data (removing the files in .local/gtg and .config/gtg), and installing a 'fresh' gtg from the repository... but no luck, the same behaviour, RTM plugin cannot be activated...

This is very weird since I only get this error in one of the two machines I am working... In both machines I am testing GTG I have ubuntu 10.04... one of them I just installed it and another I do upgrades since 2007, so it has many more things installed, such as python libraries/packages, which may be causing this different behaviour. Both systems are 64 bits.

Any thoughts on this?

Any ways, the new ubuntu package is working very nicely in the system that is not giving me the activation error, so people can install it from the repository (https://edge.launchpad.net/~gtg/+archive/ppa, daily buils).

Cheers!

Luca Invernizzi (invernizzi) wrote :

Since you have ubuntu, could you try to create a temporary guest account (from the menu from which you shut down your computer) and see if the plugin runs fine? That way, we can see if it's due to some configurations which interferes with GTG or is caused by missing dependencies.

emgsilva (godsiem) wrote :

I tried, but the same happens... so, the RTM cannot be activated :(

It is very strange since if I install the version 0.3~karmic4developersubuntu100 the RTM plugin is activated, but still it has the bug... Do you use some new python libraries or something like that in the newer versions? I suspect it has something to do with this...

Any other ideas? Thank you!

Luca Invernizzi (invernizzi) wrote :

Try installing python-dateutil. I think I forgot to add it as dependency.

emgsilva (godsiem) wrote :

:)
That was the one missing! Everything is now up and running!
Thank you again, and keep up with the good work!
Cheers!

Changed in gtg:
milestone: 0.3 → 0.2.9
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers