About window crashes gtg

Bug #476119 reported by chab on 2009-11-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
High
Luca Invernizzi

Bug Description

Hi,
I download the last version few hours ago using bzr.
First remarks : In the Help / About window the version showed is the 0.1.2-dev and not the 0.2, is it normal ?
Secondly GTG crashed doing it :
1. Launch GTG
2. Open the Help / About window where you can see the GTG version
3. Press the [Esc] key to close this windows
4. Try to re-open the about window and GTG will crash :

/home/pc49/Escritorio/tmp/gtg/GTG/taskbrowser/browser.py:1014: GtkWarning: gtk_widget_show: assertion `GTK_IS_WIDGET (widget)' failed
  self.about.show()
/home/pc49/Escritorio/tmp/gtg/GTG/taskbrowser/browser.py:1014: GtkWarning: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
  self.about.show()
/home/pc49/Escritorio/tmp/gtg/GTG/taskbrowser/browser.py:1014: GtkWarning: gtk_link_button_set_uri: assertion `GTK_IS_LINK_BUTTON (link_button)' failed
  self.about.show()
/home/pc49/Escritorio/tmp/gtg/GTG/taskbrowser/browser.py:1014: GtkWarning: gtk_button_set_label: assertion `GTK_IS_BUTTON (button)' failed
  self.about.show()
Fallo de segmentación

By using the "close" button of the about windows everything works fine.
It's not a so critical bug, but it's never nice to see a software crashed without reason.

Related branches

Changed in gtg:
status: New → Confirmed
assignee: nobody → Luca Invernizzi (invernizzi)
Luca Invernizzi (invernizzi) wrote :

You're right. I've fixed it in lp:~gtg-user/gtg/about_window_crash_fix . Will be in trunk in the next few days (or you can check out that via "bzr branch lp:~gtg-user/gtg/about_window_crash_fix").
Thanks for the report.

Changed in gtg:
status: Confirmed → Fix Released
status: Fix Released → Confirmed
Luca Invernizzi (invernizzi) wrote :

By the way, which is the correct bug status now? Every project seem to handle this differently (there is even a bug for that https://bugs.edge.launchpad.net/malone/+bug/163694).

Changed in gtg:
status: Confirmed → In Progress
chab (chab-chab) wrote :

thanks for this quick fix, it works well now.
what about the version level, is normal that it is the 0.1.2-dev and not the 0.2 ?

Luca Invernizzi (invernizzi) wrote :

I believe they'll change that when the 0.2 is released. Anyway, for a real answer you'll have to wait that the developers wake up, since they're mostly European.

Changed in gtg:
importance: Undecided → High
milestone: none → 0.2

Hey Luca, *you are* a GTG developer now ;-)

So I let you merge your fix yourself. If there's any question or problem, just ask me by mail, jabber (same address) or IRC.

Changed in gtg:
status: In Progress → Fix Committed
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers