Rename a tag

Bug #384263 reported by Progi1984 on 2009-06-06
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!

Bug Description

Add support in liblarch for renaming tags and support in editor for changing tags name

Changed in gtg:
importance: Undecided → Medium
milestone: none → 0.2
status: New → Confirmed
Lionel Dricot (ploum) on 2009-09-25
Changed in gtg:
milestone: 0.2 → 0.3
Lionel Dricot (ploum) on 2009-12-20
Changed in gtg:
milestone: 0.3 → 0.2.1
Lionel Dricot (ploum) wrote :

mmm, it seems that we have to add editing capability to our CellRendererTags. Is it easier to subclass directly CellRenderer instead of GenericCellRenderer?

Kevin Mehall (kevin-mehall) wrote :

Isn't it the CellRendererText that needs to be edited? The CellRendererTags is just the color square next to the tag.

Yes, CellRendererTags just displays a square. CellRendereText already
has mechanisms for in-place text edition.

On Tue, Dec 22, 2009 at 4:28 AM, Kevin Mehall <email address hidden> wrote:
> Isn't it the CellRendererText that needs to be edited? The
> CellRendererTags is just the color square next to the tag.
> --
> Rename a tag
> You received this bug notification because you are subscribed to Getting
> Things GNOME!.

Bertrand Rousseau

Lionel Dricot (ploum) on 2009-12-22
Changed in gtg:
assignee: nobody → Lionel Dricot (ploum)
status: Confirmed → In Progress
Lionel Dricot (ploum) wrote :

fixed in rev. 491

Changed in gtg:
status: In Progress → Fix Committed
Lionel Dricot (ploum) on 2010-01-27
Changed in gtg:
milestone: 0.2.1 → 0.3
status: Fix Committed → In Progress
Karlo Jež (karlo-jez) wrote :

I added a context menu item that opens a rename dialog. It seems to work for me.

Lionel Dricot (ploum) wrote :

Hi Karlo,

We don't want a menu. Simply editing the tag in the treeview is enough. In fact, this feature is already implemented but was disabled due to a bug. We should re-enable it.

So this is going to be working on 0.3 right?

Lionel Dricot (ploum) wrote :

Fixed in rev. 381 (still doesn't work for opened tasks. This should be a separate bug)

Changed in gtg:
status: In Progress → Fix Committed
Thibault Févry (thibaultfevry) wrote :

[Trunk: Not working; PPA: works]

 I can't rename a task anymore, seems it's liblarch that introduced the bug as i didn't have that in the ppa version.

Changed in gtg:
status: Fix Committed → New
tags: added: regression
Lionel Dricot (ploum) on 2010-09-13
Changed in gtg:
status: New → Triaged
Yuriy Voziy (yuretsz) wrote :

Tried to apply: Karlo Jež's patch : no luck

Daily ppa version

Izidor Matušov (izidor) on 2011-08-12
Changed in gtg:
milestone: 0.3 → 0.4
Changed in gtg:
milestone: 0.4 → 0.3
Changed in gtg:
status: Triaged → Confirmed
Lionel Dricot (ploum) on 2012-08-06
Changed in gtg:
milestone: 0.3 → 0.4
Izidor Matušov (izidor) on 2012-11-02
Changed in gtg:
status: Confirmed → Triaged
assignee: Lionel Dricot (ploum) → nobody
description: updated
tags: added: editor liblarch
removed: regression

NB: the tag editor already has support for tag renaming, it just waits for liblarch to provide the necessary API to be enabled.

Forage (forage) wrote :

I would love to have this, though unfortunately it is not functioning for 0.3.1. Is it still waiting for liblarch after more then a year now? You might want to disable the text extry field in the tag editor for the time being since it causes confusion now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers