GTG

Package for Jaunty (python 2.6)

Bug #336678 reported by Lionel Dricot
4
Affects Status Importance Assigned to Milestone
GTG
Medium
Unassigned

Bug Description

Can we have the launchpad doing the build without installing Jaunty ourselves ?

Changed in gtg:
assignee: nobody → ploum
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

A package for Jaunty had been added to the PPA :

https://edge.launchpad.net/~gtg/+archive/ppa

thibaut > could you test it please ? You are the only one I know that is running Jaunty ;-)

Revision history for this message
antistress (antistress) wrote :

it works for me, thanks

I've seen that GTG is in Utility/Accessories menu (Accessoires in french)
i wonder if it would fit better in Utility/Accessories or Office ?

Revision history for this message
antistress (antistress) wrote :

the installation was successful but i get that message when trying to launch gtg :

Impossible de lancer l'application
L'exécution du processus fils « /usr/bin/gtg » a échoué (Aucun fichier ou dossier de ce type)

Note that i had former formerly installed GTG from Tarballs with # python setup.py install command

However keying F2 to launch "gtg" works

Revision history for this message
antistress (antistress) wrote :

~$ which gtg
/usr/local/bin/gtg

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

For an unknown reason, the Jaunty package put all in /usr/local so your old /usr/bin/gtg symlink from the previous installation would not work. (except if /usr/bin/gtg is hardcoded in some place)

Revision history for this message
antistress (antistress) wrote :

how can i delete the old installation ?

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

There's no uninstallation that I now with setup.py. You have to remove file by hands.
/usr/share/applications/gtg.desktop
/usr/lib/gtg
/usr/share/gtg
/usr/bin/gtg

Can you tell me how you got the error that you cannot launch /usr/bin/gtg ?

Revision history for this message
antistress (antistress) wrote :

by clicking GTG icon in the Applications menu which pointed to /usr/bin/gtg
i've changed it for /usr/local/bin/gtg with Alacarte

Uninstalling gtg with Synaptic removed all these files
Reinstalling gtg with Synaptic works fine
Launcher in Application is /usr/local/bin/gtg %F and everythings works as expected

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

The package is valid, then. Thanks for testing :-)

Changed in gtg:
status: Confirmed → Fix Released
Revision history for this message
antistress (antistress) wrote :

It seems that a few icons are missing when right-clicking on a task (see screenshot)

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

That's fixed with 0.1 package. Thanks for the information :-)

Revision history for this message
antistress (antistress) wrote :

with new version (0.1) :

~$ which gtg
/usr/bin/gtg

therefore the entry in Application menu> Accessoires was wrong again ! i had to manually change it

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

It's because you manually changed it before so it was not updated with the package. If you remove gtg then reinstall it you will not have this problem.

Revision history for this message
antistress (antistress) wrote :

indeed.

Note that synaptic doesn't display the application screenshot but maybe it's not possible with PPA ?

Revision history for this message
antistress (antistress) wrote :

i've fount that
Debian/Ubuntu only: Get screenshots from screenshots.debian.net
http://www.nongnu.org/synaptic/

Revision history for this message
antistress (antistress) wrote :

How does this website work?

This is a public repository of screenshots taken from applications contained in the Debian GNU/Linux distribution. It was created to help getting an impression of what a certain software will look like on your desktop before you install it. Everybody can take screenshots and upload them. Our admin team will just review your changes before they become publicly visible.
http://screenshots.debian.net/

Revision history for this message
antistress (antistress) wrote :

i'm filling a separate bug about that

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers