GTG

Translation infrastructure

Bug #336624 reported by Lionel Dricot on 2009-03-02
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GTG
High
Bertrand Rousseau

Bug Description

We should allow localization of GTG. We currently suck...

Changed in gtg:
importance: Undecided → Medium
milestone: none → 0.2
status: New → Confirmed
Romeo A. Cioaba (romeo-cioaba) wrote :

i'm using poedit to translate .po files

Pierre Slamich (pierre-slamich) wrote :

To automate the process, it would need to wait though. Automatic import of translations into LP from the pot file in code is not implemented yet.
https://answers.edge.launchpad.net/rosetta/+question/63574

French translation

Changed in gtg:
assignee: nobody → comzen91
status: Confirmed → In Progress
assignee: comzen91 → nobody
status: In Progress → Confirmed
Changed in gtg:
importance: Medium → High
Changed in gtg:
milestone: 0.2 → 0.1.1

Right now, the infrastructure is built in GTG.

1) All translatable strings in the code should be "gettextified" -> "string" becomes _("string")

2) generatepot.sh script will then generate a .pot file will all the translatable strings.

3) The .pot file should be uploaded on Launchpad (or translated using any tool you want)
(Warning : the upload could take 24h hours)

4) Once a translation is complete, you can download from Launchpad a .po and a .mo
- The .po is human-readbe and should be put in /locales for GTG distribution
- The .mo should be put in its subfolder in /locales and is used for testing purpose. It should not be distributed as it is compiled from the .po file during installation by setup.py (To be tested)

In order for this bug to be closed :

1) Most strings should be textified with _() (the remaining should be reported as bugs)
2) generatepot.sh should be modified to take care of the strings in Glade file (see pygtk FAQ and learningpython blog for example)
3) The .pot file should be uploaded to Launchpad

./generate_potfile.sh has been updated to take glade files into account
Added _() around strings in source code

Changed in gtg:
status: Confirmed → Fix Committed
Alexey Kostyuk (unitoff) wrote :

Hello!
How do I get this sh file?

On Sat, Mar 28, 2009 at 8:02 AM, Alexey Kostyuk <email address hidden> wrote:
> Hello!
> How do I get this sh file?

This file is in the root directory of the source code. However, if you
want to translate the application, you should rather use this page:
https://translations.launchpad.net/gtg

> --
> Translation infrastructure
> https://bugs.launchpad.net/bugs/336624
> You received this bug notification because you are a member of Gtg
> developers, which is the registrant for gtg.
>
> Status in Getting Things GNOME!: Fix Committed
>
> Bug description:
> We should allow localization of GTG. We currently suck...
>

--
Bertrand Rousseau
Place communale 1, 1450 Chastre, Belgium
e-mail : <email address hidden>
tel : +32 485 96 69 86

Changed in gtg:
assignee: nobody → bertrand-rousseau
IC Raibow (icrbow) wrote :

> To automate the process, it would need to wait though.
> Automatic import of translations into LP from the pot file in code is not implemented yet.

The time is now (:

https://dev.launchpad.net/Translations/BazaarIntegrationTutorial

Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers