Multiple selection and action on tasks

Bug #321880 reported by Bertrand Rousseau on 2009-01-27
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Luca Invernizzi

Bug Description

We should be able to select multiple task on the task list and perform an action on them (ex: delete/marking as done several tasks in one step)

Changed in gtg:
importance: Undecided → Medium
status: New → Confirmed
Changed in gtg:
milestone: none → 0.3
Changed in gtg:
status: Confirmed → In Progress
assignee: nobody → Luca Invernizzi (invernizzi)
Changed in gtg:
status: In Progress → Fix Committed
Jeff Fortin Tam (kiddo) wrote :

Seems to work. Some quick feedback and questions:
- some users might want to drag multiple tasks onto a tag to tag them. It could be nice to add that.
- any reason why multiple selections don't work in the "Closed tasks" pane?

Jonathan Lange (jml) wrote :

Doesn't work for me.

I can now select multiple items, but I cannot do anything with them. Whenever I right-click, only a single item is selected. Even though bug 497218 was marked as a duplicate of this bug, there's no way of tagging multiple items at once.

Luca Invernizzi (invernizzi) wrote :

You're right, multiple tagging has not been implemented yet. I think kevin is looking into it. However, it does work: multiple removal, mark as done and dismiss via the toolbar buttons.
 It's not working for the right mouse button menu, so I'll open a bug for that

Changed in gtg:
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Lionel Dricot (ploum) on 2009-12-20
Changed in gtg:
milestone: 0.3 → 0.2.1
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers