Gnome applet

Bug #319152 reported by Lionel Dricot on 2009-01-20
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Wishlist
Luca Invernizzi

Bug Description

We should have a GTG gnome applet. This applet would allow to open the taskbrowser, to create a new task and display a list of tasks that you can open immediatly without having to launch the taskbrowser.

By default, the list of displayed tasks will be the same than tasks "All tags - Workview" (the task immediatly actionnable). This could be configurable to be filtered with tags.

Changed in gtg:
importance: Undecided → Wishlist
Changed in gtg:
status: New → Confirmed
Changed in gtg:
milestone: none → 0.2

Maybe an option to appear in the systray - that would make it supported on other desktops e.g. xfce, kde ect..

There is no such thing as a systray under Gnome. It's a notification area. Applications using it as a systray are abusing it and are in clear violation of the HIG. That's why we want to develop an applet.

Romeo A. Cioaba (romeo-cioaba) wrote :

+1 for applet

"There is no such thing as a systray under Gnome. It's a notification area. Applications using it as a systray are abusing it and are in clear violation of the HIG. That's why we want to develop an applet."

That's why I suggested an option - I meant in addition to an applet. The problem with a gnome applet is that you can't use it easily on other DEs but a systray (for those who use it as such) option will work on all DEs which implement one.

I think it would be a perfect plugin example when we will have a plugin system (Bertrand want to do that). But don't hold your breath, it's not in our current top priorities ;-)

(So much idea, so little time !)

On Sun, Mar 8, 2009 at 6:41 PM, Lionel Dricot <email address hidden> wrote:
> I think it would be a perfect plugin example when we will have a plugin
> system (Bertrand want to do that). But don't hold your breath, it's not
> in our current top priorities ;-)

I agree about this: this is exactly the kind of thing that would fit a
plugin. Maybe we could develop some plugins and provide a "default"
package with the applications, like gedit does. That way users would
easily find be able to activate such features without encumbering the
default UI, wich aims to be simple, and still provide advanced
features for users who an them (and don't bother for the -slight-
increase in complexity it implies).

> (So much idea, so little time !)
>
> --
> Gnome applet
> https://bugs.launchpad.net/bugs/319152
> You received this bug notification because you are a member of Gtg
> developers, which is the registrant for gtg.
>
> Status in Getting Things Gnome!: Confirmed
>
> Bug description:
> We should have a GTG gnome applet. This applet would allow to open the taskbrowser, to create a new task and display a list of tasks that you can open immediatly without having to launch the taskbrowser.
>
> By default, the list of displayed tasks will be the same than tasks "All tags - Workview" (the task immediatly actionnable). This could be configurable to be filtered with tags.
>

--
Bertrand Rousseau
Place communale 1, 1450 Chastre, Belgium
e-mail : <email address hidden>
tel : +32 485 96 69 86

Walter Leibbrandt (walterl) wrote :

The applet vs. tray icon issue seems to boil down the gnomeapplet module (python-gnome2-desktop package) vs. the egg.trayicon module (python-gnome2-extras package). Both of them have their pro's and cons.

For a proper ("official") Gnome applet, the gnomeapplet module should be used. The cons about using gnomeapplet is that it's a bit more difficult than egg.trayicon, but the (much) more important con is that it will unusable without having root access. It will also be more difficult to debug. These problems are because of the requirements of Bonobo activation server.

The egg.trayicon.TrayIcon class is simpler to use (just like any other widget) and no Bonobo issues. Cons:
* Adds a package dependency, python-gnome2-extras, if it's not required already
* Doesn't feel like the Right Way (tm) to do it. Lionel, just for interest sake, could you point me to the part of the HIG where the panel is define (if that's the right word)?

Come to think of it, they are completely different, aren't they? A Gnome applet can be placed anywhere on a panel, but the tray icon only lives in the Gnome notification area.

I would very much like to implement this, if you like.

Hey Walter,

Here's the link :
http://developer.gnome.org/projects/gup/hig/2.0/desktop-notification-area.html

Anyway, don't you find your sentence a bit odd : "the tray icon only lives in the Gnome notification area". Repeat after me : notification area ;-)

As your are pointing out, developing an applet is harder and that's why people use the tray. This is really bad because we are decreasing user experience and HMI quality for the sake of lazyness. This is *really bad* ! The solution is of course to fix the gnome-panel to get rid of this awful bonobo stuffs.

Because I'm developping for users and not to make the job easy, I will not accept code that add a tray icon, even optionnaly.

If we have a plugin system, it would be different. A tray plugin would be perfect because it would mean that the tray code is completely independant.

I should really take the time to exlain this issue more on my blog because I understand it's a bit unusual. But generally, people agree with the idea if I have the time to explain the details and the reasons.

Walter Leibbrandt (walterl) wrote :

I definitely agree with you that egg.trayicon is the lazier way and bad, but my bigger concern is that a Gnome applet does not use the notification area. At least not in the examples that I've seen (so far).

So the question becomes whether the notification area is the important part or not.

What does that make NetworkManager? It seems to be an applet, but is in the notification area. :/

As a side note I see that Tasque uses a Gtk.StatusIcon (Mono Gtk bindings) which is shown in the notification area. I have no idea what the equivalent in the Python bindings is, though.

Changed in gtg:
milestone: 0.2 → 0.3
mati (mati-wroc) wrote :

For the record, ideas from my duplicate bug:

1. It should be possible to quickly mark a task as done without opening main (or task) window. The menu layout could be as this:

Main window
-- (separator)
Create new task
--
v Task 1
v Task 2
...
v Task 10

That way the GUI would be less cluttered and user could quickly mark task as done and go to the next one, maintaining her workflow.

2. When main window isn't shown, user doesn't see the count of active task. There could be possibility to display that number as an applet icon. I imagine having images (scalable svgs for panels with increased height?) with numbers from 1 to 30 that could be used for it. That way user should be more focused on the tasks left :)

Luca Invernizzi (invernizzi) wrote :

@mati: your idea has been partially implemented, see attached screenshot.
I don't really get the gnome applet - status icon question. Can we close this bug, since we have a notification icon?

Paul Natsuo Kishimoto (khaeru) wrote :

Jono Bacon has apparently coded an application indicator plugin that may land on Thursday: http://www2.bryceharrington.org:8080/drupal/node/106

...if that is very servicable, maybe there is not much need to also have an applet.

mati (mati-wroc) wrote :

I don't know about "application indicator" thing (is it used only by Ubuntu?), but I found an illustration of displaying a number along the icon:
-example 1: http://3.bp.blogspot.com/_FJH0hYZmVtc/S2Bn2O6o9iI/AAAAAAAAFkI/805z14aMSvQ/s1600-h/Screenshot-2.png (see that "1813")
-example 2: http://2.bp.blogspot.com/_FJH0hYZmVtc/S2LqYHi1abI/AAAAAAAAFko/w1vFcteeTyM/s1600-h/4311371318_48705d1818_o.png ("7", kind of ugly font :) )

It could be used in notification area/application indicator area/gnome applet and whatever gtg uses :)

Luca Invernizzi (invernizzi) wrote :

I guess that, since we have a application indicator plugin, we can close this bug.
I'm still confused about the advantages of a gnome-applet, so feel free to reopen if this doesn't make sense

Changed in gtg:
assignee: nobody → Luca Invernizzi (invernizzi)
status: Confirmed → Fix Committed

I still fail to see the difference between the indicatior and the "tray". ;-)

But anyway, I don't believe we will actually write an applet. It would be better to concentrate on integration with gnome-shell

Changed in gtg:
milestone: 0.3 → 0.2.9
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Bug attachments