Task title column width is growing when typing the task body

Bug #317469 reported by Bertrand Rousseau on 2009-01-15
2
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
High
Unassigned

Bug Description

When you create a new task, and you start to type the description, the column width of the task title increase as the texte grows.

More precisely, when the text is long enough to reach the column width, each new letter pushes the column limit a bit more to the right.

The column width should not change while typing since, generally the user decide to set in a convenient way.

Related branches

Changed in gtg:
importance: Undecided → Low
status: New → Confirmed
Changed in gtg:
importance: Low → High
milestone: none → 0.1rc

fixed in rev.125

Changed in gtg:
assignee: nobody → ploum
status: Confirmed → Fix Released

Actually it was growing because of the descriptive text (at least, I
think so). Now that the extended view is disabled,, it doesn't grow
anymore.

On Tue, Jan 27, 2009 at 11:02 PM, Lionel Dricot <email address hidden> wrote:
> fixed in rev.125
>
> ** Changed in: gtg
> Assignee: (unassigned) => Lionel Dricot (ploum)
> Status: Confirmed => Fix Released
>
> --
> Task title column width is growing when typing the task body
> https://bugs.launchpad.net/bugs/317469
> You received this bug notification because you are a member of Gtg
> developers, which is the registrant for gtg.
>
> Status in Getting Things Gnome!: Fix Released
>
> Bug description:
> When you create a new task, and you start to type the description, the column width of the task title increase as the texte grows.
>
> More precisely, when the text is long enough to reach the column width, each new letter pushes the column limit a bit more to the right.
>
> The column width should not change while typing since, generally the user decide to set in a convenient way.
>

--
Bertrand Rousseau
Place communale 1, 1450 Chastre, Belgium
e-mail : <email address hidden>
tel : +32 485 96 69 86

No, it was growing even without that view if you typed a very long title.
It's not the case anymore thanks to my one-line fix which does not look
related at all ;-)

> Actually it was growing because of the descriptive text (at least, I
> think so). Now that the extended view is disabled,, it doesn't grow
> anymore.
>
> On Tue, Jan 27, 2009 at 11:02 PM, Lionel Dricot <email address hidden> wrote:
>> fixed in rev.125
>>
>> ** Changed in: gtg
>> Assignee: (unassigned) => Lionel Dricot (ploum)
>> Status: Confirmed => Fix Released
>>
>> --
>> Task title column width is growing when typing the task body
>> https://bugs.launchpad.net/bugs/317469
>> You received this bug notification because you are a member of Gtg
>> developers, which is the registrant for gtg.
>>
>> Status in Getting Things Gnome!: Fix Released
>>
>> Bug description:
>> When you create a new task, and you start to type the description, the
>> column width of the task title increase as the texte grows.
>>
>> More precisely, when the text is long enough to reach the column width,
>> each new letter pushes the column limit a bit more to the right.
>>
>> The column width should not change while typing since, generally the
>> user decide to set in a convenient way.
>>
>
>
> --
> Bertrand Rousseau
> Place communale 1, 1450 Chastre, Belgium
> e-mail : <email address hidden>
> tel : +32 485 96 69 86
>
> --
> Task title column width is growing when typing the task body
> https://bugs.launchpad.net/bugs/317469
> You received this bug notification because you are a bug assignee.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers